summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ros/gencpp/Manifest1
-rw-r--r--dev-ros/gencpp/gencpp-0.6.0.ebuild19
2 files changed, 20 insertions, 0 deletions
diff --git a/dev-ros/gencpp/Manifest b/dev-ros/gencpp/Manifest
index 8f89f6215d60..6fc901fef256 100644
--- a/dev-ros/gencpp/Manifest
+++ b/dev-ros/gencpp/Manifest
@@ -1 +1,2 @@
DIST gencpp-0.5.5.tar.gz 8601 BLAKE2B c048ce73f41d8b9ef3111bcb00b9a8776f4b1498bf4828e48ec45994c4f0fecfc75318fcfbfddd18b492d7b597e62e69fd497de63b6cc1417a107e11ecf38e83 SHA512 6440747ba98b23ed515db6d7b6760a98dcb3f832f87c0a8d3797b47c48e51cb01e2c62837ff5a84a2f8aeff16764493093170d83639602e3d82de846e95f9f8a
+DIST gencpp-0.6.0.tar.gz 9164 BLAKE2B 97b7e3904cde95ca6304e498d5f338cf303a55c407c187994b3dcb2bb062bd6dc1b4a2ab6f0cc949bfc6c481199586abef115fe54b4b99e99bc99dac8ae261cf SHA512 0ef0ae3d5f93ab5693455eb5319a0b8fbaab4ee56bd890e0ef96bfbdf8959affe61551f30739bab7e945c213c9b2fb51ff5e89c5b3a40d945da23e1ba88b9c1e
diff --git a/dev-ros/gencpp/gencpp-0.6.0.ebuild b/dev-ros/gencpp/gencpp-0.6.0.ebuild
new file mode 100644
index 000000000000..e33fa4486006
--- /dev/null
+++ b/dev-ros/gencpp/gencpp-0.6.0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/gencpp"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+
+inherit ros-catkin
+
+DESCRIPTION="ROS C++ message definition and serialization generators"
+HOMEPAGE="http://wiki.ros.org/gencpp"
+LICENSE="BSD"
+SLOT="0/${PV}"
+IUSE=""
+
+RDEPEND="dev-ros/genmsg[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"