summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-portage/repoman/Manifest1
-rw-r--r--app-portage/repoman/repoman-2.3.7.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/app-portage/repoman/Manifest b/app-portage/repoman/Manifest
index aa2827fc5805..52f25ab072ab 100644
--- a/app-portage/repoman/Manifest
+++ b/app-portage/repoman/Manifest
@@ -3,3 +3,4 @@ DIST repoman-2.3.0.tar.bz2 75285 BLAKE2B 980fadf2247869358f76f6708117b8a9591763e
DIST repoman-2.3.3.tar.bz2 78045 BLAKE2B 5c2e770af3ba0c93ce24c710fb32e8b9d937ad8dcb75cdd6461721163d012937c14745f248543bd2dafe154b649100aba1cb626c0de3bb47294d053bb19bd3a8 SHA512 17212c19b14817a8a004619dd56ad557457d45919da45edfb27538304e68187fe1104f0b6ccc2b29fa1709645a7a82c75676b118b20d79dc790b0eb2ebf5a2ce
DIST repoman-2.3.4.tar.bz2 78764 BLAKE2B 0fb6bd75463fe10dd41ab1fcdfd0857341dbe973e796f2f97e636df2c29dd633d7199eb22b4605b34d6e56624ac5a75f4783ff7119c421e2303aacf7adae4877 SHA512 1a434eea6361cc06ba3c27ccd31aa02875af1a577860490f8de666b0160370f09d1c46cea95d577163845e12c5672486b176c0009c32e735e16752d67bf4d96c
DIST repoman-2.3.6.tar.bz2 78961 BLAKE2B c11953ced4d6bcd5e6e6a5b2dacb8802446f3acfd1842854b33fa8c0a64fa636a0b278b4fd3010b7070a7e2f00ae841ea331925ca20175e7c7e571082195d3d1 SHA512 490078d4621073e448d037373617911093bc4c3262961c4da00f201f880069c0b70c019abd86c15954ff0c547b0ea49434ee97cd972c2baff82f7cfed1a987b3
+DIST repoman-2.3.7.tar.bz2 80514 BLAKE2B 9342b5be35523f1eb597c94ad33425fd9f1bc81cf7b48c0194d96d2afc2cc27962e9cfbea14492c5e16856c79ab6429988201b269ef0444c17c6d91c9c11feaa SHA512 9caeb06cfe55e38566154923b785c1e3053722b50d7423241950b73c810781d111848e64815001abe218e6073a96ca462debdc99acc05123987cf4d4be0a0420
diff --git a/app-portage/repoman/repoman-2.3.7.ebuild b/app-portage/repoman/repoman-2.3.7.ebuild
new file mode 100644
index 000000000000..51f20a852af7
--- /dev/null
+++ b/app-portage/repoman/repoman-2.3.7.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+PYTHON_REQ_USE='bzip2(+)'
+
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/portage.git"
+ S="${WORKDIR}/${P}/repoman"
+else
+ SRC_URI="https://dev.gentoo.org/~zmedico/portage/archives/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="Repoman is a Quality Assurance tool for Gentoo ebuilds"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Portage"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=sys-apps/portage-2.3.25[${PYTHON_USEDEP}]
+ >=dev-python/lxml-3.6.0[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+python_test() {
+ esetup.py test
+}
+
+python_install() {
+ # Install sbin scripts to bindir for python-exec linking
+ # they will be relocated in pkg_preinst()
+ distutils-r1_python_install \
+ --system-prefix="${EPREFIX}/usr" \
+ --bindir="$(python_get_scriptdir)" \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --htmldir="${EPREFIX}/usr/share/doc/${PF}/html" \
+ --sbindir="$(python_get_scriptdir)" \
+ --sysconfdir="${EPREFIX}/etc" \
+ "${@}"
+}
+
+pkg_postinst() {
+ einfo ""
+ einfo "This release of repoman is from the new portage/repoman split"
+ einfo "release code base."
+ einfo "This new repoman code base is still being developed. So its API's"
+ einfo "are not to be considered stable and are subject to change."
+ einfo "The code released has been tested and considered ready for use."
+ einfo "This however does not guarantee it to be completely bug free."
+ einfo "Please report any bugs you may encounter."
+ einfo ""
+}