summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-libs/motif/Manifest2
-rw-r--r--x11-libs/motif/motif-2.3.5.ebuild115
2 files changed, 117 insertions, 0 deletions
diff --git a/x11-libs/motif/Manifest b/x11-libs/motif/Manifest
index dbb640ebb8ee..05b50f803a70 100644
--- a/x11-libs/motif/Manifest
+++ b/x11-libs/motif/Manifest
@@ -1,4 +1,6 @@
DIST motif-2.3.4-patches-1.tar.xz 1776 SHA256 b5c9a0d026202c488a95b24beaefc63139b0cd30084af66da4247117c8c2d1e6 SHA512 f6773e0d7720adff8b5225025a682d12a4a60465c2a49d26df29daf7f8d7891f68b7ad3e284ff5cc73938ec4c78ed27216f9304f35905267b28c33f6d29b5666 WHIRLPOOL e677f210513dbb2ce68bffa0662443e232b2515c7796165cfe66e6c15cf765a9477362ba1d9ce42ef606c351df6e342063733fde907995d0954a10929ebacad1
DIST motif-2.3.4-src.tgz 9527040 SHA256 637efa09608e0b8f93465dbeb7c92e58ebb14c4bc1b488040eb79a65af3efbe0 SHA512 fb1033caa68f25b93282fa6700d5b7856be217b3651072d86e7c93a747df5b31219230998eb93deae22a8fa698e816b1a30e52b3ae88ae1c01c1f0aac59a2af2 WHIRLPOOL 9e4447fb1ac09a41cd6c61af52584f42fee3d026874bc15e258bc79f239f95a21bb3fe79ed7df08d86aaac370a669ec83cacc9eadb11320fbad6df6c27715d95
+DIST motif-2.3.5-patches-1.tar.xz 1408 SHA256 7c3e8fd55397e99c319652d1054156d4e62528f71cf85986417e20b5da66fef5 SHA512 cb157630f0c301e0cb6e5d17668486db41d90cf540ced234c96742e0ec7258fb2596a349a84db9fd4ac621f3cd019cdd89cdadce596a70ea1dec91cc69dd3351 WHIRLPOOL dccc460ec7eb00114470445caed7c92814d1b64b29338d5f2e57064fe71f198bc8d6eae45c702d4d20c3b6e6b6c9efb050fd639bf4481cf8770f112f6461eb59
+DIST motif-2.3.5.tar.gz 6035803 SHA256 afc5c93c03327a7207f5822c272aaf0d98439007aa85a23149f833ba24916d25 SHA512 6c489409c8ac9d61da6aa916fde5b306d9175d329269885d1f8253f035c33b5b78e75e82178276538a84a6bd76f23c2fa31b40326ea0d00391c6e23afbcd1663 WHIRLPOOL 600e8ddd120447a9f71ad3ab4bd7b10f15b7a770cf289f1083a528dae79e4f08c8d1ffea1e7b04af43d25442cb117f0b9e0ee119cbcba360995c9609006f67b5
DIST openMotif-2.2.3.tar.gz 5149785 SHA256 12fc0d1de53ff30307603e31826db9b63a442f6f743451aed2cb7cedb038d3d9 SHA512 322381faf50bde6bbd2253f1b52a25e5471df87a2b01fba4de7e0d1bb4c1267e2b0d358e13e1b924a60d9e85316959fa6b2be5a458964d03f47a936bb618eae8 WHIRLPOOL 970f3f20eefde787af9fa932dcbf77e870ca6ba248e2632c358bbb7d149c2c4fef31a33a64888bc2b2e891f1c66a803a12e1121378539a94599e0be753c04bad
DIST openmotif-2.2.3-patches-5.tar.xz 19972 SHA256 69e1b1e37023ce0aa65c1aa8bdb60a6b2ead3472df26f1d10bffae7386b24c35 SHA512 62c0489d1bda83952e1c8d39e8c8fe0ee5a4d2927f9139227cb80b2c58751d63d95b70fff3eb165219e75cdfdc299f92d90482124e6334a28781a13b174786c9 WHIRLPOOL e2f8abc439d25d631b8489e1007788e931ea4982957d50e0e3e1062b76a3d37b279140f30bac95ab378a76cc33d5a49c1c217a66c441959510d9a96d7409d4af
diff --git a/x11-libs/motif/motif-2.3.5.ebuild b/x11-libs/motif/motif-2.3.5.ebuild
new file mode 100644
index 000000000000..7cdb19dc4eec
--- /dev/null
+++ b/x11-libs/motif/motif-2.3.5.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools eutils flag-o-matic multilib toolchain-funcs multilib-minimal
+
+DESCRIPTION="The Motif user interface component toolkit"
+HOMEPAGE="http://sourceforge.net/projects/motif/
+ http://motif.ics.com/"
+SRC_URI="mirror://sourceforge/project/motif/Motif%20${PV}%20Source%20Code/${P}.tar.gz
+ http://dev.gentoo.org/~ulm/distfiles/${P}-patches-1.tar.xz"
+
+LICENSE="LGPL-2.1+ MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="examples jpeg +motif22-compatibility png static-libs unicode xft"
+
+RDEPEND="abi_x86_32? ( !app-emulation/emul-linux-x86-motif[-abi_x86_32(-)] )
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXmu-1.1.1-r1[${MULTILIB_USEDEP}]
+ >=x11-libs/libXp-1.0.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXt-1.1.4[${MULTILIB_USEDEP}]
+ jpeg? ( >=virtual/jpeg-0-r2:0=[${MULTILIB_USEDEP}] )
+ png? ( >=media-libs/libpng-1.6.10:0=[${MULTILIB_USEDEP}] )
+ unicode? ( >=virtual/libiconv-0-r1[${MULTILIB_USEDEP}] )
+ xft? (
+ >=media-libs/fontconfig-2.10.92[${MULTILIB_USEDEP}]
+ >=x11-libs/libXft-2.3.1-r1[${MULTILIB_USEDEP}]
+ )"
+
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ || ( dev-util/byacc sys-freebsd/freebsd-ubin )
+ x11-misc/xbitmaps"
+
+src_prepare() {
+ eapply ../patch
+ eapply_user
+
+ # disable compilation of demo binaries
+ sed -i -e '/^SUBDIRS/{:x;/\\$/{N;bx;};s/[ \t\n\\]*demos//;}' Makefile.am
+
+ # add X.Org vendor string to aliases for virtual bindings
+ echo -e '"The X.Org Foundation"\t\t\t\t\tpc' >>bindings/xmbind.alias
+
+ AT_M4DIR=. eautoreconf
+
+ # get around some LANG problems in make (#15119)
+ LANG=C
+
+ # bug #80421
+ filter-flags -ftracer
+
+ # feel free to fix properly if you care
+ append-flags -fno-strict-aliasing
+
+ # for Solaris Xos_r.h :(
+ [[ ${CHOST} == *-solaris2.11 ]] \
+ && append-cppflags -DNEED_XOS_R_H -DHAVE_READDIR_R_3
+
+ if use !elibc_glibc && use !elibc_uclibc && use unicode; then
+ # libiconv detection in configure script doesn't always work
+ # http://bugs.motifzone.net/show_bug.cgi?id=1423
+ export LIBS="${LIBS} -liconv"
+ fi
+
+ # "bison -y" causes runtime crashes #355795
+ export YACC=byacc
+
+ # remember the name of the C compiler for the native ABI
+ MY_NATIVE_CC=$(tc-getCC)
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ --with-x \
+ $(use_enable static-libs static) \
+ $(use_enable motif22-compatibility) \
+ $(use_enable unicode utf8) \
+ $(use_enable xft) \
+ $(use_enable jpeg) \
+ $(use_enable png)
+}
+
+multilib_src_compile() {
+ # The wmluiltok build tool is linked with libfl.a, so always
+ # compile it for the native ABI
+ emake -C tools/wml CC="${MY_NATIVE_CC}" LIBS="-lfl" wmluiltok
+ emake
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+
+ if multilib_is_native_abi && use examples; then
+ emake -C demos DESTDIR="${D}" install-data
+ dodir /usr/share/doc/${PF}/demos
+ mv "${ED}"/usr/share/Xm/* "${ED}"/usr/share/doc/${PF}/demos || die
+ fi
+}
+
+multilib_src_install_all() {
+ # mwm default configs
+ insinto /usr/share/X11/app-defaults
+ newins "${FILESDIR}"/Mwm.defaults Mwm
+
+ # cleanup
+ rm -rf "${ED}"/usr/share/Xm
+ prune_libtool_files
+
+ dodoc BUGREPORT ChangeLog README RELEASE RELNOTES TODO
+}