summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/urwidtrees/Manifest1
-rw-r--r--dev-python/urwidtrees/metadata.xml12
-rw-r--r--dev-python/urwidtrees/urwidtrees-1.0.1.1.ebuild50
3 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/urwidtrees/Manifest b/dev-python/urwidtrees/Manifest
new file mode 100644
index 000000000000..9e75ffbf4525
--- /dev/null
+++ b/dev-python/urwidtrees/Manifest
@@ -0,0 +1 @@
+DIST urwidtrees-1.0.1.1.tar.gz 12916 SHA256 08a66d0e76e94bc32bc590e35ed283e8a6b0c93adeb431dc576ec0a345f09bfd SHA512 9494cc3c4fe72b468443bbaef0d95f5288ed0dc3a8be00a3bbc261b9b3c4a3752df2f89e439082ed91ba89790c5ad656850d874b5e934cc5a23e87eea8fe4df0 WHIRLPOOL 929d69e4e05fb8e1d68263948b46be5fdc55c480e2678d59d85fa05bd68f795979d97c4fab3f6c8e5d74a71c2375d4805d19f4d44e3def87750dfaad2bdee192
diff --git a/dev-python/urwidtrees/metadata.xml b/dev-python/urwidtrees/metadata.xml
new file mode 100644
index 000000000000..09adda987e26
--- /dev/null
+++ b/dev-python/urwidtrees/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>aidecoe@gentoo.org</email>
+ <name>Amadeusz Żołnowski</name>
+ </maintainer>
+ <longdescription lang="en">
+ This is a Widget Container API for the urwid toolkit. It uses a MVC
+ approach and allows to build trees of widgets.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/urwidtrees/urwidtrees-1.0.1.1.ebuild b/dev-python/urwidtrees/urwidtrees-1.0.1.1.ebuild
new file mode 100644
index 000000000000..c63efff47c61
--- /dev/null
+++ b/dev-python/urwidtrees/urwidtrees-1.0.1.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Tree widgets for urwid"
+HOMEPAGE="https://github.com/pazz/urwidtrees"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+RDEPEND=">=dev-python/urwid-1.1.0[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ find "${S}" -name '*.py' -print0 | xargs -0 -- sed \
+ -e '1i# -*- coding: utf-8 -*-' -i || die
+
+ distutils-r1_src_prepare
+
+ local md
+ for md in *.md; do
+ mv "${md}" "${md%.md}"
+ done
+}
+
+src_compile() {
+ distutils-r1_src_compile
+
+ if use doc; then
+ pushd docs || die
+ emake html
+ popd || die
+ fi
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ if use doc; then
+ dohtml -r docs/build/html/*
+ fi
+}