summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-plugins/passff-host/passff-host-1.2.1.ebuild57
1 files changed, 0 insertions, 57 deletions
diff --git a/www-plugins/passff-host/passff-host-1.2.1.ebuild b/www-plugins/passff-host/passff-host-1.2.1.ebuild
deleted file mode 100644
index 3dd1e204515e..000000000000
--- a/www-plugins/passff-host/passff-host-1.2.1.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 2018-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_6 python3_7 )
-
-inherit python-single-r1
-
-DESCRIPTION="Host app for the PassFF WebExtension"
-HOMEPAGE="https://github.com/passff/passff-host"
-
-SRC_URI="
- https://github.com/passff/passff-host/releases/download/${PV}/passff.py -> ${P}.py
- https://github.com/passff/passff-host/releases/download/${PV}/passff.json -> ${P}.json
-"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~x86"
-IUSE="chrome chromium firefox vivaldi"
-REQUIRED_USE="
- ${PYTHON_REQUIRED_USE}
- || ( chrome chromium firefox vivaldi )
-"
-
-RDEPEND="${PYTHON_DEPS}"
-
-S="${WORKDIR}"
-
-src_unpack() {
- cp "${DISTDIR}/${P}.json" . || die
- cp "${DISTDIR}/${P}.py" . || die
-}
-
-src_prepare() {
- default
- python_fix_shebang "${P}.py"
-}
-
-src_install() {
- local target_dirs=()
-
- use chrome && target_dirs+=( "/etc/opt/chrome/native-messaging-hosts" )
- use chromium && target_dirs+=( "/etc/chromium/native-messaging-hosts" )
- use firefox && target_dirs+=( "/usr/$(get_libdir)/mozilla/native-messaging-hosts" )
- use vivaldi && target_dirs+=( "/etc/vivaldi/native-messaging-hosts" )
-
- for target_dir in "${target_dirs[@]}"; do
- sed "s;PLACEHOLDER;${target_dir}/passff.py;g" "${P}.json" > "passff.json" || die
-
- insinto "${target_dir}"
- doins passff.json
- exeinto "${target_dir}"
- newexe "${P}.py" passff.py
- done
-}