summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-libs/tnt/tnt-3.0.12.ebuild18
1 files changed, 6 insertions, 12 deletions
diff --git a/sci-libs/tnt/tnt-3.0.12.ebuild b/sci-libs/tnt/tnt-3.0.12.ebuild
index 2a622ddfa0c2..9de7e6dca2ee 100644
--- a/sci-libs/tnt/tnt-3.0.12.ebuild
+++ b/sci-libs/tnt/tnt-3.0.12.ebuild
@@ -1,28 +1,22 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
-inherit versionator
-
-MYP="${PN}_$(replace_all_version_separators '_')"
+MY_P="${PN}_$(ver_rs 1-3 '_')"
DESCRIPTION="Template Numerical Toolkit: C++ headers for array and matrices"
HOMEPAGE="http://math.nist.gov/tnt/"
-SRC_URI="http://math.nist.gov/tnt/${MYP}.zip"
+SRC_URI="http://math.nist.gov/tnt/${MY_P}.zip"
LICENSE="public-domain"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-DEPEND="app-arch/unzip"
-RDEPEND=""
+BDEPEND="app-arch/unzip"
S="${WORKDIR}/${PN}"
src_install() {
- insinto /usr/include
- doins *.h
+ doheader *.h
}