summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-admin/aerospike-amc-community/Manifest1
-rw-r--r--app-admin/aerospike-amc-community/aerospike-amc-community-4.0.17.ebuild24
-rw-r--r--app-admin/aerospike-amc-community/files/amc.init.321
3 files changed, 46 insertions, 0 deletions
diff --git a/app-admin/aerospike-amc-community/Manifest b/app-admin/aerospike-amc-community/Manifest
index 55aec7b91387..fcb4bb303d21 100644
--- a/app-admin/aerospike-amc-community/Manifest
+++ b/app-admin/aerospike-amc-community/Manifest
@@ -5,3 +5,4 @@ DIST aerospike-amc-community-3.6.13.all.x86_64.deb 1436414 BLAKE2B cd823dd1c546f
DIST aerospike-amc-community-3.6.8.2.all.x86_64.deb 1429424 BLAKE2B 591f9982af0f9c696211fca341fc521b7e096f0cb57a0c0f0ff8d807422dfbcf121f31d87c7c3d89143c2e1e1bf96b2161531c3bad998cc5d3a069e545951e3f SHA512 ed1b82f825888ce2985b77d75e2e9988f87a241159fc0452af12892f66c37ec0d88f7edd2be6fce6d06184a5c09305f5e9727af48774e55b6290402fa406abc3
DIST aerospike-amc-community-3.6.8.all.x86_64.deb 1429404 BLAKE2B efebdb3d1d9136b0a1fcf5aa09d8c293cc552b32895070afc1557752d304a88f3da9970f178b8e30a0c8b9ac0762c18af93ab9446e3ba6e12a70b57c8d179370 SHA512 de44333471307410461bd53266b84fdc9fa92f7115012eb4b29b3ad415dd471ca3d9bf1a7c52bec7063df02a7e600dce9366910a089751dd19163cc212574d28
DIST aerospike-amc-community-3.6.9.all.x86_64.deb 1431182 BLAKE2B 6ba0618d048e7aa57b11a13dc92b9a838de2e26a316ae1fa35bf157656c3463e2933667dc96323648f28c5013093d59c7bf460906e2f7ff04ac3d9bd94f7e7c2 SHA512 67059ef2b96c4cf69b8a2edacb3edc711a18889b7eee16a038c63e8176d80e4b5ff23f126c0c16113a529e181b9c6f16601cbfa0251b0b12231ad7a23b8bc65e
+DIST aerospike-amc-community-4.0.17.tar.gz 7868123 BLAKE2B 86ada2e5af69b9306dc10b5386d21bd4459fff8a05672f289511f1b4efc27b1bd114cdd7bf9e5d6656fa3911ca111c8eabaa178a564f2ff9e6ab64c4a88a0145 SHA512 3dce8e8d435f70685498083d50818c1655faa61125391424c0ff99ea50618df4f9f3c3ddc7be5c64aba7118e75c5c3f24f7c5bfe834ba7fb504fa7d72bd00db3
diff --git a/app-admin/aerospike-amc-community/aerospike-amc-community-4.0.17.ebuild b/app-admin/aerospike-amc-community/aerospike-amc-community-4.0.17.ebuild
new file mode 100644
index 000000000000..ee583da80e5f
--- /dev/null
+++ b/app-admin/aerospike-amc-community/aerospike-amc-community-4.0.17.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils user
+
+DESCRIPTION="Web UI based monitoring tool for Aerospike Community Edition Server"
+HOMEPAGE="http://www.aerospike.com"
+SRC_URI="http://www.aerospike.com/download/amc/${PV}/artifact/linux -> ${P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+S=$WORKDIR
+
+src_install() {
+ cp -r "$S/"* "$D"
+ rm "${D}/etc/init.d/*"
+ newinitd "${FILESDIR}/amc.init.3" amc
+}
diff --git a/app-admin/aerospike-amc-community/files/amc.init.3 b/app-admin/aerospike-amc-community/files/amc.init.3
new file mode 100644
index 000000000000..6fd8097b18f1
--- /dev/null
+++ b/app-admin/aerospike-amc-community/files/amc.init.3
@@ -0,0 +1,21 @@
+#!/sbin/openrc-run
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+run_dir=${run_dir:-/run}
+
+command="/opt/amc/amc"
+command_progress="true"
+retry='TERM/30/KILL/5'
+pidfile=${run_dir}/${SVCNAME}.pid
+user=${user:-root}
+group=${group:-root}
+start_stop_daemon_args="--user ${user} --group ${group}"
+
+depend() {
+ use net
+}
+
+start_post() {
+ ewaitfile 60 "${pidfile}"
+}