summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-metrics/nginx-lua-prometheus/Manifest1
-rw-r--r--app-metrics/nginx-lua-prometheus/metadata.xml8
-rw-r--r--app-metrics/nginx-lua-prometheus/nginx-lua-prometheus-0.1_pre20170610.ebuild33
3 files changed, 42 insertions, 0 deletions
diff --git a/app-metrics/nginx-lua-prometheus/Manifest b/app-metrics/nginx-lua-prometheus/Manifest
new file mode 100644
index 000000000000..71476dd467f1
--- /dev/null
+++ b/app-metrics/nginx-lua-prometheus/Manifest
@@ -0,0 +1 @@
+DIST nginx-lua-prometheus-0.1_pre20170610.tar.gz 10307 BLAKE2B b08fcb126a6d7034c143c7e96709f3f2751d90f60f6b9225f55ed46f7f211ebcf5f1688bd8b2c82286e329dd23e09a5163ad316ba6568755936253e8e55590f1 SHA512 df1022a88e82e388e68146f81e51a53f9b0c1a14a43d58e468d258ac0ca9875c1c88af44c46c91d89dc7fc1fef0ffebdb9163f886d85fde995e61e2cac3b5c81
diff --git a/app-metrics/nginx-lua-prometheus/metadata.xml b/app-metrics/nginx-lua-prometheus/metadata.xml
new file mode 100644
index 000000000000..c36c37139fad
--- /dev/null
+++ b/app-metrics/nginx-lua-prometheus/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>williamh@gentoo.org</email>
+ <name>William Hubbs</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-metrics/nginx-lua-prometheus/nginx-lua-prometheus-0.1_pre20170610.ebuild b/app-metrics/nginx-lua-prometheus/nginx-lua-prometheus-0.1_pre20170610.ebuild
new file mode 100644
index 000000000000..b8af9afe146c
--- /dev/null
+++ b/app-metrics/nginx-lua-prometheus/nginx-lua-prometheus-0.1_pre20170610.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# This is the upstream tag which corresponds to this release.
+# It needs to be updated with every bump.
+TAG="0.1-20170610"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Library that exports Nginx metrics to Prometheus"
+HOMEPAGE="https://github.com/knyar/nginx-lua-prometheus"
+SRC_URI="https://github.com/knyar/${PN}/archive/${TAG}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+COMMON_DEPEND=">=dev-lang/lua-5.1:="
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}
+ www-servers/nginx[nginx_modules_http_lua]"
+BDEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
+
+ S="${WORKDIR}/${PN}-${TAG}"
+
+src_install() {
+ insinto "$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD lua)"/${PN}
+ doins prometheus.lua
+ dodoc *.md
+}