summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/casync/casync-2_p20190407.ebuild35
-rw-r--r--net-misc/casync/metadata.xml4
2 files changed, 20 insertions, 19 deletions
diff --git a/net-misc/casync/casync-2_p20190407.ebuild b/net-misc/casync/casync-2_p20190407.ebuild
index 5dc04cbd3945..a0e571ae1fc6 100644
--- a/net-misc/casync/casync-2_p20190407.ebuild
+++ b/net-misc/casync/casync-2_p20190407.ebuild
@@ -1,28 +1,30 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit vcs-snapshot meson
+EAPI=7
+inherit meson
-COMMIT="6d185a540c54195a919d4b44f9bf28c341da3bf1"
-DESCRIPTION=" Content-Addressable Data Synchronization Tool"
+EGIT_COMMIT="6d185a540c54195a919d4b44f9bf28c341da3bf1"
+DESCRIPTION="Content-Addressable Data Synchronization Tool"
HOMEPAGE="https://github.com/systemd/casync"
-SRC_URI="https://github.com/systemd/casync/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://github.com/systemd/casync/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
-LICENSE="LGPL-2.1"
+LICENSE="LGPL-2.1+"
SLOT="0"
KEYWORDS="~amd64"
IUSE="+fuse +udev man selinux test"
+RESTRICT="!test? ( test )"
+S="${WORKDIR}/${PN}-${EGIT_COMMIT}"
RDEPEND="
- app-arch/xz-utils
- app-arch/zstd
- dev-libs/openssl:0
- net-misc/curl
- virtual/acl
- fuse? ( sys-fs/fuse:0 )
- selinux? ( sys-libs/libselinux )
- udev? ( virtual/libudev )
+ app-arch/xz-utils:=
+ app-arch/zstd:=
+ dev-libs/openssl:0=
+ net-misc/curl:=
+ virtual/acl:=
+ fuse? ( sys-fs/fuse:0= )
+ selinux? ( sys-libs/libselinux:= )
+ udev? ( virtual/libudev:= )
"
DEPEND="${RDEPEND}
virtual/pkgconfig
@@ -39,8 +41,3 @@ src_configure() {
)
meson_src_configure
}
-
-src_install() {
- meson_src_install
- find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die
-}
diff --git a/net-misc/casync/metadata.xml b/net-misc/casync/metadata.xml
index 4468d7433a37..0a6e55e76e12 100644
--- a/net-misc/casync/metadata.xml
+++ b/net-misc/casync/metadata.xml
@@ -2,6 +2,10 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
+ <email>zoltan@sinustrom.info</email>
+ <name>Zoltan Puskas</name>
+ </maintainer>
+ <maintainer type="person">
<email>hurikhan77+bgo@gmail.com</email>
<name>Kai Krakow</name>
</maintainer>