summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-simulation/openttd/Manifest1
-rw-r--r--games-simulation/openttd/openttd-1.7.0.ebuild170
-rw-r--r--games-simulation/openttd/openttd-1.7.1.ebuild170
3 files changed, 0 insertions, 341 deletions
diff --git a/games-simulation/openttd/Manifest b/games-simulation/openttd/Manifest
index a6d89f569ea9..cb5020b62d8a 100644
--- a/games-simulation/openttd/Manifest
+++ b/games-simulation/openttd/Manifest
@@ -1,4 +1,3 @@
DIST openttd-1.6.0-source.tar.gz 10064454 SHA256 32f63477aba1ccf238dfe0538a6660163c2b725e077978e570e38d023d269cad SHA512 d235e6e094b2e3fda0cf58a2dce1e5d779654bee638def60f00da4e7c6443b00a6f3b204d5a63cf56e141074c8aa3700ce7e9f1b1eccbb5cd36260f1892ad501 WHIRLPOOL 497272ccc3836710a68cabfbf5b925a30c3d23ee332e5ba5fa24a2b79b199d2b7ce6bd22507ea977986382ae32193247b9eedee638419d1e6f41165f5fa8abd9
DIST openttd-1.6.1-source.tar.gz 10157130 SHA256 c7bd713377f08d5b63d703e3b8b8eff3bb4ec7042ad13511575fff4640cbc78f SHA512 57ea47689c8eb1cea5b8fd7ae884164a87fc8d442ef32e8234af8306589e587a6397f1a89ee64c797ff0b7310386f0b602365ab1fb61f7765bfb03c0dbd4fdfd WHIRLPOOL 05b3a7a5ebdeb6733a36b5133a17bd143b89d1f84a034061dbb0708c1eb836d13aaeb176d39846283214c15e613c048d5956970c6a09534f46d2bc0727137867
-DIST openttd-1.7.0-source.tar.gz 10088730 SHA256 16b8ef2450c80e79fca28e0932435c4493f0f4d18f1b3f55ebcc65454b3aeb38 SHA512 81cf49ebc916a58cfddc2be4a151162eaec3c27b2482972fe4dc87b9527a8e2166b6d29db688c6fb6045d14ae60531b7740f6f75385b9fa9c366e51dca27003f WHIRLPOOL 6422199c63d6bf7389d02999588fd9ba8118562a8f81ceea41ec1c4564a1904a94494221443a0a2a48ffc7be508a36cf2e81f51c5dc591a072c0f4f2b27bc11c
DIST openttd-1.7.1-source.tar.gz 10090311 SHA256 9f7a5f5051dc9f43e8eec00bd56755a20846c8738ffcd4bb1f2e1eae334f3371 SHA512 4a0d2ee424374b50fe0d089b86ff16b5de3159848a38143ca6745e349b6126567f1e4beda9afe2e6bc21ffffce1166acf719d3f5c95703a14c1379f8857e83d3 WHIRLPOOL 65d0ee93dad5b865b1de362dc2259e8528bed273f640a9ec9097cf177cd507068f2fc093bfca1b55b0fa2865b9f7f3b68cf4d2caf1f9290ecaa61e46af2c60d9
diff --git a/games-simulation/openttd/openttd-1.7.0.ebuild b/games-simulation/openttd/openttd-1.7.0.ebuild
deleted file mode 100644
index 4154210b8b51..000000000000
--- a/games-simulation/openttd/openttd-1.7.0.ebuild
+++ /dev/null
@@ -1,170 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit eutils gnome2-utils
-
-DESCRIPTION="OpenTTD is a clone of Transport Tycoon Deluxe"
-HOMEPAGE="http://www.openttd.org/"
-SRC_URI="http://binaries.openttd.org/releases/${PV}/${P}-source.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~x86"
-IUSE="aplaymidi debug dedicated iconv icu lzo +openmedia +png cpu_flags_x86_sse +timidity +truetype zlib"
-RESTRICT="test" # needs a graphics set in order to test
-
-RDEPEND="!dedicated? (
- media-libs/libsdl[sound,X,video]
- icu? (
- dev-libs/icu-layoutex
- dev-libs/icu-le-hb
- >=dev-libs/icu-58.1:=
- )
- truetype? (
- media-libs/fontconfig
- media-libs/freetype:2
- sys-libs/zlib
- )
- )
- lzo? ( dev-libs/lzo:2 )
- iconv? ( virtual/libiconv )
- png? ( media-libs/libpng:0 )
- zlib? ( sys-libs/zlib )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-PDEPEND="
- !dedicated? (
- openmedia? (
- games-misc/openmsx
- games-misc/opensfx
- )
- aplaymidi? ( media-sound/alsa-utils )
- !aplaymidi? ( timidity? ( media-sound/timidity++ ) )
- )
- openmedia? ( >=games-misc/opengfx-0.4.7 )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.6.0-cflags.patch
-)
-
-src_configure() {
- local myopts=()
- # there is an allegro interface available as well as sdl, but
- # the configure for it looks broken so the sdl interface is
- # always built instead.
- local myopts+=( --without-allegro )
-
- # libtimidity not needed except for some embedded platform
- # nevertheless, it will be automagically linked if it is
- # installed. Hence, we disable it.
- myopts+=( --without-libtimidity )
-
- use debug && myopts+=( --enable-debug=3 )
-
- if use dedicated ; then
- myopts+=( --enable-dedicated )
- else
- use aplaymidi && myopts+=( --with-midi='/usr/bin/aplaymidi' )
- myopts+=(
- $(use_with truetype freetype)
- $(use_with icu)
- --with-sdl
- )
- fi
- if use png || { use !dedicated && use truetype; } || use zlib ; then
- myopts+=( --with-zlib )
- else
- myopts+=( --without-zlib )
- fi
-
- # configure is a hand-written bash-script, so econf will not work.
- # It's all built as C++, upstream uses CFLAGS internally.
- CFLAGS="" ./configure \
- --disable-strip \
- --prefix-dir="${EPREFIX}/usr" \
- --binary-dir="bin" \
- --install-dir="${D}" \
- --menu-group="Game;Simulation;" \
- ${myopts[@]} \
- $(use_with iconv) \
- $(use_with png) \
- $(use_with cpu_flags_x86_sse sse) \
- $(use_with lzo liblzo2) \
- || die
-}
-
-src_compile() {
- emake VERBOSE=1
-}
-
-src_install() {
- default
- if use dedicated ; then
- newinitd "${FILESDIR}"/${PN}.initd ${PN}
- rm -rf "${ED}"/usr/share/{applications,icons,pixmaps}
- fi
- rm -f "${ED}"/usr/share/doc/${PF}/COPYING
-}
-
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
-
- if ! use lzo ; then
- elog "OpenTTD was built without 'lzo' in USE. While 'lzo' is not"
- elog "required, disabling it does mean that loading old savegames"
- elog "or scenarios from ancient versions (~0.2) will fail."
- elog
- fi
-
- if use dedicated ; then
- ewarn "Warning: The init script will kill all running openttd"
- ewarn "processes when triggered, including any running client sessions!"
- else
- if use aplaymidi ; then
- elog "You have emerged with 'aplaymidi' for playing MIDI."
- elog "This option is for those with a hardware midi device,"
- elog "or who have set up ALSA to handle midi ports."
- elog "You must set the environment variable ALSA_OUTPUT_PORTS."
- elog "Available ports can be listed by using 'aplaymidi -l'."
- else
- if ! use timidity ; then
- elog "OpenTTD was built with neither 'aplaymidi' nor 'timidity'"
- elog "in USE. Music may or may not work in-game. If you happen"
- elog "to have timidity++ installed, music will work so long"
- elog "as it remains installed, but OpenTTD will not depend on it."
- fi
- fi
- if ! use openmedia ; then
- elog
- elog "OpenTTD was compiled without the 'openmedia' USE flag."
- elog
- elog "In order to play, you must at least install:"
- elog "games-misc/opengfx, and games-misc/opensfx, or copy the "
- elog "following 6 files from a version of Transport Tycoon Deluxe"
- elog "(windows or DOS) to ~/.openttd/data/ or"
- elog "${GAMES_DATADIR}/${PN}/data/."
- elog
- elog "From the WINDOWS version you need: "
- elog "sample.cat trg1r.grf trgcr.grf trghr.grf trgir.grf trgtr.grf"
- elog "OR from the DOS version you need: "
- elog "SAMPLE.CAT TRG1.GRF TRGC.GRF TRGH.GRF TRGI.GRF TRGT.GRF"
- elog
- elog "File names are case sensitive, but should work either with"
- elog "all upper or all lower case names"
- elog
- elog "In addition, in-game music will be unavailable: for music,"
- elog "install games-misc/openmsx, or use the in-game download"
- elog "functionality to get a music set"
- elog
- fi
- fi
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
-}
diff --git a/games-simulation/openttd/openttd-1.7.1.ebuild b/games-simulation/openttd/openttd-1.7.1.ebuild
deleted file mode 100644
index 4154210b8b51..000000000000
--- a/games-simulation/openttd/openttd-1.7.1.ebuild
+++ /dev/null
@@ -1,170 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit eutils gnome2-utils
-
-DESCRIPTION="OpenTTD is a clone of Transport Tycoon Deluxe"
-HOMEPAGE="http://www.openttd.org/"
-SRC_URI="http://binaries.openttd.org/releases/${PV}/${P}-source.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~x86"
-IUSE="aplaymidi debug dedicated iconv icu lzo +openmedia +png cpu_flags_x86_sse +timidity +truetype zlib"
-RESTRICT="test" # needs a graphics set in order to test
-
-RDEPEND="!dedicated? (
- media-libs/libsdl[sound,X,video]
- icu? (
- dev-libs/icu-layoutex
- dev-libs/icu-le-hb
- >=dev-libs/icu-58.1:=
- )
- truetype? (
- media-libs/fontconfig
- media-libs/freetype:2
- sys-libs/zlib
- )
- )
- lzo? ( dev-libs/lzo:2 )
- iconv? ( virtual/libiconv )
- png? ( media-libs/libpng:0 )
- zlib? ( sys-libs/zlib )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-PDEPEND="
- !dedicated? (
- openmedia? (
- games-misc/openmsx
- games-misc/opensfx
- )
- aplaymidi? ( media-sound/alsa-utils )
- !aplaymidi? ( timidity? ( media-sound/timidity++ ) )
- )
- openmedia? ( >=games-misc/opengfx-0.4.7 )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.6.0-cflags.patch
-)
-
-src_configure() {
- local myopts=()
- # there is an allegro interface available as well as sdl, but
- # the configure for it looks broken so the sdl interface is
- # always built instead.
- local myopts+=( --without-allegro )
-
- # libtimidity not needed except for some embedded platform
- # nevertheless, it will be automagically linked if it is
- # installed. Hence, we disable it.
- myopts+=( --without-libtimidity )
-
- use debug && myopts+=( --enable-debug=3 )
-
- if use dedicated ; then
- myopts+=( --enable-dedicated )
- else
- use aplaymidi && myopts+=( --with-midi='/usr/bin/aplaymidi' )
- myopts+=(
- $(use_with truetype freetype)
- $(use_with icu)
- --with-sdl
- )
- fi
- if use png || { use !dedicated && use truetype; } || use zlib ; then
- myopts+=( --with-zlib )
- else
- myopts+=( --without-zlib )
- fi
-
- # configure is a hand-written bash-script, so econf will not work.
- # It's all built as C++, upstream uses CFLAGS internally.
- CFLAGS="" ./configure \
- --disable-strip \
- --prefix-dir="${EPREFIX}/usr" \
- --binary-dir="bin" \
- --install-dir="${D}" \
- --menu-group="Game;Simulation;" \
- ${myopts[@]} \
- $(use_with iconv) \
- $(use_with png) \
- $(use_with cpu_flags_x86_sse sse) \
- $(use_with lzo liblzo2) \
- || die
-}
-
-src_compile() {
- emake VERBOSE=1
-}
-
-src_install() {
- default
- if use dedicated ; then
- newinitd "${FILESDIR}"/${PN}.initd ${PN}
- rm -rf "${ED}"/usr/share/{applications,icons,pixmaps}
- fi
- rm -f "${ED}"/usr/share/doc/${PF}/COPYING
-}
-
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
-
- if ! use lzo ; then
- elog "OpenTTD was built without 'lzo' in USE. While 'lzo' is not"
- elog "required, disabling it does mean that loading old savegames"
- elog "or scenarios from ancient versions (~0.2) will fail."
- elog
- fi
-
- if use dedicated ; then
- ewarn "Warning: The init script will kill all running openttd"
- ewarn "processes when triggered, including any running client sessions!"
- else
- if use aplaymidi ; then
- elog "You have emerged with 'aplaymidi' for playing MIDI."
- elog "This option is for those with a hardware midi device,"
- elog "or who have set up ALSA to handle midi ports."
- elog "You must set the environment variable ALSA_OUTPUT_PORTS."
- elog "Available ports can be listed by using 'aplaymidi -l'."
- else
- if ! use timidity ; then
- elog "OpenTTD was built with neither 'aplaymidi' nor 'timidity'"
- elog "in USE. Music may or may not work in-game. If you happen"
- elog "to have timidity++ installed, music will work so long"
- elog "as it remains installed, but OpenTTD will not depend on it."
- fi
- fi
- if ! use openmedia ; then
- elog
- elog "OpenTTD was compiled without the 'openmedia' USE flag."
- elog
- elog "In order to play, you must at least install:"
- elog "games-misc/opengfx, and games-misc/opensfx, or copy the "
- elog "following 6 files from a version of Transport Tycoon Deluxe"
- elog "(windows or DOS) to ~/.openttd/data/ or"
- elog "${GAMES_DATADIR}/${PN}/data/."
- elog
- elog "From the WINDOWS version you need: "
- elog "sample.cat trg1r.grf trgcr.grf trghr.grf trgir.grf trgtr.grf"
- elog "OR from the DOS version you need: "
- elog "SAMPLE.CAT TRG1.GRF TRGC.GRF TRGH.GRF TRGI.GRF TRGT.GRF"
- elog
- elog "File names are case sensitive, but should work either with"
- elog "all upper or all lower case names"
- elog
- elog "In addition, in-game music will be unavailable: for music,"
- elog "install games-misc/openmsx, or use the in-game download"
- elog "functionality to get a music set"
- elog
- fi
- fi
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
-}