summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-vim/tlib/Manifest1
-rw-r--r--app-vim/tlib/tlib-1.22.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/app-vim/tlib/Manifest b/app-vim/tlib/Manifest
index 60080ae08b89..e9d409701373 100644
--- a/app-vim/tlib/Manifest
+++ b/app-vim/tlib/Manifest
@@ -1 +1,2 @@
DIST tlib-1.20.tar.gz 111202 BLAKE2B 0ee6c662e1658607706516adab9b770942ec948633a75879b5a516b46989a34744acde52d10d5b2ea58af6e7215f1241b18c53267d643d4c2e08da425a93169e SHA512 d8a344483da2a174324dc81472b5d3bdb811e54af22a1599c5567019d33bafdf499845d3efeabf081ecf17dc6965c69640a6a01b208811529e86266ba1871218
+DIST tlib-1.22.tar.gz 119979 BLAKE2B 2fe1231b6a075989c41aa2cf38d0964b6d9ada390d0729ea417aa1c2ef1a105a07d569f80c75ba91a55f7e68f349faab2dcda66741b0b1da59f76d68a5467e24 SHA512 b7fc7e3741876c92bbccc116d4e170663e3d178aa8fb546f969475723cd82e07d9470af37574f8f97cfd23b8ca8f5dd5daa2e7bef50e2f62beec0015a2355908
diff --git a/app-vim/tlib/tlib-1.22.ebuild b/app-vim/tlib/tlib-1.22.ebuild
new file mode 100644
index 000000000000..3b7985db27c7
--- /dev/null
+++ b/app-vim/tlib/tlib-1.22.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+MY_PN=${PN}_vim
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="vim plugin: a library of utility functions"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=1863 https://github.com/tomtom/tlib_vim"
+SRC_URI="https://github.com/tomtom/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ default
+ rm -r test samples addon-info.json || die
+}