summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-benchmarks/siege/siege-4.0.7.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/app-benchmarks/siege/siege-4.0.7.ebuild b/app-benchmarks/siege/siege-4.0.7.ebuild
index 96acf64824f7..7309c86336a0 100644
--- a/app-benchmarks/siege/siege-4.0.7.ebuild
+++ b/app-benchmarks/siege/siege-4.0.7.ebuild
@@ -23,7 +23,12 @@ DEPEND="${RDEPEND}"
src_prepare() {
default
# bundled macros break recent libtool
- sed -i -e '/AC_PROG_SHELL/d' configure.ac || die
+ # remove /usr/lib from LDFLAGS, bug #732886
+ sed -i \
+ -e '/AC_PROG_SHELL/d' \
+ -e 's/SSL_LDFLAGS="-L.*lib"/SSL_LDFLAGS=""/g' \
+ -e 's/Z_LDFLAGS="-L.*lib"/Z_LDFLAGS=""/g' \
+ configure.ac || die
rm *.m4 || die "failed to remove bundled macros"
eautoreconf
}
@@ -36,7 +41,7 @@ src_configure() {
}
src_install() {
- emake DESTDIR="${D}" install
+ emake DESTDIR="${ED}" install
dodoc AUTHORS ChangeLog INSTALL README* doc/siegerc doc/urls.txt