summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-terms/guake/files/guake-3.4.0-paths.patch14
-rw-r--r--x11-terms/guake/guake-3.4.0-r1.ebuild (renamed from x11-terms/guake/guake-3.4.0.ebuild)8
-rw-r--r--x11-terms/guake/guake-9999.ebuild10
3 files changed, 25 insertions, 7 deletions
diff --git a/x11-terms/guake/files/guake-3.4.0-paths.patch b/x11-terms/guake/files/guake-3.4.0-paths.patch
new file mode 100644
index 000000000000..30a47294d5ec
--- /dev/null
+++ b/x11-terms/guake/files/guake-3.4.0-paths.patch
@@ -0,0 +1,14 @@
+https://bugs.gentoo.org/667878
+https://github.com/Guake/guake/issues/1436
+
+--- a/guake/paths.py
++++ b/guake/paths.py
+@@ -35,7 +35,7 @@
+
+
+ def get_data_files_dir():
+- d = os.path.dirname(os.path.dirname(sys.modules["guake"].__file__))
++ d = os.path.dirname(sys.modules["guake"].__file__)
+ p = os.path.basename(os.path.abspath(os.path.join(d, "..")))
+ if p in ["site-packages", "dist-packages"]:
+ # current "guake" package has been installed in a prefix structure (/usr, /usr/local or
diff --git a/x11-terms/guake/guake-3.4.0.ebuild b/x11-terms/guake/guake-3.4.0-r1.ebuild
index ec3ad80d6f2e..a9aeb41ea1cf 100644
--- a/x11-terms/guake/guake-3.4.0.ebuild
+++ b/x11-terms/guake/guake-3.4.0-r1.ebuild
@@ -17,13 +17,14 @@ KEYWORDS="~amd64 ~arm ~x86"
IUSE="utempter"
RDEPEND="
- dev-libs/keybinder:3
+ dev-libs/glib[${PYTHON_USEDEP}]
+ dev-libs/keybinder:3[introspection]
dev-python/dbus-python[${PYTHON_USEDEP}]
dev-python/pbr[${PYTHON_USEDEP}]
dev-python/pycairo[${PYTHON_USEDEP}]
dev-python/pygobject:3[${PYTHON_USEDEP}]
- x11-libs/libnotify
- x11-libs/vte:2.91
+ x11-libs/libnotify[introspection]
+ x11-libs/vte:2.91[introspection]
utempter? ( sys-libs/libutempter )
"
DEPEND="
@@ -36,6 +37,7 @@ DEPEND="
PATCHES=(
"${FILESDIR}"/${PN}-3.3.2-paths.patch
+ "${FILESDIR}"/${PN}-3.4.0-paths.patch
)
S=${WORKDIR}/${P^}
diff --git a/x11-terms/guake/guake-9999.ebuild b/x11-terms/guake/guake-9999.ebuild
index 46f3706e7f3d..593f8375adb6 100644
--- a/x11-terms/guake/guake-9999.ebuild
+++ b/x11-terms/guake/guake-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -17,13 +17,14 @@ KEYWORDS=""
IUSE="utempter"
RDEPEND="
- dev-libs/keybinder:3
+ dev-libs/glib[${PYTHON_USEDEP}]
+ dev-libs/keybinder:3[introspection]
dev-python/dbus-python[${PYTHON_USEDEP}]
dev-python/pbr[${PYTHON_USEDEP}]
dev-python/pycairo[${PYTHON_USEDEP}]
dev-python/pygobject:3[${PYTHON_USEDEP}]
- x11-libs/libnotify
- x11-libs/vte:2.91
+ x11-libs/libnotify[introspection]
+ x11-libs/vte:2.91[introspection]
utempter? ( sys-libs/libutempter )
"
DEPEND="
@@ -36,6 +37,7 @@ DEPEND="
PATCHES=(
"${FILESDIR}"/${PN}-3.3.2-paths.patch
+ "${FILESDIR}"/${PN}-3.4.0-paths.patch
)
python_compile_all() {