summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-im/prosody/Manifest1
-rw-r--r--net-im/prosody/prosody-0.11.1.ebuild (renamed from net-im/prosody/prosody-0.11.0.ebuild)25
2 files changed, 12 insertions, 14 deletions
diff --git a/net-im/prosody/Manifest b/net-im/prosody/Manifest
index 21822501c77e..98b2a1896d0e 100644
--- a/net-im/prosody/Manifest
+++ b/net-im/prosody/Manifest
@@ -1,3 +1,4 @@
DIST prosody-0.10.2.tar.gz 331874 BLAKE2B 0e0af95a9168810263e6f60b825393d1088f69dba1faabf6c0c9dda3ef6b039a92f7edb9643cb9a60a3131a64038de5c3598f7076837b58ad196ac03fa98bfc4 SHA512 9fc05e34b45b0c16835ba94a73532fb3b4ee335f27d56bb9260e1b3e22614f89f44eb5d04b4e90d016db0b5bee6f5c7e7d099e1defb027e6823ee7667c1fe28f
DIST prosody-0.11.0.tar.gz 418710 BLAKE2B 2a9af1edbd77d3ef8f629ed5855a6638929bd0476d5245c0ef3ec6e2d840fda3a8b733bcfe35b7603057caa23576e0ec344d244d0c1678e28aa41badb75b6170 SHA512 292f555a25108716cd3ceb8ab39210bcb7f2fd113bd844092a51f68127e59b64ec76045740fd93edca8be2c1711a5fbab0f51a285f3ab78d36423a897ea667bf
+DIST prosody-0.11.1.tar.gz 418780 BLAKE2B 0fa45b71bb7eeaa60385683427c9547af3e014faa97dec409cc19e48bfd1b91fec7eb001fb14a86c9f3ce2c653ece2fdb113bba860cdc500cb164dd7749af6cc SHA512 6e25d2365d40582f57799bb08bf2673ba43270e8bcca5c5b785381380db55ec3ea6ab771fb9bd228bf265a564bb017dbfeae81713abd2de35a92704f8b8004ef
DIST prosody-0.9.14.tar.gz 268253 BLAKE2B 0ae62ca3c8eb89feb34f1f67aa3d14aa1e6bf02cf10ff90a43fd7de8bd257d70508e36b10b3f159040c1fa5dcfb6ad8018e3411a5d6042992f71f643a13c11d4 SHA512 30116ebc20c719d88bae7f2f44c129604ec4477004581c3556ff548c75ee026a83dc519701a61a8c3f547776ba74c571e38c3e1e5240da9148dad35a5d1f67e3
diff --git a/net-im/prosody/prosody-0.11.0.ebuild b/net-im/prosody/prosody-0.11.1.ebuild
index 7ccfe253a716..eccd2e1da7be 100644
--- a/net-im/prosody/prosody-0.11.0.ebuild
+++ b/net-im/prosody/prosody-0.11.1.ebuild
@@ -8,8 +8,8 @@ inherit flag-o-matic multilib systemd
MY_PV=$(ver_rs 3 '')
MY_P="${PN}-${MY_PV}"
DESCRIPTION="Prosody is a flexible communications server for Jabber/XMPP written in Lua"
-HOMEPAGE="http://prosody.im/"
-SRC_URI="http://prosody.im/tmp/${MY_PV}/${MY_P}.tar.gz"
+HOMEPAGE="https://prosody.im/"
+SRC_URI="https://prosody.im/tmp/${MY_PV}/${MY_P}.tar.gz"
LICENSE="MIT"
SLOT="0"
@@ -20,7 +20,7 @@ DEPEND="net-im/jabber-base
dev-lua/LuaBitOp
!jit? ( >=dev-lang/lua-5.1:0 )
jit? ( dev-lang/luajit:2 )
- >=net-dns/libidn-1.1
+ >=net-dns/libidn-1.1:=
!libressl? ( dev-libs/openssl:0 ) libressl? ( dev-libs/libressl:= )"
RDEPEND="${DEPEND}
>=dev-lua/luaexpat-1.3.0
@@ -53,18 +53,15 @@ src_configure() {
# the configure script is handcrafted (and yells at unknown options)
# hence do not use 'econf'
append-cflags -D_GNU_SOURCE
- luajit=""
- if use jit; then
- luajit="--runwith=luajit"
- fi
./configure \
- --ostype=linux $luajit \
+ --ostype=linux \
--prefix="${EPREFIX}/usr" \
- --libdir="${EPREFIX}/usr/lib64" \
- --sysconfdir="${JABBER_ETC}" \
- --datadir="${JABBER_SPOOL}" \
- --with-lua-include=/usr/include \
- --with-lua-lib=/usr/$(get_libdir)/lua \
+ --libdir="${EPREFIX}/usr/$(get_libdir)" \
+ --sysconfdir="${EPREFIX}/${JABBER_ETC}" \
+ --datadir="${EPREFIX}/${JABBER_SPOOL}" \
+ --with-lua-include="${EPREFIX}/usr/include" \
+ --with-lua-lib="${EPREFIX}/usr/$(get_libdir)/lua" \
+ --runwith=lua"$(usev jit)" \
--cflags="${CFLAGS} -Wall -fPIC" \
--ldflags="${LDFLAGS} -shared" \
--c-compiler="$(tc-getCC)" \
@@ -76,7 +73,7 @@ src_install() {
systemd_dounit "${FILESDIR}/${PN}".service
systemd_newtmpfilesd "${FILESDIR}/${PN}".tmpfilesd "${PN}".conf
newinitd "${FILESDIR}/${PN}".initd-r2 ${PN}
- keepdir /var/spool/jabber
+ keepdir "${JABBER_SPOOL}"
}
pkg_postinst() {