summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-text/blogc/Manifest2
-rw-r--r--app-text/blogc/blogc-0.7.6.ebuild (renamed from app-text/blogc/blogc-0.7.5.ebuild)19
2 files changed, 11 insertions, 10 deletions
diff --git a/app-text/blogc/Manifest b/app-text/blogc/Manifest
index 6f56d1b133e1..76c286a36a11 100644
--- a/app-text/blogc/Manifest
+++ b/app-text/blogc/Manifest
@@ -1 +1 @@
-DIST blogc-0.7.5.tar.xz 265468 SHA256 22b66fd38c70ec094bc77bd7a04a0ce2bc1bb2177d3d8cb705baf4ec79283d69 SHA512 75ad54c65fff927117a9135bf606357e52eb91d2c448bf8cac2676e519ab58f919447057e031ebfa90cb033728fa49f5bafb8c94678fe142e1856082870690fb WHIRLPOOL 92f4aec3864e80d57e17ed8b2bef6bdb3e7f12c8f32fc0c42bfb653ce2fcbaf3ee6ab5aebaf9aece79cbb75515d07d28068f83f98cf847c54fd68e7ef6668a7f
+DIST blogc-0.7.6.tar.xz 279444 SHA256 67799d933ef907973ae9b6333b1a22c254ef49c829e2a24b76eea04484b68de3 SHA512 092590f2249dcc71b170ebbe20bbdd975bea6bb60cbcf8f0739db0bb8318c2718d22becd4be121fd18a63be5619beae9c95b451e417909f4c4e82e53aa6d683e WHIRLPOOL bbe13eb95976d2a36872e7cd034b487550392eeeb2761ea305ff3044215c208a9b634b2af1e25cb92161e1f508b22f1f81919c97f078a250324efa29371548a6
diff --git a/app-text/blogc/blogc-0.7.5.ebuild b/app-text/blogc/blogc-0.7.6.ebuild
index f50ce2b99c03..cddb4f58911f 100644
--- a/app-text/blogc/blogc-0.7.5.ebuild
+++ b/app-text/blogc/blogc-0.7.6.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
if [[ ${PV} = *9999* ]]; then
EGIT_REPO_URI="
@@ -11,8 +11,6 @@ if [[ ${PV} = *9999* ]]; then
inherit git-r3 autotools
fi
-inherit eutils
-
DESCRIPTION="A blog compiler"
HOMEPAGE="http://blogc.org/"
@@ -21,24 +19,26 @@ KEYWORDS="~amd64 ~x86"
if [[ ${PV} = *9999* ]]; then
SRC_URI=""
KEYWORDS=""
- DEPEND="app-text/ronn"
+ RDEPEND="=dev-libs/squareball-9999"
+ DEPEND="${RDEPEND}
+ app-text/ronn"
+else
+ RDEPEND=">=dev-libs/squareball-0.1"
+ DEPEND="${RDEPEND}"
fi
LICENSE="BSD"
SLOT="0"
IUSE="test"
-RDEPEND=""
-
-# pkg-config is used only to find cmocka libraries
DEPEND="${DEPEND}
+ virtual/pkgconfig
test? (
- virtual/pkgconfig
dev-util/cmocka )"
src_prepare() {
[[ ${PV} = *9999* ]] && eautoreconf
- epatch_user
+ eapply_user
default
}
@@ -52,5 +52,6 @@ src_configure() {
econf \
$(use_enable test tests) \
--disable-valgrind \
+ --with-squareball=system \
${myconf}
}