summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-cdr/cdemu-daemon/Manifest1
-rw-r--r--app-cdr/cdemu-daemon/cdemu-daemon-3.0.4.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/app-cdr/cdemu-daemon/Manifest b/app-cdr/cdemu-daemon/Manifest
index 8a91513c5ba7..df48d8dea2ad 100644
--- a/app-cdr/cdemu-daemon/Manifest
+++ b/app-cdr/cdemu-daemon/Manifest
@@ -1,2 +1,3 @@
DIST cdemu-daemon-2.1.1.tar.bz2 62600 SHA256 d26782071184d555b06ad5def7d1c22916cbeb73377328879499b91e1196f36f SHA512 be59bf12e326855ccdfe5cec72a813b7a80dcc2cb408c3f19b9abe66eeb8d092e2755b1ba9f746ac7d3c1b27276ed857947ce1b2509d8cbf07eb1c6663f3536d WHIRLPOOL fd6ad9aa28ae9c821934099a3be271a1fe85db684dcc1ca9b65d499281ce65b27ac63d44c8570309d1fc3fbd486eadb165e15cec285c81bb07b10c709a1f6f42
DIST cdemu-daemon-3.0.2.tar.bz2 76029 SHA256 8c9a0d292e0fd71538f123f2b795f4490ff455f68b391b97812be369c34a4f06 SHA512 eb09880dcc984c8843cf0254d45aeaa39cff8faa3a415352c574b59ea6778de9bc10a9634022c1fe5c7de8aa0493129a7bd15b859a7ca3895d5175b2bb2296e1 WHIRLPOOL 918554fead811418bd1e1b1ad8cd22342c5e5559eb7e4f3e30f1ccb1c889547bbd7f70bd7af86c19af86a7c432281f3d98a2fb5d0ef59f57dcddf3ad0fc10686
+DIST cdemu-daemon-3.0.4.tar.bz2 76121 SHA256 8101b4ad659de3cc53dcc39b14381d7d85b3dad131d780caefe9cc1c03551ecd SHA512 e5a3da9dd87e6ad6cf226e53628dbee76eb26104c51a511adb5b6b65d46e3f213a682ba0d845c8a651d939c44b853b6a9881e542e10f9f7d1dd579b8fc408154 WHIRLPOOL b92a78732f177e31b7a80288ec5253d92d5e92f796612cc288c7b976e46d5ebff3e8a2ffd9c3a0a1acb785893a0a663317ece75c3ed5c30592f69d53c01199b8
diff --git a/app-cdr/cdemu-daemon/cdemu-daemon-3.0.4.ebuild b/app-cdr/cdemu-daemon/cdemu-daemon-3.0.4.ebuild
new file mode 100644
index 000000000000..07971177cee3
--- /dev/null
+++ b/app-cdr/cdemu-daemon/cdemu-daemon-3.0.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+CMAKE_MIN_VERSION="2.8.5"
+
+inherit cmake-utils eutils
+
+DESCRIPTION="Daemon of the CDEmu optical media image mounting suite"
+HOMEPAGE="http://cdemu.org"
+SRC_URI="mirror://sourceforge/cdemu/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0/7" # subslot = CDEMU_DAEMON_INTERFACE_VERSION_MAJOR in CMakeLists.txt
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.32:2
+ >=dev-libs/libmirage-${PV}:=
+ >=media-libs/libao-0.8.0:=
+ sys-apps/dbus
+ >=sys-fs/vhba-20130607"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ DOCS="AUTHORS README"
+ cmake-utils_src_prepare
+}
+
+pkg_postinst() {
+ elog "You will need to load the vhba module to use cdemu devices:"
+ elog " # modprobe vhba"
+ elog "To automatically load the vhba module at boot time, edit your"
+ elog "/etc/conf.d/modules file."
+
+ if [[ -e "${ROOT}etc/conf.d/cdemud" ]]; then
+ elog
+ elog "${PN} no longer installs an init.d service; instead, it is"
+ elog "automatically activated when needed via dbus."
+ elog "You can therefore remove ${ROOT}etc/conf.d/cdemud"
+ fi
+}