summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-dns/s6-dns/Manifest1
-rw-r--r--net-dns/s6-dns/s6-dns-2.3.5.4.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/net-dns/s6-dns/Manifest b/net-dns/s6-dns/Manifest
index 0557975166a4..e8c6d65fd7cd 100644
--- a/net-dns/s6-dns/Manifest
+++ b/net-dns/s6-dns/Manifest
@@ -1 +1,2 @@
DIST s6-dns-2.3.5.3.tar.gz 84916 BLAKE2B b315e2319c4b15401a6e41847faefc1798c3a945fc78f1601b06ce13ef0a55ddde270549e0585cac0356f9b1558a1433675dc4c636d1cc58aee434b86bd81627 SHA512 f3984913df65823c4edbeddc2f8c534926e74c5b06c357c394b05b25943ac8c6b4154859c93e182c60228f018522eb6173ece0bd2dbeffe8e1cc6fcbe33f6a76
+DIST s6-dns-2.3.5.4.tar.gz 84892 BLAKE2B 3bba411b297b85fdf5da7caf251b3c093d0e7108fdf16321e510a485e750ef37c6ec1a923e627a81a9719f211e2e284c9b8d3bcf60a4e18738d0886f931e380d SHA512 04c8fd40c71c9517f4e8d847a0ddf7d60a7759b4d7075035c2e00b4eb34e81edf4608df562929042c294ed671ab953e613374b577210ff49841ceb27dd563ae5
diff --git a/net-dns/s6-dns/s6-dns-2.3.5.4.ebuild b/net-dns/s6-dns/s6-dns-2.3.5.4.ebuild
new file mode 100644
index 000000000000..f2aac4dc81a3
--- /dev/null
+++ b/net-dns/s6-dns/s6-dns-2.3.5.4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Suite of DNS client programs and libraries for Unix systems"
+HOMEPAGE="https://www.skarnet.org/software/s6-dns/"
+SRC_URI="https://www.skarnet.org/software/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~x86"
+IUSE="static static-libs"
+
+REQUIRED_USE="static? ( static-libs )"
+
+RDEPEND=">=dev-libs/skalibs-2.12.0.0:=[static-libs?]"
+DEPEND="${RDEPEND}"
+
+HTML_DOCS=( doc/. )
+
+src_prepare() {
+ default
+
+ # Avoid QA warning for LDFLAGS addition
+ sed -i -e 's/.*-Wl,--hash-style=both$/:/' configure || die
+
+ sed -i -e '/AR := /d' -e '/RANLIB := /d' Makefile || die
+}
+
+src_configure() {
+ tc-export AR CC RANLIB
+
+ local myconf=(
+ --bindir=/bin
+ --dynlibdir=/usr/$(get_libdir)
+ --libdir=/usr/$(get_libdir)/${PN}
+ --with-dynlib=/usr/$(get_libdir)
+ --with-lib=/usr/$(get_libdir)/skalibs
+ --with-sysdeps=/usr/$(get_libdir)/skalibs
+ --enable-shared
+ $(use_enable static allstatic)
+ $(use_enable static static-libc)
+ $(use_enable static-libs static)
+ )
+
+ econf "${myconf[@]}"
+}