summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/dnotify/dnotify-0.18.0.ebuild17
-rw-r--r--sys-apps/dnotify/files/dnotify-0.18.0-glibc-212.patch4
-rw-r--r--sys-apps/dnotify/files/dnotify-0.18.0-nls.patch4
3 files changed, 12 insertions, 13 deletions
diff --git a/sys-apps/dnotify/dnotify-0.18.0.ebuild b/sys-apps/dnotify/dnotify-0.18.0.ebuild
index 440759ad96ac..5a207d27f378 100644
--- a/sys-apps/dnotify/dnotify-0.18.0.ebuild
+++ b/sys-apps/dnotify/dnotify-0.18.0.ebuild
@@ -1,11 +1,10 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=2
-inherit eutils
+EAPI=6
DESCRIPTION="Execute a command when the contents of a directory change"
-HOMEPAGE="http://directory.fsf.org/project/dnotify/"
+HOMEPAGE="https://directory.fsf.org/project/dnotify/"
SRC_URI="mirror://gentoo/${P}.tar.gz"
LICENSE="GPL-2"
@@ -16,10 +15,10 @@ IUSE="nls"
RDEPEND=""
DEPEND="nls? ( sys-devel/gettext )"
-src_prepare() {
- epatch "${FILESDIR}"/${P}-nls.patch \
- "${FILESDIR}"/${P}-glibc-212.patch
-}
+PATCHES=(
+ "${FILESDIR}/${P}-nls.patch"
+ "${FILESDIR}/${P}-glibc-212.patch"
+)
src_configure() {
econf \
@@ -28,5 +27,5 @@ src_configure() {
src_install() {
emake DESTDIR="${D}" install || die
- dodoc AUTHORS TODO NEWS README
+ default
}
diff --git a/sys-apps/dnotify/files/dnotify-0.18.0-glibc-212.patch b/sys-apps/dnotify/files/dnotify-0.18.0-glibc-212.patch
index 6cc6e6f40092..19cd20039424 100644
--- a/sys-apps/dnotify/files/dnotify-0.18.0-glibc-212.patch
+++ b/sys-apps/dnotify/files/dnotify-0.18.0-glibc-212.patch
@@ -1,7 +1,7 @@
http://bugs.gentoo.org/336649
---- src/main.c
-+++ src/main.c
+--- a/src/main.c
++++ b/src/main.c
@@ -19,6 +19,7 @@
#include <config.h>
diff --git a/sys-apps/dnotify/files/dnotify-0.18.0-nls.patch b/sys-apps/dnotify/files/dnotify-0.18.0-nls.patch
index 7721ac1ee411..55400b704983 100644
--- a/sys-apps/dnotify/files/dnotify-0.18.0-nls.patch
+++ b/sys-apps/dnotify/files/dnotify-0.18.0-nls.patch
@@ -1,5 +1,5 @@
---- src/gettext.h.orig 2006-01-27 18:23:31.000000000 +0100
-+++ src/gettext.h 2006-01-27 18:25:07.000000000 +0100
+--- a/src/gettext.h 2006-01-27 18:23:31.000000000 +0100
++++ b/src/gettext.h 2006-01-27 18:25:07.000000000 +0100
@@ -24,6 +24,7 @@
/* Get declarations of GNU message catalog functions. */