summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-qt/qtlocation/qtlocation-5.9.2.ebuild8
1 files changed, 8 insertions, 0 deletions
diff --git a/dev-qt/qtlocation/qtlocation-5.9.2.ebuild b/dev-qt/qtlocation/qtlocation-5.9.2.ebuild
index 420e3c9ba782..06c3a9a1206f 100644
--- a/dev-qt/qtlocation/qtlocation-5.9.2.ebuild
+++ b/dev-qt/qtlocation/qtlocation-5.9.2.ebuild
@@ -34,3 +34,11 @@ QT5_TARGET_SUBDIRS=(
src/imports/location
src/plugins/geoservices
)
+
+src_configure() {
+ # src/plugins/geoservices requires files that are only generated when
+ # qmake is run in the root directory. Bug 633776.
+ mkdir -p "${QT5_BUILD_DIR}" || die
+ qt5_qmake "${QT_BUILD_DIR}"
+ qt5-build_src_configure
+}