summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-fs/aufs3/Manifest1
-rw-r--r--sys-fs/aufs3/aufs3-3_p20150622.ebuild172
2 files changed, 0 insertions, 173 deletions
diff --git a/sys-fs/aufs3/Manifest b/sys-fs/aufs3/Manifest
index c57ee9cb8a9c..c67f57b8e3c6 100644
--- a/sys-fs/aufs3/Manifest
+++ b/sys-fs/aufs3/Manifest
@@ -1,3 +1,2 @@
-DIST aufs3-standalone-3_p20150622.tar.xz 3063280 SHA256 2fa44f9df9d58df7a5251ebd2cec206fa90ca8e110c1f657df18e62adb170517 SHA512 fe7a62249130d68f72b14f21b57e5d6db402f56637afc876068d916e78884d08476c804ac58ef06eeb9e13e0a2e1cb75ac782f83054f1c06cb85c74a3c48ba01 WHIRLPOOL 7f85a5324d51e148c97109357c13fcab76121d25ee006211d2212f9c6d352330be110569848c8ca96421bc4582025c73030329d7e501837e4d18cafd6002f153
DIST aufs3-standalone-3_p20160219.tar.xz 3256736 SHA256 23652c6d8fd12a9a29454293f13add7e0f97f2ec542b69e5dfecbc99064c4247 SHA512 af65cb3d9890c05ec24d64d27759d8c0fa98f35887d62a7ec77ebc496ec9de02563bc5a3e05b67c342926b062fe077c7a8de543291177a4e0210b2159027e1af WHIRLPOOL 1ed7042c9e1e8efc29fa36fcbd2f09a10ffa51cc9d6b349869f6f6947ed27399deb2fa1035df7dbaf69dcbfa7eddb6f240b934a343732ace26f77bcf2e72167a
DIST aufs3-standalone-3_p20160223.tar.xz 3270932 SHA256 4e213e678991a028595893a2c3425894bef021cd374a6798f80ad8863bf7f593 SHA512 37805b54a2471def5948d3484349de7bfc4fee09788b36b9589aba2006484cf330bb642f27862d74a528999cf2e7fa4888b5d46b54bb3e7f8468c6857f34730f WHIRLPOOL 1e42d1a32a62b25923041b8f71b00f8ae1a8b8524752b1d796ae2fd2ada79792cbe2a35ad380e24ecad8374bbd432674763d69ffa9144dfc3074742b33d4d138
diff --git a/sys-fs/aufs3/aufs3-3_p20150622.ebuild b/sys-fs/aufs3/aufs3-3_p20150622.ebuild
deleted file mode 100644
index 9f8ba0ef022c..000000000000
--- a/sys-fs/aufs3/aufs3-3_p20150622.ebuild
+++ /dev/null
@@ -1,172 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit eutils flag-o-matic linux-info linux-mod multilib readme.gentoo toolchain-funcs
-
-AUFS_VERSION="${PV%%_p*}"
-# highest branch version
-PATCH_MAX_VER=19
-# highest supported version
-KERN_MAX_VER=20
-# lowest supported version
-KERN_MIN_VER=14
-
-DESCRIPTION="An entirely re-designed and re-implemented Unionfs"
-HOMEPAGE="http://aufs.sourceforge.net/"
-SRC_URI="https://dev.gentoo.org/~jlec/distfiles/aufs3-standalone-${PV}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="debug doc fuse hfs inotify kernel-patch nfs pax_kernel ramfs"
-
-DEPEND="
- dev-util/patchutils
- dev-vcs/git"
-RDEPEND="
- sys-fs/aufs-util
- !sys-fs/aufs
- !sys-fs/aufs2
- !sys-fs/aufs4"
-
-S="${WORKDIR}"/${PN}-standalone
-
-MODULE_NAMES="aufs(misc:${S})"
-
-pkg_setup() {
- CONFIG_CHECK+=" !AUFS_FS"
- use inotify && CONFIG_CHECK+=" ~FSNOTIFY"
- use nfs && CONFIG_CHECK+=" EXPORTFS"
- use fuse && CONFIG_CHECK+=" ~FUSE_FS"
- use hfs && CONFIG_CHECK+=" ~HFSPLUS_FS"
- use pax_kernel && CONFIG_CHECK+=" PAX" && ERROR_PAX="Please use hardened sources"
-
- # this is needed so merging a binpkg ${PN} is possible w/out a kernel unpacked on the system
- [ -n "$PKG_SETUP_HAS_BEEN_RAN" ] && return
-
- get_version
- kernel_is lt 3 ${KERN_MIN_VER} 0 && die "the kernel version isn't supported by upstream anymore. Please upgrade."
- kernel_is gt 3 ${KERN_MAX_VER} 99 && die "kernel too new"
-
- linux-mod_pkg_setup
-
- if [[ "${KV_MINOR}" -gt "${PATCH_MAX_VER}" ]]; then
- PATCH_BRANCH="x-rcN"
- elif [[ "${KV_MINOR}" == "14" ]] && [[ "${KV_PATCH}" -ge "21" ]]; then
- PATCH_BRANCH="${KV_MINOR}".21+
- elif [[ "${KV_MINOR}" == "18" ]] && [[ "${KV_PATCH}" -ge "1" ]]; then
- PATCH_BRANCH="${KV_MINOR}".1+
- else
- PATCH_BRANCH="${KV_MINOR}"
- fi
-
- case ${KV_EXTRA} in
- "")
- elog "It seems you are using vanilla-sources with aufs3"
- elog "Please use sys-kernel/aufs-sources with USE=vanilla"
- elog "This will save you the nasty reemerge of sys-fs/aufs3 on every kernel upgrade"
- ;;
- "-gentoo")
- elog "It seems you are using gentoo-sources with aufs3"
- elog "Please use sys-kernel/aufs-sources"
- elog "This will save you the nasty reemerge of sys-fs/aufs3 on every kernel upgrade"
- ;;
- esac
-
- pushd "${T}" &> /dev/null
- unpack ${A}
- cd ${PN}-standalone || die
- local module_branch=origin/${PN}.${PATCH_BRANCH}
- einfo "Using ${module_branch} as patch source"
- git checkout -q -b local-${PN}.${PATCH_BRANCH} ${module_branch} || die
- combinediff ${PN}-base.patch ${PN}-standalone.patch > "${T}"/combined-1.patch
- combinediff "${T}"/combined-1.patch ${PN}-mmap.patch > ${PN}-standalone-base-mmap-combined.patch
- if ! ( patch -p1 --dry-run --force -R -d ${KV_DIR} < ${PN}-standalone-base-mmap-combined.patch > /dev/null ); then
- if use kernel-patch; then
- cd ${KV_DIR}
- ewarn "Patching your kernel..."
- patch --no-backup-if-mismatch --force -p1 -R -d ${KV_DIR} < "${T}"/${PN}-standalone/${PN}-standalone-base-mmap-combined.patch >/dev/null
- epatch "${T}"/${PN}-standalone/${PN}-standalone-base-mmap-combined.patch
- ewarn "You need to compile your kernel with the applied patch"
- ewarn "to be able to load and use the aufs kernel module"
- else
- eerror "You need to apply a patch to your kernel to compile and run the ${PN} module"
- eerror "Either enable the kernel-patch useflag to do it with this ebuild"
- eerror "or apply "${T}"/${PN}-standalone/${PN}-standalone-base-mmap-combined.patch by hand"
- die "missing kernel patch, please apply it first"
- fi
- fi
- popd &> /dev/null
- export PKG_SETUP_HAS_BEEN_RAN=1
-}
-
-set_config() {
- for option in $*; do
- grep -q "^CONFIG_AUFS_${option} =" config.mk || die "${option} is not a valid config option"
- sed "/^CONFIG_AUFS_${option}/s:=:= y:g" -i config.mk || die
- done
-}
-
-src_prepare() {
- local module_branch=origin/${PN}.${PATCH_BRANCH}
-
- einfo "Using for module creation branch ${module_branch}"
- git checkout -q -b local-gentoo ${module_branch} || die
-
- # All config options to off
- sed "s:= y:=:g" -i config.mk || die
-
- set_config RDU BRANCH_MAX_127 SBILIST
-
- use debug && set_config DEBUG
- use fuse && set_config BR_FUSE POLL
- use hfs && set_config BR_HFSPLUS
- use inotify && set_config HNOTIFY HFSNOTIFY
- use nfs && set_config EXPORT
- use nfs && ( use amd64 || use ppc64 ) && set_config INO_T_64
- use ramfs && set_config BR_RAMFS
-
- if use pax_kernel; then
- if kernel_is ge 3 11; then
- epatch "${FILESDIR}"/pax-3.11.patch
- else
- epatch "${FILESDIR}"/pax-3.patch
- fi
- fi
-
- sed -i "s:aufs.ko usr/include/linux/aufs_type.h:aufs.ko:g" Makefile || die
-}
-
-src_compile() {
- local ARCH=x86
-
- emake \
- CC=$(tc-getCC) \
- LD=$(tc-getLD) \
- LDFLAGS="$(raw-ldflags)" \
- ARCH=$(tc-arch-kernel) \
- CONFIG_AUFS_FS=m \
- KDIR="${KV_OUT_DIR}"
-}
-
-src_install() {
- linux-mod_src_install
-
- insinto /usr/share/doc/${PF}
-
- use doc && doins -r Documentation
-
- use kernel-patch || doins "${T}"/${PN}-standalone/${PN}-standalone-base-mmap-combined.patch
-
- dodoc Documentation/filesystems/aufs/README "${T}"/${PN}-standalone/{aufs3-loopback,vfs-ino,tmpfs-idr}.patch
-
- readme.gentoo_create_doc
-}
-
-pkg_postinst() {
- readme.gentoo_pkg_postinst
- linux-mod_pkg_postinst
-}