summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/trinity/Manifest1
-rw-r--r--dev-util/trinity/metadata.xml11
-rw-r--r--dev-util/trinity/trinity-1.9.ebuild46
-rw-r--r--dev-util/trinity/trinity-9999.ebuild9
4 files changed, 61 insertions, 6 deletions
diff --git a/dev-util/trinity/Manifest b/dev-util/trinity/Manifest
index 8a55880f3595..dec5c8d1afd5 100644
--- a/dev-util/trinity/Manifest
+++ b/dev-util/trinity/Manifest
@@ -1 +1,2 @@
DIST trinity-1.8.tar.xz 213984 BLAKE2B 56f664023e2bc3648e941e4a3cb20e450cdcad3556289e201513d1755267eb013da2be035e81c87b3f1d1b0b1e12cb041c6bb345f7a84ee4c5c12f20a8e87f55 SHA512 686076dab2346cf9b5d8a20b14db31f460a352fa72eeadbe005a7423941918f5afef08b4987bb68cbbf4218d0cb620adb85f8036294d8df5ab5262e0031a44e4
+DIST trinity-1.9.tar.xz 216364 BLAKE2B dbf5af03539fc7bac37fd49f495e3feb506c7a403f72d0ef0b85327a3714b8edef52260a03dce1082db05d520376d7b96b0f85d541d6dff67e1245b0e1b35fe8 SHA512 3a2ab84b61b450d50e46a5da5dffa803f92bf469fc3d04ff4cb39f26b4f486bede9790bb48fc6b3bbda0ee882f0acf5b610d39e86b16bea7f2207adef94be31a
diff --git a/dev-util/trinity/metadata.xml b/dev-util/trinity/metadata.xml
index 1d8df37aeeb8..7471f5066889 100644
--- a/dev-util/trinity/metadata.xml
+++ b/dev-util/trinity/metadata.xml
@@ -1,8 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
- <upstream>
- <remote-id type="github">kernelslacker/trinity</remote-id>
- </upstream>
+ <maintainer type="person">
+ <email>bircoph@gentoo.org</email>
+ <name>Andrew Savchenko</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">kernelslacker/trinity</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/dev-util/trinity/trinity-1.9.ebuild b/dev-util/trinity/trinity-1.9.ebuild
new file mode 100644
index 000000000000..583104b92a5e
--- /dev/null
+++ b/dev-util/trinity/trinity-1.9.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="A Linux system call fuzz tester"
+HOMEPAGE="http://codemonkey.org.uk/projects/trinity/ https://github.com/kernelslacker/trinity/"
+SRC_URI="http://codemonkey.org.uk/projects/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+# We need newer headers to avoid compilation failures in the BPF stuff.
+DEPEND="
+ >=sys-kernel/linux-headers-4.8
+"
+
+src_prepare() {
+ sed -e 's/-g -O2//' \
+ -e 's/-D_FORTIFY_SOURCE=2//' \
+ -e 's/-Werror//' \
+ -e '/-o $@/s/$(LDFLAGS) //' \
+ -i Makefile || die
+
+ tc-export CC
+ default
+}
+
+src_compile() {
+ emake V=1
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc Documentation/* README
+ doman trinity.1
+
+ if use examples ; then
+ exeinto /usr/share/doc/${PF}/scripts
+ doexe scripts/*
+ docompress -x /usr/share/doc/${PF}/scripts
+ fi
+}
diff --git a/dev-util/trinity/trinity-9999.ebuild b/dev-util/trinity/trinity-9999.ebuild
index 4245b613481a..3910c2f87cdd 100644
--- a/dev-util/trinity/trinity-9999.ebuild
+++ b/dev-util/trinity/trinity-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -13,11 +13,15 @@ LICENSE="GPL-2"
SLOT="0"
IUSE="examples"
-DEPEND="sys-kernel/linux-headers"
+# We need newer headers to avoid compilation failures in the BPF stuff.
+DEPEND="
+ >=sys-kernel/linux-headers-4.8
+"
src_prepare() {
sed -e 's/-g -O2//' \
-e 's/-D_FORTIFY_SOURCE=2//' \
+ -e 's/-Werror//' \
-e '/-o $@/s/$(LDFLAGS) //' \
-i Makefile || die
@@ -32,6 +36,7 @@ src_compile() {
src_install() {
dobin ${PN}
dodoc Documentation/* README
+ doman trinity.1
if use examples ; then
exeinto /usr/share/doc/${PF}/scripts