summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-plugins/freshplayerplugin/Manifest1
-rw-r--r--www-plugins/freshplayerplugin/freshplayerplugin-0.3.3.ebuild81
2 files changed, 82 insertions, 0 deletions
diff --git a/www-plugins/freshplayerplugin/Manifest b/www-plugins/freshplayerplugin/Manifest
index 0c2241478ea4..2b411b88227b 100644
--- a/www-plugins/freshplayerplugin/Manifest
+++ b/www-plugins/freshplayerplugin/Manifest
@@ -1,2 +1,3 @@
DIST freshplayerplugin-0.3.1.tar.gz 2711793 SHA256 4ed582896fff618d8025dd51bbf2fae0c5e36e2875065acc536b2c76befb593c SHA512 78e87548ecd758ad9ff0dab59b1b2f68b8b9a639ff19de08046a7090ab51d87f0e4c879b1b0075151ff17642d50ff937e199733c55c4a9cff94599fd98eae9de WHIRLPOOL d8be949cc9a2087d8f62fcfb4a1786d68574a5ec52dccc45da06df9838ee84e8dd4d7f3c3f86703e428df1b3f4d6d75c1e87d0809d3f78550a16ed278d51b211
DIST freshplayerplugin-0.3.2.tar.gz 2713241 SHA256 b3687b9d67ab88c64fea32b17f281f142bf861e33d9135b00da5d90d385d9ce5 SHA512 9c908ce1a168c0797dc3b0da8e98d722cc32d729acb1c4a8f38b7e95c23fe870baabe4b3f8790d021711578fdb9a61f44aba27cebb924fec9aabcf8cd91323e5 WHIRLPOOL 2e9b78bcc3605409ec6853caf31aab03658c044e0d05449a620b31261323856503db8db960db9992d6db4fd61df8f9feb05800124c2f4a450c4ff65b22fc7c34
+DIST freshplayerplugin-0.3.3.tar.gz 2722467 SHA256 0dc20d6ca083b24225d8bbab88be1ed483034bde71eb360962de47cdb2e51f00 SHA512 ae85adb7e894adf8c1cd4228d15975c9d5fefdb6c6d3aa90e65d93865996c787f6378eb145f35ed348db67cec0adad794b78a0f77519236c28082630ad3756bc WHIRLPOOL 3e9694738d5e926b44588560b2a6bf50eeeefc35855722bda2494a9d08bd11c8ed844791cdd8a312592be0ef002d3ee6b1c7fc090bbd94ca438ccc8a148eac99
diff --git a/www-plugins/freshplayerplugin/freshplayerplugin-0.3.3.ebuild b/www-plugins/freshplayerplugin/freshplayerplugin-0.3.3.ebuild
new file mode 100644
index 000000000000..5bfcf0312c0e
--- /dev/null
+++ b/www-plugins/freshplayerplugin/freshplayerplugin-0.3.3.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+CMAKE_MIN_VERSION="2.8.8"
+
+inherit cmake-utils multilib
+
+LICENSE="MIT"
+HOMEPAGE="https://github.com/i-rinat/freshplayerplugin"
+DESCRIPTION="PPAPI-host NPAPI-plugin adapter for flashplayer in npapi based browsers"
+SRC_URI="https://github.com/i-rinat/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SLOT=0
+IUSE="gtk3 jack libav pulseaudio vaapi vdpau"
+
+KEYWORDS="~amd64 ~x86"
+
+HWDEC_DEPEND="
+ libav? ( media-video/libav:0=[vaapi?,vdpau?,x264] )
+ !libav? ( media-video/ffmpeg:0=[vaapi?,vdpau?,x264] )
+ x11-libs/libva
+ x11-libs/libvdpau
+"
+
+CDEPEND="
+ dev-libs/glib:2=
+ dev-libs/libevent:=[threads]
+ dev-libs/openssl:0=
+ media-libs/alsa-lib:=
+ media-libs/freetype:2=
+ media-libs/libv4l:0=
+ media-libs/mesa:=[egl,gles2]
+ x11-libs/libXrandr:=
+ x11-libs/libXrender:=
+ x11-libs/libdrm:=
+ x11-libs/pango:=[X]
+ jack? ( media-sound/jack-audio-connection-kit )
+ pulseaudio? ( media-sound/pulseaudio )
+ !gtk3? ( x11-libs/gtk+:2= )
+ gtk3? ( x11-libs/gtk+:3= )
+ vaapi? ( ${HWDEC_DEPEND} )
+ vdpau? ( ${HWDEC_DEPEND} )
+"
+
+DEPEND="${CDEPEND}
+ dev-util/ragel
+ virtual/pkgconfig
+ "
+RDEPEND="${CDEPEND}
+ || (
+ www-plugins/chrome-binary-plugins[flash]
+ www-client/google-chrome
+ www-client/google-chrome-beta
+ www-client/google-chrome-unstable
+ )
+ "
+
+PATCHES=( "${FILESDIR}/0.2.4-cmake.patch" )
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with jack JACK)
+ $(cmake-utils_use_with pulseaudio PULSEAUDIO)
+ -DWITH_GTK=$(usex gtk3 3 2)
+ -DCMAKE_SKIP_RPATH=1
+ )
+ if use vaapi || use vdpau ; then
+ mycmakeargs+=( -DWITH_HWDEC=1 )
+ else
+ mycmakeargs+=( -DWITH_HWDEC=0 )
+ fi
+ cmake-utils_src_configure
+}
+
+src_install() {
+ dodoc ChangeLog data/freshwrapper.conf.example README.md
+ exeinto /usr/$(get_libdir)/nsbrowser/plugins
+ doexe "${BUILD_DIR}/libfreshwrapper-flashplayer.so"
+}