summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-board/blokish/blokish-0.9.4-r3.ebuild54
-rw-r--r--games-board/blokish/files/blokish-0.9.4-gcc43.patch4
-rw-r--r--games-board/blokish/files/blokish-0.9.4-underlink.patch4
-rw-r--r--games-board/blokish/files/blokish-0.9.4-wxgtk.patch4
4 files changed, 60 insertions, 6 deletions
diff --git a/games-board/blokish/blokish-0.9.4-r3.ebuild b/games-board/blokish/blokish-0.9.4-r3.ebuild
new file mode 100644
index 000000000000..780a429953c0
--- /dev/null
+++ b/games-board/blokish/blokish-0.9.4-r3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+WX_GTK_VER="3.0"
+inherit eutils autotools wxwidgets
+
+MY_P="${PN}_v${PV}"
+DESCRIPTION="Open source clone of the four-player board game Blokus"
+HOMEPAGE="https://sourceforge.net/projects/blokish/"
+SRC_URI="mirror://sourceforge/blokish/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="x11-libs/wxGTK:${WX_GTK_VER}[X,opengl]
+ virtual/glu
+ virtual/opengl"
+RDEPEND=${DEPEND}
+
+S=${WORKDIR}/${PN}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc43.patch
+ "${FILESDIR}"/${P}-underlink.patch
+ "${FILESDIR}"/${P}-wxgtk.patch
+)
+
+src_prepare() {
+ default
+
+ # Otherwise $WX_CONFIG is unset:
+ setup-wxwidgets
+
+ sed -i \
+ -e "s:wx-config:${WX_CONFIG}:" \
+ configure.in makefile.am || die
+ mv configure.in configure.ac || die
+
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ doicon src/${PN}.xpm
+ make_desktop_entry ${PN} Blokish ${PN}
+
+ dodoc docs/*
+}
diff --git a/games-board/blokish/files/blokish-0.9.4-gcc43.patch b/games-board/blokish/files/blokish-0.9.4-gcc43.patch
index 3e48bce774d6..f53e5495aa57 100644
--- a/games-board/blokish/files/blokish-0.9.4-gcc43.patch
+++ b/games-board/blokish/files/blokish-0.9.4-gcc43.patch
@@ -1,5 +1,5 @@
---- src/base.h
-+++ src/base.h
+--- a/src/base.h
++++ b/src/base.h
@@ -25,6 +25,9 @@
#include <vector>
#include <fstream>
diff --git a/games-board/blokish/files/blokish-0.9.4-underlink.patch b/games-board/blokish/files/blokish-0.9.4-underlink.patch
index 9a9eb6eab5a4..a4433379e37a 100644
--- a/games-board/blokish/files/blokish-0.9.4-underlink.patch
+++ b/games-board/blokish/files/blokish-0.9.4-underlink.patch
@@ -1,5 +1,5 @@
---- makefile.am.old 2011-06-21 08:43:21.804880067 +0200
-+++ makefile.am 2011-06-21 08:43:49.875661081 +0200
+--- a/makefile.am 2011-06-21 08:43:21.804880067 +0200
++++ b/makefile.am 2011-06-21 08:43:49.875661081 +0200
@@ -1,5 +1,5 @@
INCLUDES = `wx-config --cxxflags`
-LIBS = `wx-config --libs --gl-libs`
diff --git a/games-board/blokish/files/blokish-0.9.4-wxgtk.patch b/games-board/blokish/files/blokish-0.9.4-wxgtk.patch
index 008702ee9976..1821e0b5f86d 100644
--- a/games-board/blokish/files/blokish-0.9.4-wxgtk.patch
+++ b/games-board/blokish/files/blokish-0.9.4-wxgtk.patch
@@ -1,5 +1,5 @@
-diff -ru blokish.orig/src/blokish.cpp blokish/src/blokish.cpp
---- blokish.orig/src/blokish.cpp 2007-04-01 17:01:26.000000000 -0400
+diff -ru blokish/src/blokish.cpp blokish/src/blokish.cpp
+--- blokish/src/blokish.cpp 2007-04-01 17:01:26.000000000 -0400
+++ blokish/src/blokish.cpp 2015-11-15 21:48:32.426081482 -0500
@@ -903,7 +903,7 @@
void OnSaveGame(wxCommandEvent &event)