summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/shoulda/shoulda-2.11.3-r1.ebuild28
-rw-r--r--dev-ruby/shoulda/shoulda-3.5.0-r1.ebuild34
2 files changed, 0 insertions, 62 deletions
diff --git a/dev-ruby/shoulda/shoulda-2.11.3-r1.ebuild b/dev-ruby/shoulda/shoulda-2.11.3-r1.ebuild
deleted file mode 100644
index 6198d82f5042..000000000000
--- a/dev-ruby/shoulda/shoulda-2.11.3-r1.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-USE_RUBY="ruby19 ruby20"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="CONTRIBUTION_GUIDELINES.rdoc README.rdoc"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Making tests easy on the fingers and eyes"
-HOMEPAGE="http://thoughtbot.com/projects/shoulda"
-SRC_URI="https://github.com/thoughtbot/${PN}/tarball/v${PV} -> ${P}.tar.gz"
-RUBY_S="thoughtbot-${PN}-*"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~ia64 ppc ~ppc64 ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE=""
-
-# tests seem to be quite broken :( They require working version of
-# various rails versions. There appear to be unit and matcher tests but
-# they can't be run on their own.
-RESTRICT=test
diff --git a/dev-ruby/shoulda/shoulda-3.5.0-r1.ebuild b/dev-ruby/shoulda/shoulda-3.5.0-r1.ebuild
deleted file mode 100644
index d1692250da25..000000000000
--- a/dev-ruby/shoulda/shoulda-3.5.0-r1.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-USE_RUBY="ruby19 ruby20 ruby21"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="README.md"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Making tests easy on the fingers and eyes"
-HOMEPAGE="http://thoughtbot.com/projects/shoulda"
-SRC_URI="https://github.com/thoughtbot/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="3"
-KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64"
-IUSE=""
-
-# This now more or less a meta-gem and it only contains features for
-# integration tests using Appraisals, which we don't currently package.
-RESTRICT=test
-
-ruby_add_rdepend ">=dev-ruby/shoulda-context-1.0.1
- >=dev-ruby/shoulda-matchers-1.4.1"
-
-all_ruby_prepare() {
- sed -e '/git ls-files/d' -i ${RUBY_FAKEGEM_GEMSPEC} || die
-}