summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-apps/klaus/Manifest1
-rw-r--r--www-apps/klaus/klaus-1.4.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/www-apps/klaus/Manifest b/www-apps/klaus/Manifest
index a692d2ea4115..00bd7416901f 100644
--- a/www-apps/klaus/Manifest
+++ b/www-apps/klaus/Manifest
@@ -1,2 +1,3 @@
DIST klaus-1.2.2.tar.gz 35308 BLAKE2B 4ac2cd77f5c95fd207a83e1688b65e286009a5830c96fce442e3e4a2989a320c0980ab96a03817be27d45d01ccb5e2db277ed535d62a781006b4747c797838d2 SHA512 2f054ca3d285dcf334188d72bbbc4ea99fe8778126d0d215cfd3508cb294d52e2944b3e251f903a863df018ec61d9dcd779f5c6cd284fb2f6cd90abb98783176
DIST klaus-1.3.0.tar.gz 35363 BLAKE2B 881f9bd1a80d4a580a0dc84a7b8528a5703777817495639bb3ea8f608c2495287a37fe43839d0c64002e1d36453d37f116c73c9a7ef93651bc8a2d010d4d2e2c SHA512 c159d8195b1bde43f46d013f0337e998d905b1f3a9a23caf5f71180d19192c3c391cc5143545bd3d05a2aef45451a43e873ca3828c8f9f69ae3eaaa0d00560cb
+DIST klaus-1.4.0.tar.gz 36879 BLAKE2B 8a621338514e3be143c5b64a0a486d47edc7e7a14c839bc135e7c1693fd09ddea1529b5b2e1d8e0bb70f152629d7bff288f9221ae4243dac01995da4d00e5848 SHA512 8e596590fe29c62eeb823047780f747a0f4908f926dad8ff54000469dca013fcfcbaf7b53c0555db095fef71e4d9056e9b6e959005550bdfccc338f1ee3a5d2c
diff --git a/www-apps/klaus/klaus-1.4.0.ebuild b/www-apps/klaus/klaus-1.4.0.ebuild
new file mode 100644
index 000000000000..1966b9410b74
--- /dev/null
+++ b/www-apps/klaus/klaus-1.4.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+
+inherit distutils-r1
+
+DESCRIPTION="A simple, easy-to-set-up Git web viewer"
+HOMEPAGE="https://github.com/jonashaag/klaus/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ctags"
+
+RDEPEND="
+ >=dev-python/dulwich-0.19.3[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/httpauth[${PYTHON_USEDEP}]
+ dev-python/humanize[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ ctags? ( dev-python/python-ctags[${PYTHON_USEDEP}] )
+"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# The tests can only be run from a git repository
+# so they are not included in the source distributions
+
+python_install_all() {
+ distutils-r1_python_install_all
+ doman ${PN}.1
+}