summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-cdr/cdemu-daemon/Manifest1
-rw-r--r--app-cdr/cdemu-daemon/cdemu-daemon-3.2.1.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/app-cdr/cdemu-daemon/Manifest b/app-cdr/cdemu-daemon/Manifest
index fd9b4f62bfb1..66cb16114c08 100644
--- a/app-cdr/cdemu-daemon/Manifest
+++ b/app-cdr/cdemu-daemon/Manifest
@@ -1 +1,2 @@
DIST cdemu-daemon-3.1.0.tar.bz2 79943 BLAKE2B 23407c3a14b426fa9f53c2d62564e34a8f878598c24cdd9419c811786d858135a0af3a1cde8b7afc4178f7772336ed533077c089c976e98de30c932deca1c426 SHA512 f0f3de31b2bf6a97852bb1bc45d301e6cbf401ca7499f42e99811ca62431e86b344c83ddb4420571f2038e43432711e04817b9ed3859893eec7d36fbad8dfdb5
+DIST cdemu-daemon-3.2.1.tar.bz2 82426 BLAKE2B 282b1a62ca3a770e709ff31ee7b72ed9f5e102c5f318a765a99421c93881e9ecacfdc5867af494e69dddda40603c8eb6cc8904a7c82fec004a6d5644a28a9f87 SHA512 399dbb818de8a550bd31784a5a7f0adb9d2e35d922ba71f341df81d20fd7e5ebaba5f31db1554caca17919325773f9ec6bb3d5ae99afa5d6eaf5b22142e010ee
diff --git a/app-cdr/cdemu-daemon/cdemu-daemon-3.2.1.ebuild b/app-cdr/cdemu-daemon/cdemu-daemon-3.2.1.ebuild
new file mode 100644
index 000000000000..dacea999bf80
--- /dev/null
+++ b/app-cdr/cdemu-daemon/cdemu-daemon-3.2.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-utils
+
+DESCRIPTION="Daemon of the CDEmu optical media image mounting suite"
+HOMEPAGE="http://cdemu.org"
+SRC_URI="mirror://sourceforge/cdemu/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0/7" # subslot = CDEMU_DAEMON_INTERFACE_VERSION_MAJOR in CMakeLists.txt
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.32:2
+ >=dev-libs/libmirage-3.2.0:=
+ >=media-libs/libao-0.8.0:=
+ sys-apps/dbus
+ >=sys-fs/vhba-20130607"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS README )
+
+pkg_postinst() {
+ elog "You will need to load the vhba module to use cdemu devices:"
+ elog " # modprobe vhba"
+ elog "To automatically load the vhba module at boot time, edit your"
+ elog "/etc/conf.d/modules file."
+
+ if [[ -e "${ROOT}etc/conf.d/cdemud" ]]; then
+ elog
+ elog "${PN} no longer installs an init.d service; instead, it is"
+ elog "automatically activated when needed via dbus."
+ elog "You can therefore remove ${ROOT%/}/etc/conf.d/cdemud"
+ fi
+}