summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-servers/gatling/Manifest1
-rw-r--r--www-servers/gatling/gatling-0.12-r2.ebuild60
-rw-r--r--www-servers/gatling/gatling-0.13.ebuild60
3 files changed, 0 insertions, 121 deletions
diff --git a/www-servers/gatling/Manifest b/www-servers/gatling/Manifest
index c78dda5671ec..288ce4137c21 100644
--- a/www-servers/gatling/Manifest
+++ b/www-servers/gatling/Manifest
@@ -1,3 +1,2 @@
-DIST gatling-0.12.tar.bz2 99540 BLAKE2B 5711c1960d62979397919cceaee1331b71ea516ab0a4e877244c83e24ab8b6aa3978f7646dbf4f54b71e41eb32f7739800748e6a49c80adcaaa1491dd5158cd4 SHA512 50330e92576ce8002acaba9692cb9270ed2d794b1118e697193bd47beadac8ae75a8e2e0b802923172961d74e50cbe114b5e39c083b79a975c0a1bf4c86cab0a
DIST gatling-0.13.tar.bz2 108128 BLAKE2B a8226bb9c608dd77491e4a922a79c310a40e155afcb28602a0cf279e45919bd86a0e93e58d7f33a3551820de20ae219e7af75bc0402eab27c95ba0530575f4c0 SHA512 b9fa604aa8bb8c5d40d9c3eaaa536ed5e73d0ed93eccb41ca4744316ad893dc6fe92fe2c1f0247de82d4eda63b0ab7ab338355d9963fb58f23d39a2c678a1db8
DIST gatling-0.15.tar.xz 121804 BLAKE2B 7df5f6d4fc823e8a1252bacca2b57d0848dd3a920216d1d3185d5f471f786eee1eb36396114b367660ead816bd4ee6c734099bbb9bdb5ffbd5b70a59e0fb0667 SHA512 b76d220a0644f1e6e7ea966a4eff409964c564fc4a31c4efdb764e5f7b5857bc58c26bc31e860fe35df932cbd60fb2b0f4f21c75cb5aa56427e8a2a453684716
diff --git a/www-servers/gatling/gatling-0.12-r2.ebuild b/www-servers/gatling/gatling-0.12-r2.ebuild
deleted file mode 100644
index ffa25cc9ce32..000000000000
--- a/www-servers/gatling/gatling-0.12-r2.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="4"
-
-inherit eutils toolchain-funcs user
-
-DESCRIPTION="High performance web server"
-HOMEPAGE="http://www.fefe.de/gatling/"
-SRC_URI="http://dl.fefe.de/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-IUSE="ssl diet"
-REQUIRED_USE="ssl? ( !diet )"
-
-DEPEND=">=dev-libs/libowfat-0.25[diet=]
- diet? ( dev-libs/dietlibc )
- ssl? ( dev-libs/openssl )"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- rm Makefile # leaves us with GNUmakefile
- epatch "${FILESDIR}/${P}-compile.patch"
-}
-
-src_compile() {
- local DIET=
- use diet && DIET='/usr/bin/diet'
-
- local targets='gatling'
- use ssl && targets+=' tlsgatling'
-
- emake DIET="${DIET}" CC="$(tc-getCC)" \
- CFLAGS="${CFLAGS} -I/usr/include/libowfat" \
- LDFLAGS="${LDFLAGS}" prefix=/usr ${targets} \
- || die "emake ${targets} failed"
-}
-
-src_install() {
- doman gatling.1 || die "installing manpage failed"
-
- newconfd "${FILESDIR}/gatling.confd" gatling || die
- newinitd "${FILESDIR}/gatling.initd-2" gatling || die
- dodoc README.{ftp,http} || die "installing docs failed"
-
- dobin gatling || die "installing gatling binary failed"
- use ssl && {
- dodoc README.tls || die "installing docs failed"
- dobin tlsgatling || die "installing tlsgatling binary failed"
- }
-}
-
-pkg_setup() {
- ebegin "Creating gatling user and group"
- enewgroup gatling
- enewuser ${PN} -1 -1 /var/www/localhost ${PN}
-}
diff --git a/www-servers/gatling/gatling-0.13.ebuild b/www-servers/gatling/gatling-0.13.ebuild
deleted file mode 100644
index a3f6ea2f13d6..000000000000
--- a/www-servers/gatling/gatling-0.13.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="4"
-
-inherit eutils toolchain-funcs user
-
-DESCRIPTION="High performance web server"
-HOMEPAGE="http://www.fefe.de/gatling/"
-SRC_URI="http://dl.fefe.de/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-IUSE="ssl diet"
-REQUIRED_USE="ssl? ( !diet )"
-
-DEPEND=">=dev-libs/libowfat-0.25[diet=]
- diet? ( dev-libs/dietlibc )
- ssl? ( dev-libs/openssl )"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- rm Makefile # leaves us with GNUmakefile
- epatch "${FILESDIR}/${P}-compile.patch"
-}
-
-src_compile() {
- local DIET=
- use diet && DIET='/usr/bin/diet'
-
- local targets='gatling'
- use ssl && targets+=' tlsgatling'
-
- emake DIET="${DIET}" CC="$(tc-getCC)" \
- CFLAGS="${CFLAGS} -I${ROOT}usr/include/libowfat" \
- LDFLAGS="${LDFLAGS}" prefix=/usr ${targets} \
- || die "emake ${targets} failed"
-}
-
-src_install() {
- doman gatling.1 || die "installing manpage failed"
-
- newconfd "${FILESDIR}/gatling.confd" gatling || die
- newinitd "${FILESDIR}/gatling.initd-2" gatling || die
- dodoc README.{ftp,http} || die "installing docs failed"
-
- dobin gatling || die "installing gatling binary failed"
- use ssl && {
- dodoc README.tls || die "installing docs failed"
- dobin tlsgatling || die "installing tlsgatling binary failed"
- }
-}
-
-pkg_setup() {
- ebegin "Creating gatling user and group"
- enewgroup gatling
- enewuser ${PN} -1 -1 /var/www/localhost ${PN}
-}