summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-libs/octomap/Manifest1
-rw-r--r--sci-libs/octomap/files/gentoo.patch39
-rw-r--r--sci-libs/octomap/octomap-1.8.0-r2.ebuild82
3 files changed, 0 insertions, 122 deletions
diff --git a/sci-libs/octomap/Manifest b/sci-libs/octomap/Manifest
index 228b4b314009..20840feed31c 100644
--- a/sci-libs/octomap/Manifest
+++ b/sci-libs/octomap/Manifest
@@ -1,2 +1 @@
-DIST octomap-1.8.0.tar.gz 1584799 SHA256 158f66af55bb660a2aa7d0a00c60c9e5320f6594bd0924748af1471d315d5633 SHA512 61ceeee80de8bcdcfde69c3dd30a218ec7f9e4362b1bae8e80d29dde74875a717cc1cbcfba1a7c3ee7ec0ee954297796ac35052782b98af36448f5c3305bdfa9 WHIRLPOOL 12d1dd64d0b7999aa41c5ed878af63385f25536a32a38b28d168a10560dc6de5ce1148d6f20c310082da765066a8f3f826860f481ae11e1669aa9a15f6365b71
DIST octomap-1.8.1.tar.gz 1679526 SHA256 8b18ef7693e87f1400b9a8bc41f86e3b28259ac98c0b458037232652380aa6af SHA512 e35567da0d6741747abbc87de49733d0e92bae8aedfe66a63766740cc6566f3cfdbc3c986369177497cc9a8fb208ed9b727da496cec48e2ad23328df06fbc8d6 WHIRLPOOL 7bad33e4bb01ef0d0599d4e7ea6b323e4aacb06d9f5e8d4a05b52aa0be72d205735402ed25f2ff3fcad6636f838124453f61bff1808fbe75154a4e7d32d1ded3
diff --git a/sci-libs/octomap/files/gentoo.patch b/sci-libs/octomap/files/gentoo.patch
deleted file mode 100644
index 0fe7426c2855..000000000000
--- a/sci-libs/octomap/files/gentoo.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-Index: octomap-1.8.0/dynamicEDT3D/CMakeLists.txt
-===================================================================
---- octomap-1.8.0.orig/dynamicEDT3D/CMakeLists.txt
-+++ octomap-1.8.0/dynamicEDT3D/CMakeLists.txt
-@@ -62,7 +62,7 @@ file(GLOB dynamicEDT3D_HDRS ${PROJECT_SO
- install(FILES ${dynamicEDT3D_HDRS} DESTINATION include/dynamicEDT3D)
-
- # Install catkin package.xml, attention package.xml names the catkin package "dynamic_edt_3d", so this is also the location where it needs to be installed to (and not "dynamicEDT3D")
--install(FILES package.xml DESTINATION share/dynamic_edt_3d)
-+install(FILES package.xml DESTINATION share/ros_packages/dynamic_edt_3d)
-
- #TODO: this conflicts with the octomap uninstall
- #it is not only a target name problem, also both will use the same manifest file
-Index: octomap-1.8.0/octomap/CMakeLists.txt
-===================================================================
---- octomap-1.8.0.orig/octomap/CMakeLists.txt
-+++ octomap-1.8.0/octomap/CMakeLists.txt
-@@ -65,7 +65,7 @@ file(GLOB octomap_math_HDRS ${PROJECT_SO
- install(FILES ${octomap_math_HDRS} DESTINATION include/octomap/math)
-
- # Install catkin package.xml
--install(FILES package.xml DESTINATION share/octomap)
-+install(FILES package.xml DESTINATION share/ros_packages/octomap)
-
- # uninstall target
- configure_file(
-Index: octomap-1.8.0/octovis/CMakeLists.txt
-===================================================================
---- octomap-1.8.0.orig/octovis/CMakeLists.txt
-+++ octomap-1.8.0/octovis/CMakeLists.txt
-@@ -126,7 +126,7 @@ IF(BUILD_VIEWER)
- install(FILES ${octovis_HDRS} DESTINATION include/octovis)
-
- # Install catkin package.xml
-- install(FILES package.xml DESTINATION share/octovis)
-+ install(FILES package.xml DESTINATION share/ros_packages/octovis)
-
- ELSE()
- MESSAGE ( "Unfortunately, the viewer (octovis) can not be built because some requirements are missing.")
diff --git a/sci-libs/octomap/octomap-1.8.0-r2.ebuild b/sci-libs/octomap/octomap-1.8.0-r2.ebuild
deleted file mode 100644
index 19df370fdb02..000000000000
--- a/sci-libs/octomap/octomap-1.8.0-r2.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-SCM=""
-if [ "${PV#9999}" != "${PV}" ] ; then
- SCM="git-r3"
- EGIT_REPO_URI="https://github.com/OctoMap/octomap"
-fi
-
-inherit ${SCM} cmake-utils
-
-if [ "${PV#9999}" != "${PV}" ] ; then
- KEYWORDS=""
- SRC_URI=""
-else
- KEYWORDS="~amd64 ~arm"
- SRC_URI="https://github.com/OctoMap/octomap/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-fi
-
-DESCRIPTION="An Efficient Probabilistic 3D Mapping Framework Based on Octrees"
-HOMEPAGE="http://octomap.github.io/"
-IUSE="qt4 dynamicEDT3D doc"
-LICENSE="BSD qt4? ( GPL-2 )"
-SLOT="0"
-
-RDEPEND="
- qt4? (
- virtual/opengl
- dev-qt/qtcore:4
- dev-qt/qtgui:4
- x11-libs/libQGLViewer:=
- )
-"
-DEPEND="${RDEPEND}
- doc? (
- app-doc/doxygen
- media-gfx/graphviz
- )
-"
-PATCHES=( "${FILESDIR}/gentoo.patch" )
-
-src_prepare() {
- sed -e 's/DESTINATION lib/DESTINATION ${CMAKE_INSTALL_LIBDIR}/' \
- -i */CMakeLists.txt \
- -i */CMakeModules/InstallPkgConfigFile.cmake || die
- cmake-utils_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- "-DBUILD_OCTOVIS_SUBPROJECT=$(usex qt4 ON OFF)"
- "-DBUILD_DYNAMICETD3D_SUBPROJECT=$(usex dynamicEDT3D ON OFF)"
- )
- cmake-utils_src_configure
-}
-
-src_compile() {
- cmake-utils_src_compile
- if use doc ; then
- cd "${BUILD_DIR}/octomap"
- emake docs
- if use dynamicEDT3D ; then
- cd "${BUILD_DIR}/dynamicEDT3D"
- emake docs_dynamicEDT3D
- fi
- fi
-}
-
-src_install() {
- cmake-utils_src_install
- if use doc ; then
- insinto /usr/share/doc/${PF}/html/octomap
- doins -r "${S}/octomap/doc/html/"*
- if use dynamicEDT3D ; then
- insinto /usr/share/doc/${PF}/html/dynamicEDT3D
- doins -r "${S}/dynamicEDT3D/doc/html/"*
- fi
- fi
-}