summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-benchmarks/cpuburn/cpuburn-1.4a-r1.ebuild31
-rw-r--r--app-benchmarks/cpuburn/cpuburn-1.4a-r2.ebuild57
-rw-r--r--app-benchmarks/cpuburn/files/cpuburn-1.4a-flags.patch7
3 files changed, 0 insertions, 95 deletions
diff --git a/app-benchmarks/cpuburn/cpuburn-1.4a-r1.ebuild b/app-benchmarks/cpuburn/cpuburn-1.4a-r1.ebuild
deleted file mode 100644
index 10c2bf9df23b..000000000000
--- a/app-benchmarks/cpuburn/cpuburn-1.4a-r1.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils flag-o-matic toolchain-funcs
-
-MY_P="${PV/./_}"
-
-DESCRIPTION="Designed to heavily load CPU chips [testing purposes]"
-HOMEPAGE="http://pages.sbcglobal.net/redelm/"
-#SRC_URI="http://pages.sbcglobal.net/redelm/cpuburn_${MY_P}_tar.gz -> ${P}.tar.gz"
-SRC_URI="https://dev.gentoo.org/~jlec/distfiles/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="-* amd64 x86"
-IUSE=""
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-flags.patch \
- "${FILESDIR}"/${P}-variables.patch
- use amd64 && append-flags -m32 #65719
- tc-export CC
-}
-
-src_install() {
- dodoc Design README
- dobin burn{BX,K6,K7,MMX,P5,P6}
-}
diff --git a/app-benchmarks/cpuburn/cpuburn-1.4a-r2.ebuild b/app-benchmarks/cpuburn/cpuburn-1.4a-r2.ebuild
deleted file mode 100644
index ae6d819bc65f..000000000000
--- a/app-benchmarks/cpuburn/cpuburn-1.4a-r2.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-MY_PV="${PV/./_}"
-
-DESCRIPTION="CPU testing utilities in optimized assembler for maximum loading"
-HOMEPAGE="https://downloads.bl4ckb0x.de/pages.sbcglobal.net/redelm/"
-SRC_URI="https://downloads.bl4ckb0x.de/pages.sbcglobal.net/redelm/${PN}_${MY_PV}_tar.gz -> ${P}.tar.gz"
-
-KEYWORDS="-* ~amd64 ~arm ~x86"
-LICENSE="GPL-2"
-SLOT="0"
-
-PATCHES=( "${FILESDIR}/${P}-variables.patch" )
-
-QA_FLAGS_IGNORED="usr/bin/burnBX
- usr/bin/burnK6
- usr/bin/burnK7
- usr/bin/burnMMX
- usr/bin/burnP5
- usr/bin/burnP6"
-
-QA_TEXTRELS="${QA_FLAGS_IGNORED}"
-
-src_prepare() {
- default
-
- # Respect users compiler and users CFLAGS and LDFLAGS on x86/amd64
- # Must be always compiled in 32-bit on amd64 arch
- # See https://bugs.gentoo.org/65719
- sed -i -e 's/gcc -s/$(CC) $(CFLAGS) -m32 $(LDFLAGS)/' Makefile || die
-
- # Respect users compiler and users CFLAGS and LDFLAGS on arm
- sed -i -e '/CC :=/d' -e 's/^.*-mfloat-abi=softfp/ $(CC) $(CFLAGS) -nostdlib $(LDFLAGS)/' ARM/Makefile || die
-}
-
-src_compile() {
- if use arm; then
- cd "${S}"/ARM || die
- fi
-
- default
-}
-
-src_install() {
- if use arm; then
- dobin ARM/burnCortexA8 ARM/burnCortexA9
- local DOCS=( "ARM/Design" "README" )
- else
- dobin burnBX burnK6 burnK7 burnMMX burnP5 burnP6
- local DOCS=( "Design" "README" )
- fi
-
- einstalldocs
-}
diff --git a/app-benchmarks/cpuburn/files/cpuburn-1.4a-flags.patch b/app-benchmarks/cpuburn/files/cpuburn-1.4a-flags.patch
deleted file mode 100644
index 97b8836c0af4..000000000000
--- a/app-benchmarks/cpuburn/files/cpuburn-1.4a-flags.patch
+++ /dev/null
@@ -1,7 +0,0 @@
---- Makefile.orig 2001-06-16 05:39:17.000000000 +0200
-+++ Makefile 2010-10-12 20:31:38.000000000 +0200
-@@ -1,3 +1,3 @@
- all : burnP5 burnP6 burnK6 burnK7 burnBX burnMMX
- .S:
-- gcc -s -nostdlib -o $@ $<
-+ $(CC) $(CFLAGS) $(LDFLAGS) -nostdlib -o $@ $<