summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-perl/Math-BigInt-Lite/Manifest1
-rw-r--r--dev-perl/Math-BigInt-Lite/Math-BigInt-Lite-0.140.0.ebuild30
-rw-r--r--dev-perl/Math-BigInt-Lite/metadata.xml20
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-perl/Math-BigInt-Lite/Manifest b/dev-perl/Math-BigInt-Lite/Manifest
new file mode 100644
index 000000000000..b2522f33c1f9
--- /dev/null
+++ b/dev-perl/Math-BigInt-Lite/Manifest
@@ -0,0 +1 @@
+DIST Math-BigInt-Lite-0.14.tar.gz 44517 SHA256 0ae0d1fdfbfe0d1801f3fd99d1958a61958f1d50ce4d38acca735e85ef3035ef SHA512 abee57d6497566f8dfa32d273f0ef9cf914ed57b9397c61455695cbfc141fce8f1ccd2c65a2043ec0d4843dc0a1cde978a0b8b05bcc12e71a7438cd379a462c5 WHIRLPOOL a64b379303cf26d048975087082aec768fbac1e46d9bcf03a6d43de0206f2fb2e649fe041628ea2fb90eae14f23d5778c246fb53c01ebd491f26e8362038c307
diff --git a/dev-perl/Math-BigInt-Lite/Math-BigInt-Lite-0.140.0.ebuild b/dev-perl/Math-BigInt-Lite/Math-BigInt-Lite-0.140.0.ebuild
new file mode 100644
index 000000000000..1e7b1afedab0
--- /dev/null
+++ b/dev-perl/Math-BigInt-Lite/Math-BigInt-Lite-0.140.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR="FLORA"
+DIST_VERSION=0.14
+inherit perl-module
+
+DESCRIPTION="What BigInts are before they become big"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=virtual/perl-Math-BigInt-1.940.0
+ >=virtual/perl-Math-BigRat-0.190.0"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.420.0
+ test? ( >=virtual/perl-Test-Simple-0.520.0 )"
+
+src_test() {
+ local bad_files=( "t/pod_cov.t" "t/pod.t" );
+ einfo "t/bigintpm.t is broken: https://rt.cpan.org/Public/Bug/Display.html?id=75667";
+ bad_files+=( "t/bigintpm.t" );
+ perl_rm_files "${bad_files[@]}";
+
+ perl-module_src_test;
+}
diff --git a/dev-perl/Math-BigInt-Lite/metadata.xml b/dev-perl/Math-BigInt-Lite/metadata.xml
new file mode 100644
index 000000000000..8b0de0126c0c
--- /dev/null
+++ b/dev-perl/Math-BigInt-Lite/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tomboy64@sina.cn</email>
+ <name>Proxy-Maintainer; please assign him to bugs.</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Gentoo Proxy Maintainers Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">Math-BigInt-Lite</remote-id>
+ <remote-id type="cpan-module">Math::BigInt::Lite</remote-id>
+ </upstream>
+</pkgmetadata>