summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/colored2/colored2-3.1.2-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ruby/colored2/colored2-3.1.2-r1.ebuild b/dev-ruby/colored2/colored2-3.1.2-r1.ebuild
new file mode 100644
index 000000000000..3d0b2e46c6fb
--- /dev/null
+++ b/dev-ruby/colored2/colored2-3.1.2-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Console coloring"
+HOMEPAGE="https://github.com/kigster/colored2"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+each_ruby_prepare() {
+ sed -i -e '/bundler/ s:^:#:' Rakefile || die
+ sed -i -e '/simplecov/I s:^:#:' spec/spec_helper.rb || die
+
+ sed -i -e 's/Fixnum/Integer/' lib/colored2/numbers.rb || die
+}