summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-portage/portage-utils/Manifest3
-rw-r--r--app-portage/portage-utils/portage-utils-0.53.ebuild76
-rw-r--r--app-portage/portage-utils/portage-utils-0.54.ebuild76
-rw-r--r--app-portage/portage-utils/portage-utils-0.55.ebuild76
4 files changed, 0 insertions, 231 deletions
diff --git a/app-portage/portage-utils/Manifest b/app-portage/portage-utils/Manifest
index 27d9ea50834f..016789adf8c7 100644
--- a/app-portage/portage-utils/Manifest
+++ b/app-portage/portage-utils/Manifest
@@ -1,4 +1 @@
-DIST portage-utils-0.53.tar.xz 404040 SHA256 876653e795af89aeadfac1206403b1ed9543f3ac75232459d4e597e20f236c04 SHA512 5965c39572dd476bde2668a4a643d6c44da47d822f75201efbaf10a8dbb02a5bb0210ef95519b99d762106caf6f3440f78312327516d33fa8551139104483259 WHIRLPOOL 115f9e67962b890e9027ba2b16ffb7c282426a514a0272e279fb2d171152cd54638e6fb94df4121f72d84b59ed3713e05d177ed29cacddd0070d555671d21e42
-DIST portage-utils-0.54.tar.xz 510528 SHA256 d3cd50e822253008c83e871ee53e83f4fa3dcfbfa25799ec48a8dcf37ac67928 SHA512 4e7b01cff96744f767a0892df5fd2f28c17a619aac1912a2f1ebb91c0706367cb02eb478e9192e6f4fb9a22956d8fb6256497b03086938f26efcd0ba27e8c1ff WHIRLPOOL 04ea363f9867896226040c9011168ea2755f67706400f9a1d183e1a8a46e97dd9f8ff3e225c933d8c01d609da72c2a2ed7ec15b050bee4c5fbd12f187b1dabf1
-DIST portage-utils-0.55.tar.xz 513336 SHA256 4754aaeda32cc9aaf2fa3943badde51caf84ccf2e03129bd2dc2a5459936baff SHA512 25a5ceabc03b264ff2210ced8307c5a73c739ea3be74ba65f59c70372255e055ccbe25f565420ee1d61490b0baa43d6af8151f8c0a47b3c67a4ff7fff1fce2d0 WHIRLPOOL b437d09cbda38ede3d233639cbada731ac5beef5201db1de37bc80f0041935b141454205d89e31db4b2ddf9c82ec356343d1ce4ee6f937f1679f95225da8910d
DIST portage-utils-0.56.tar.xz 513832 SHA256 4df7323fb2667dd9bcee0f2d169c01ed8600aa6196118e6cd3a10cfe99852bbf SHA512 f2136a7df4cd91499b135fbf000f81a71177d5a39b4da2db484ab0f9492d152eaa72a5fee0e56d4b58611462e251905e554f5e41890a749f05d19e50c16c77b6 WHIRLPOOL af0a96ca3bf2dd39335317829aa8aff110a63042c415368400977e974cc21163da7eb76f7d53fcd05e133fd8a8568255ba022a32f1b174bda0dcb15b5f1476b9
diff --git a/app-portage/portage-utils/portage-utils-0.53.ebuild b/app-portage/portage-utils/portage-utils-0.53.ebuild
deleted file mode 100644
index c7db56737a36..000000000000
--- a/app-portage/portage-utils/portage-utils-0.53.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="4"
-
-inherit flag-o-matic toolchain-funcs eutils
-
-DESCRIPTION="small and fast portage helper tools written in C"
-HOMEPAGE="https://wiki.gentoo.org/wiki/Portage-utils"
-SRC_URI="mirror://gentoo/${P}.tar.xz
- https://dev.gentoo.org/~vapier/dist/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="nls static"
-
-DEPEND="app-arch/xz-utils"
-RDEPEND=""
-
-src_prepare() {
- epatch_user
-}
-
-src_configure() {
- use static && append-ldflags -static
-
- # Avoid slow configure+gnulib+make if on an up-to-date Linux system
- if use prefix || ! use kernel_linux || \
- has_version '<sys-libs/glibc-2.10'
- then
- econf --with-eprefix="${EPREFIX}"
- else
- tc-export CC
- fi
-}
-
-src_compile() {
- emake NLS=$(usex nls)
-}
-
-src_install() {
- default
-
- exeinto /etc/portage/bin
- doexe "${FILESDIR}"/post_sync
- insinto /etc/portage/postsync.d
- doins "${FILESDIR}"/q-reinitialize
-
- # Portage fixes shebangs, we just need to fix the paths in the files
- sed -i \
- -e "s:\(/etc/portage/postsync.d\|/usr/bin/q\):${EPREFIX}&:g" \
- "${ED}"/etc/portage/bin/post_sync \
- "${ED}"/etc/portage/postsync.d/q-reinitialize || die
-}
-
-pkg_preinst() {
- # preserve +x bit on postsync files #301721
- local x
- pushd "${ED}" >/dev/null
- for x in etc/portage/postsync.d/* ; do
- [[ -x ${EROOT}/${x} ]] && chmod +x "${x}"
- done
-}
-
-pkg_postinst() {
- if [[ -z ${REPLACING_VERSIONS} ]] ; then
- elog "${EPREFIX}/etc/portage/postsync.d/q-reinitialize has been installed for convenience"
- elog "If you wish for it to be automatically run at the end of every --sync:"
- elog " # chmod +x ${EPREFIX}/etc/portage/postsync.d/q-reinitialize"
- elog "Normally this should only take a few seconds to run but file systems"
- elog "such as ext3 can take a lot longer. To disable, simply do:"
- elog " # chmod -x ${EPREFIX}/etc/portage/postsync.d/q-reinitialize"
- fi
-}
diff --git a/app-portage/portage-utils/portage-utils-0.54.ebuild b/app-portage/portage-utils/portage-utils-0.54.ebuild
deleted file mode 100644
index 662e8970772c..000000000000
--- a/app-portage/portage-utils/portage-utils-0.54.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="4"
-
-inherit flag-o-matic toolchain-funcs eutils
-
-DESCRIPTION="small and fast portage helper tools written in C"
-HOMEPAGE="https://wiki.gentoo.org/wiki/Portage-utils"
-SRC_URI="mirror://gentoo/${P}.tar.xz
- https://dev.gentoo.org/~vapier/dist/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="nls static"
-
-DEPEND="app-arch/xz-utils"
-RDEPEND=""
-
-src_prepare() {
- epatch_user
-}
-
-src_configure() {
- use static && append-ldflags -static
-
- # Avoid slow configure+gnulib+make if on an up-to-date Linux system
- if use prefix || ! use kernel_linux || \
- has_version '<sys-libs/glibc-2.10'
- then
- econf --with-eprefix="${EPREFIX}"
- else
- tc-export CC
- fi
-}
-
-src_compile() {
- emake NLS=$(usex nls)
-}
-
-src_install() {
- default
-
- exeinto /etc/portage/bin
- doexe "${FILESDIR}"/post_sync
- insinto /etc/portage/postsync.d
- doins "${FILESDIR}"/q-reinitialize
-
- # Portage fixes shebangs, we just need to fix the paths in the files
- sed -i \
- -e "s:\(/etc/portage/postsync.d\|/usr/bin/q\):${EPREFIX}&:g" \
- "${ED}"/etc/portage/bin/post_sync \
- "${ED}"/etc/portage/postsync.d/q-reinitialize || die
-}
-
-pkg_preinst() {
- # preserve +x bit on postsync files #301721
- local x
- pushd "${ED}" >/dev/null
- for x in etc/portage/postsync.d/* ; do
- [[ -x ${EROOT}/${x} ]] && chmod +x "${x}"
- done
-}
-
-pkg_postinst() {
- if [[ -z ${REPLACING_VERSIONS} ]] ; then
- elog "${EPREFIX}/etc/portage/postsync.d/q-reinitialize has been installed for convenience"
- elog "If you wish for it to be automatically run at the end of every --sync:"
- elog " # chmod +x ${EPREFIX}/etc/portage/postsync.d/q-reinitialize"
- elog "Normally this should only take a few seconds to run but file systems"
- elog "such as ext3 can take a lot longer. To disable, simply do:"
- elog " # chmod -x ${EPREFIX}/etc/portage/postsync.d/q-reinitialize"
- fi
-}
diff --git a/app-portage/portage-utils/portage-utils-0.55.ebuild b/app-portage/portage-utils/portage-utils-0.55.ebuild
deleted file mode 100644
index 662e8970772c..000000000000
--- a/app-portage/portage-utils/portage-utils-0.55.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="4"
-
-inherit flag-o-matic toolchain-funcs eutils
-
-DESCRIPTION="small and fast portage helper tools written in C"
-HOMEPAGE="https://wiki.gentoo.org/wiki/Portage-utils"
-SRC_URI="mirror://gentoo/${P}.tar.xz
- https://dev.gentoo.org/~vapier/dist/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="nls static"
-
-DEPEND="app-arch/xz-utils"
-RDEPEND=""
-
-src_prepare() {
- epatch_user
-}
-
-src_configure() {
- use static && append-ldflags -static
-
- # Avoid slow configure+gnulib+make if on an up-to-date Linux system
- if use prefix || ! use kernel_linux || \
- has_version '<sys-libs/glibc-2.10'
- then
- econf --with-eprefix="${EPREFIX}"
- else
- tc-export CC
- fi
-}
-
-src_compile() {
- emake NLS=$(usex nls)
-}
-
-src_install() {
- default
-
- exeinto /etc/portage/bin
- doexe "${FILESDIR}"/post_sync
- insinto /etc/portage/postsync.d
- doins "${FILESDIR}"/q-reinitialize
-
- # Portage fixes shebangs, we just need to fix the paths in the files
- sed -i \
- -e "s:\(/etc/portage/postsync.d\|/usr/bin/q\):${EPREFIX}&:g" \
- "${ED}"/etc/portage/bin/post_sync \
- "${ED}"/etc/portage/postsync.d/q-reinitialize || die
-}
-
-pkg_preinst() {
- # preserve +x bit on postsync files #301721
- local x
- pushd "${ED}" >/dev/null
- for x in etc/portage/postsync.d/* ; do
- [[ -x ${EROOT}/${x} ]] && chmod +x "${x}"
- done
-}
-
-pkg_postinst() {
- if [[ -z ${REPLACING_VERSIONS} ]] ; then
- elog "${EPREFIX}/etc/portage/postsync.d/q-reinitialize has been installed for convenience"
- elog "If you wish for it to be automatically run at the end of every --sync:"
- elog " # chmod +x ${EPREFIX}/etc/portage/postsync.d/q-reinitialize"
- elog "Normally this should only take a few seconds to run but file systems"
- elog "such as ext3 can take a lot longer. To disable, simply do:"
- elog " # chmod -x ${EPREFIX}/etc/portage/postsync.d/q-reinitialize"
- fi
-}