summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/dhcpcd/Manifest1
-rw-r--r--net-misc/dhcpcd/dhcpcd-6.9.4.ebuild121
-rw-r--r--net-misc/dhcpcd/files/dhcpcd-6.9.4-no-ipv6.patch20
3 files changed, 142 insertions, 0 deletions
diff --git a/net-misc/dhcpcd/Manifest b/net-misc/dhcpcd/Manifest
index 7cf8786a6f23..2ce8234ea0fa 100644
--- a/net-misc/dhcpcd/Manifest
+++ b/net-misc/dhcpcd/Manifest
@@ -2,3 +2,4 @@ DIST dhcpcd-6.9.0.tar.bz2 176736 SHA256 1566a58ef785880c07762ff6c520e974cf42872b
DIST dhcpcd-6.9.1.tar.xz 175656 SHA256 c03b750e1fe2890b62ac0e7d7092a1698b598adb6f88b67916586a619f7c066f SHA512 87ecd54fc94eb3fbebbf87c4037da4767f31ca60718c5fd8cc3dcff4c3294edf7808627ef909120b668f1b767f0d588dddb7c1920a971c86bdc83f72b64e33a3 WHIRLPOOL d8ef71fef224101a785c838ae48fbe440e7b3ca0f07d435d0a9f7a3fef458e28c094b08966ac88a25ec92fbadcfc06a52d55c39f5772427958f715d665cfe0e9
DIST dhcpcd-6.9.2.tar.xz 176240 SHA256 e9f82422a35ad1f4f5f888a433a76e98e3cdd4419886c29ccbfb336eecc58a70 SHA512 9eb9dccdd26d9b088cf1bfdcef0ebcb83b8f18f1058a8ce385c3f69ab30682814215c24fbe5903d6a9ee7b4a5fbc93504949513987525515e1f597183e8b6920 WHIRLPOOL 86788c68d92ce774a96806bdcd03ff624ccf632f9bc5627cab218e63824e4da9d997300453de2d0fe299127880dc6d51a1bc9130246bebb425d32e1315f62455
DIST dhcpcd-6.9.3.tar.xz 176320 SHA256 6089471ed695fa62ac8351466b96b4b6365fd14ec455a120a6524663808eae53 SHA512 0a895f17fa093ac758224bfddad003ee25f81fe96331b1952264c3623018e00048603c9a3c5ba385a93441e987b1ce4cd02ec1f42e1caca2e646a6ac4781c3d9 WHIRLPOOL 6de1622444cf393287abbd469016f3c3cc0a99e6ecc4b781c5b9e0389c899365cfefa46e93d16872e6427517f92ff4750e3a246604562922836ae112dbd4349d
+DIST dhcpcd-6.9.4.tar.xz 178632 SHA256 c3f3ff7473ef158a1e71db9aea7424df2c3477ad064e2b542f27948a5abc9ba0 SHA512 27a185b990c8dec847c7c580aa8da11c88796877c963a3cd44d9ff60d84bad29cad4e60bf1d9487d8af0a556fe415b2f449fac9ae71b3e72991fb5d38a72151f WHIRLPOOL dfdb9f952dcac22e4236a2787b51b7fbd3f59172e731bef84955247850db7142b73fb1fb3845d7f65df457e2c9b6f1c6cbacc971d7afb953319d8280967e7fde
diff --git a/net-misc/dhcpcd/dhcpcd-6.9.4.ebuild b/net-misc/dhcpcd/dhcpcd-6.9.4.ebuild
new file mode 100644
index 000000000000..17184cf81251
--- /dev/null
+++ b/net-misc/dhcpcd/dhcpcd-6.9.4.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+if [[ ${PV} == "9999" ]]; then
+ FOSSIL_URI="http://roy.marples.name/projects/dhcpcd"
+else
+ MY_P="${P/_alpha/-alpha}"
+ MY_P="${MY_P/_beta/-beta}"
+ MY_P="${MY_P/_rc/-rc}"
+ SRC_URI="http://roy.marples.name/downloads/${PN}/${MY_P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+inherit eutils systemd toolchain-funcs
+
+DESCRIPTION="A fully featured, yet light weight RFC2131 compliant DHCP client"
+HOMEPAGE="http://roy.marples.name/projects/dhcpcd/"
+LICENSE="BSD-2"
+SLOT="0"
+IUSE="elibc_glibc +embedded ipv6 kernel_linux +udev"
+
+COMMON_DEPEND="udev? ( virtual/udev )"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+
+if [[ ${PV} == "9999" ]]; then
+ DEPEND+=" dev-vcs/fossil"
+
+ src_unpack()
+ {
+ local distdir=${PORTAGE_ACTUAL_DISTDIR:-${DISTDIR}}
+ local repo=${distdir}/fossil/${PN}.fossil
+
+ addwrite "${distdir}"
+
+ if [[ -e "${repo}" ]]; then
+ fossil pull "${FOSSIL_URI}" -R "${repo}" || die
+ else
+ mkdir -p "${distdir}/fossil" || die
+ fossil clone "${FOSSIL_URI}" "${repo}" || die
+ fi
+
+ mkdir -p "${S}" || die
+ cd "${S}" || die
+ fossil open "${repo}" || die
+ }
+fi
+
+src_prepare()
+{
+ epatch "${FILESDIR}"/${P}-no-ipv6.patch
+ epatch_user
+}
+
+src_configure()
+{
+ local dev hooks rundir
+ use udev || dev="--without-dev --without-udev"
+ hooks="--with-hook=ntp.conf"
+ use elibc_glibc && hooks="${hooks} --with-hook=yp.conf"
+ use kernel_linux && rundir="--rundir=${EPREFIX}/run"
+ econf \
+ --prefix="${EPREFIX}" \
+ --libexecdir="${EPREFIX}/lib/dhcpcd" \
+ --dbdir="${EPREFIX}/var/lib/dhcpcd" \
+ --localstatedir="${EPREFIX}/var" \
+ ${rundir} \
+ $(use_enable embedded) \
+ $(use_enable ipv6) \
+ ${dev} \
+ CC="$(tc-getCC)" \
+ ${hooks}
+}
+
+src_install()
+{
+ default
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ systemd_dounit "${FILESDIR}"/${PN}.service
+}
+
+pkg_postinst()
+{
+ # Upgrade the duid file to the new format if needed
+ local old_duid="${ROOT}"/var/lib/dhcpcd/dhcpcd.duid
+ local new_duid="${ROOT}"/etc/dhcpcd.duid
+ if [ -e "${old_duid}" ] && ! grep -q '..:..:..:..:..:..' "${old_duid}"; then
+ sed -i -e 's/\(..\)/\1:/g; s/:$//g' "${old_duid}"
+ fi
+
+ # Move the duid to /etc, a more sensible location
+ if [ -e "${old_duid}" -a ! -e "${new_duid}" ]; then
+ cp -p "${old_duid}" "${new_duid}"
+ fi
+
+ if [ -z "$REPLACING_VERSIONS" ]; then
+ elog
+ elog "dhcpcd has zeroconf support active by default."
+ elog "This means it will always obtain an IP address even if no"
+ elog "DHCP server can be contacted, which will break any existing"
+ elog "failover support you may have configured in your net configuration."
+ elog "This behaviour can be controlled with the noipv4ll configuration"
+ elog "file option or the -L command line switch."
+ elog "See the dhcpcd and dhcpcd.conf man pages for more details."
+
+ elog
+ elog "Dhcpcd has duid enabled by default, and this may cause issues"
+ elog "with some dhcp servers. For more information, see"
+ elog "https://bugs.gentoo.org/show_bug.cgi?id=477356"
+ fi
+
+ if ! has_version net-dns/bind-tools; then
+ elog
+ elog "If you activate the lookup-hostname hook to look up your hostname"
+ elog "using the dns, you need to install net-dns/bind-tools."
+ fi
+}
diff --git a/net-misc/dhcpcd/files/dhcpcd-6.9.4-no-ipv6.patch b/net-misc/dhcpcd/files/dhcpcd-6.9.4-no-ipv6.patch
new file mode 100644
index 000000000000..d0b73f386a89
--- /dev/null
+++ b/net-misc/dhcpcd/files/dhcpcd-6.9.4-no-ipv6.patch
@@ -0,0 +1,20 @@
+Index: dhcp6.h
+==================================================================
+--- dhcp6.h
++++ dhcp6.h
+@@ -252,13 +252,14 @@
+ int dhcp6_dump(struct interface *);
+ #else
+ #define dhcp6_find_delegates(a) {}
+ #define dhcp6_start(a, b) (0)
+ #define dhcp6_reboot(a) {}
++#define dhcp6_renew(a) {}
+ #define dhcp6_env(a, b, c, d, e) {}
+ #define dhcp6_free(a) {}
+ #define dhcp6_dadcompleted(a) (0)
+ #define dhcp6_drop(a, b) {}
+ #define dhcp6_dump(a) (-1)
+ #endif
+
+ #endif
+