summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-visualization/gnuplot/files/gnuplot-5.2.2-regis.patch43
-rw-r--r--sci-visualization/gnuplot/gnuplot-5.2.2.ebuild6
-rw-r--r--sci-visualization/gnuplot/metadata.xml1
3 files changed, 48 insertions, 2 deletions
diff --git a/sci-visualization/gnuplot/files/gnuplot-5.2.2-regis.patch b/sci-visualization/gnuplot/files/gnuplot-5.2.2-regis.patch
new file mode 100644
index 000000000000..613a028ee79b
--- /dev/null
+++ b/sci-visualization/gnuplot/files/gnuplot-5.2.2-regis.patch
@@ -0,0 +1,43 @@
+Add configure option for ReGIS support.
+https://bugs.gentoo.org/643888
+
+--- gnuplot-5.2.2-orig/configure.ac
++++ gnuplot-5.2.2/configure.ac
+@@ -1057,6 +1057,13 @@
+ AC_DEFINE(HAVE_MIF,1,
+ [ Define to include support for mif terminal ],))
+
++dnl ReGIS terminal
++AC_ARG_WITH(regis,dnl
++[ --with-regis ReGIS terminal])
++AS_IF([test "x${with_regis}" = "xyes"],
++ AC_DEFINE(HAVE_REGIS,1,
++ [ Define to include support for ReGIS terminal ],))
++
+ AC_ARG_WITH(cairo,dnl
+ [ --without-cairo cairo-based terminals (default enabled)],,
+ [test -z "${with_cairo}" && with_cairo=yes])
+@@ -1350,6 +1357,12 @@
+ AC_MSG_RESULT([ mif terminal: no (use --with-mif to enable)])
+ fi
+
++if test "$with_regis" = yes; then
++ AC_MSG_RESULT([ ReGIS terminal: yes])
++else
++ AC_MSG_RESULT([ ReGIS terminal: no (use --with-regis to enable)])
++fi
++
+ if test "$is_msdos" = yes; then
+ AC_MSG_RESULT([ svga terminal (MSDOS/djgpp): yes])
+ fi
+--- gnuplot-5.2.2-orig/src/term.h
++++ gnuplot-5.2.2/src/term.h
+@@ -182,7 +182,7 @@
+ #endif
+
+ /* REGIS graphics language */
+-#ifdef VMS
++#if defined(VMS) || defined(HAVE_REGIS)
+ # include "regis.trm"
+ #endif
+
diff --git a/sci-visualization/gnuplot/gnuplot-5.2.2.ebuild b/sci-visualization/gnuplot/gnuplot-5.2.2.ebuild
index 9948859c4837..ee0a6fd16570 100644
--- a/sci-visualization/gnuplot/gnuplot-5.2.2.ebuild
+++ b/sci-visualization/gnuplot/gnuplot-5.2.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -26,7 +26,7 @@ fi
LICENSE="gnuplot bitmap? ( free-noncomm )"
SLOT="0"
-IUSE="aqua bitmap cairo compat doc examples +gd ggi latex libcaca libcerf lua qt5 readline svga wxwidgets X"
+IUSE="aqua bitmap cairo compat doc examples +gd ggi latex libcaca libcerf lua qt5 readline regis svga wxwidgets X"
RDEPEND="
cairo? (
@@ -73,6 +73,7 @@ TEXMF="${EPREFIX}/usr/share/texmf-site"
src_prepare() {
eapply "${FILESDIR}"/${PN}-5.0.1-fix-underlinking.patch
eapply "${FILESDIR}"/${PN}-5.0.6-no-picins.patch
+ eapply "${FILESDIR}"/${PN}-5.2.2-regis.patch
eapply_user
if [[ -z ${PV%%*9999} ]]; then
@@ -138,6 +139,7 @@ src_configure() {
"$(use_with libcaca caca "${EPREFIX}/usr/$(get_libdir)")" \
$(use_with libcerf) \
$(use_with lua) \
+ $(use_with regis) \
$(use_with svga linux-vga) \
$(use_with X x) \
--enable-stats \
diff --git a/sci-visualization/gnuplot/metadata.xml b/sci-visualization/gnuplot/metadata.xml
index 8700ea957399..6442566e482f 100644
--- a/sci-visualization/gnuplot/metadata.xml
+++ b/sci-visualization/gnuplot/metadata.xml
@@ -27,6 +27,7 @@
<flag name="libcerf">Enable special functions from
<pkg>sci-libs/libcerf</pkg></flag>
<flag name="bitmap">Enable dot-matrix printers and pbm terminal</flag>
+ <flag name="regis">Enable ReGIS terminal</flag>
</use>
<upstream>
<remote-id type="sourceforge">gnuplot</remote-id>