summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-tex/latex2html/files/latex2html-2017.2-brace.patch36
-rw-r--r--dev-tex/latex2html/files/latex2html-2017.2-dotinc-2.patch12
-rw-r--r--dev-tex/latex2html/files/latex2html-2017.2-dotinc.patch33
-rw-r--r--dev-tex/latex2html/latex2html-2017.2-r1.ebuild81
4 files changed, 162 insertions, 0 deletions
diff --git a/dev-tex/latex2html/files/latex2html-2017.2-brace.patch b/dev-tex/latex2html/files/latex2html-2017.2-brace.patch
new file mode 100644
index 000000000000..4782fb313e79
--- /dev/null
+++ b/dev-tex/latex2html/files/latex2html-2017.2-brace.patch
@@ -0,0 +1,36 @@
+diff -ruN latex2html-2017.2.orig/versions/html3_2.pl latex2html-2017.2/versions/html3_2.pl
+--- latex2html-2017.2.orig/versions/html3_2.pl 2017-01-23 17:14:25.000000000 -0000
++++ latex2html-2017.2/versions/html3_2.pl 2017-08-04 09:38:17.219909442 -0000
+@@ -607,7 +607,7 @@
+
+ if ($color_env) {
+ local($color_test) = join(',',@$open_tags_R);
+- if ($color_test =~ /(color{[^}]*})/g ) {
++ if ($color_test =~ /(color\{[^}]*})/g ) {
+ $color_env = $1;
+ }
+ }
+diff -ruN latex2html-2017.2.orig/versions/html4_01.pl latex2html-2017.2/versions/html4_01.pl
+--- latex2html-2017.2.orig/versions/html4_01.pl 2017-01-23 17:14:25.000000000 -0000
++++ latex2html-2017.2/versions/html4_01.pl 2017-08-04 09:39:32.529023088 -0000
+@@ -976,7 +976,7 @@
+
+ if ($color_env) {
+ local($color_test) = join(',',@$open_tags_R);
+- if ($color_test =~ /(color{[^}]*})/g ) {
++ if ($color_test =~ /(color\{[^}]*})/g ) {
+ $color_env = $1;
+ }
+ }
+diff -ruN latex2html-2017.2.orig/versions/html4_1.pl latex2html-2017.2/versions/html4_1.pl
+--- latex2html-2017.2.orig/versions/html4_1.pl 2017-01-23 17:14:25.000000000 -0000
++++ latex2html-2017.2/versions/html4_1.pl 2017-08-04 09:37:48.507866114 -0000
+@@ -976,7 +976,7 @@
+
+ if ($color_env) {
+ local($color_test) = join(',',@$open_tags_R);
+- if ($color_test =~ /(color{[^}]*})/g ) {
++ if ($color_test =~ /(color\{[^}]*})/g ) {
+ $color_env = $1;
+ }
+ }
diff --git a/dev-tex/latex2html/files/latex2html-2017.2-dotinc-2.patch b/dev-tex/latex2html/files/latex2html-2017.2-dotinc-2.patch
new file mode 100644
index 000000000000..2e58c0070d7d
--- /dev/null
+++ b/dev-tex/latex2html/files/latex2html-2017.2-dotinc-2.patch
@@ -0,0 +1,12 @@
+diff -ruN latex2html-2017.2.orig/configure latex2html-2017.2/configure
+--- latex2html-2017.2.orig/configure 2017-01-23 17:14:25.000000000 -0000
++++ latex2html-2017.2/configure 2017-08-04 09:21:02.929355288 -0000
+@@ -1225,7 +1225,7 @@
+ fi
+
+ # this is used to get the values from the config file
+-eval `perl -w -e 'use cfgcache; foreach(keys %cfg) { print qq($_='"'"'$cfg{$_}'"'"'\n);}'`
++eval `perl -w -e 'use lib q[.]; use cfgcache; foreach(keys %cfg) { print qq($_='"'"'$cfg{$_}'"'"'\n);}'`
+
+
+
diff --git a/dev-tex/latex2html/files/latex2html-2017.2-dotinc.patch b/dev-tex/latex2html/files/latex2html-2017.2-dotinc.patch
new file mode 100644
index 000000000000..e7f29ad5779c
--- /dev/null
+++ b/dev-tex/latex2html/files/latex2html-2017.2-dotinc.patch
@@ -0,0 +1,33 @@
+diff -ruN latex2html-2017.2.orig/config/build.pl latex2html-2017.2/config/build.pl
+--- latex2html-2017.2.orig/config/build.pl 2017-01-23 17:14:25.000000000 -0000
++++ latex2html-2017.2/config/build.pl 2017-08-04 09:13:26.040867263 -0000
+@@ -145,6 +145,7 @@
+ # Read in the system's configuration
+ use FindBin;
+ use lib "$FindBin::Bin/..";
++use lib "$FindBin::Bin";
+ use cfgcache;
+
+ my $dd = $cfg{'dd'};
+diff -ruN latex2html-2017.2.orig/config/config.pl latex2html-2017.2/config/config.pl
+--- latex2html-2017.2.orig/config/config.pl 2017-01-23 17:14:25.000000000 -0000
++++ latex2html-2017.2/config/config.pl 2017-08-04 09:13:45.500980317 -0000
+@@ -435,6 +435,7 @@
+
+ use FindBin;
+ use lib "$FindBin::Bin/..";
++use lib "$FindBin::Bin";
+ use L2hos;
+
+ #use diagnostics;
+diff -ruN latex2html-2017.2.orig/config/install.pl latex2html-2017.2/config/install.pl
+--- latex2html-2017.2.orig/config/install.pl 2017-08-04 09:08:53.608284554 -0000
++++ latex2html-2017.2/config/install.pl 2017-08-04 09:13:57.116047796 -0000
+@@ -183,6 +183,7 @@
+
+ use FindBin;
+ use lib "$FindBin::Bin/..";
++use lib "$FindBin::Bin";
+ use cfgcache;
+ use L2hos;
+
diff --git a/dev-tex/latex2html/latex2html-2017.2-r1.ebuild b/dev-tex/latex2html/latex2html-2017.2-r1.ebuild
new file mode 100644
index 000000000000..ff150f6a652d
--- /dev/null
+++ b/dev-tex/latex2html/latex2html-2017.2-r1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Convertor written in Perl that converts LATEX documents to HTML"
+HOMEPAGE="http://www.latex2html.org/"
+SRC_URI="http://mirrors.ctan.org/support/latex2html/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="gif png"
+
+DEPEND="app-text/ghostscript-gpl
+ virtual/latex-base
+ media-libs/netpbm
+ dev-lang/perl
+ gif? ( media-libs/giflib )
+ png? ( media-libs/libpng:0 )"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}"-{destdir,tests}.patch
+ "${FILESDIR}/${P}"-dotinc.patch
+ "${FILESDIR}/${P}"-dotinc-2.patch
+ "${FILESDIR}/${P}"-brace.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i -e 's%@PERL@%'"${EPREFIX}"'/usr/bin/perl%g' wrapper/unix.pin || die
+}
+
+src_configure() {
+ local myconf
+
+ use gif || use png || myconf="${myconf} --disable-images"
+
+ econf --libdir="${EPREFIX}"/usr/$(get_libdir)/latex2html \
+ --shlibdir="${EPREFIX}"/usr/$(get_libdir)/latex2html \
+ --enable-pk \
+ --enable-eps \
+ --enable-reverse \
+ --enable-pipes \
+ --enable-paths \
+ --enable-wrapper \
+ --with-texpath="${EPREFIX}"/usr/share/texmf-site/tex/latex/html \
+ --without-mktexlsr \
+ $(use_enable gif) \
+ $(use_enable png) \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ # make /usr/share/latex2html sticky
+ keepdir /usr/share/latex2html
+
+ # clean the perl scripts up to remove references to the sandbox
+ local dir="${ED}/usr/$(get_libdir)/latex2html"
+ if use png || use gif; then
+ # pstoimg isn't built unless gif or png useflags are enabled
+ sed -i -e "s:${T}:/tmp:g" "${dir}"/pstoimg.pl || die
+ fi
+ sed -i -e "s:${S}::g" "${dir}"/latex2html.pl || die
+ sed -i -e "s:${T}:/tmp:g" "${dir}"/cfgcache.pm || die
+ sed -i -e "s:${T}:/tmp:g" "${dir}"/l2hconf.pm || die
+
+ dodoc BUGS Changes FAQ MANIFEST README.md TODO
+}
+
+pkg_postinst() {
+ "${EROOT}"/usr/bin/mktexlsr
+}
+
+pkg_postrm() {
+ "${EROOT}"/usr/bin/mktexlsr
+}