summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-benchmarks/stress-ng/Manifest1
-rw-r--r--app-benchmarks/stress-ng/files/stress-ng-0.11.19-optimization-checks.patch87
-rw-r--r--app-benchmarks/stress-ng/stress-ng-0.11.19.ebuild44
3 files changed, 0 insertions, 132 deletions
diff --git a/app-benchmarks/stress-ng/Manifest b/app-benchmarks/stress-ng/Manifest
index badb00724f83..8765c676141a 100644
--- a/app-benchmarks/stress-ng/Manifest
+++ b/app-benchmarks/stress-ng/Manifest
@@ -1,2 +1 @@
-DIST stress-ng-0.11.19.tar.xz 475692 BLAKE2B 711e9532655e8b76c44d06a86c773e2a2d5c19cf08dec693f7aacf100060ed492fc7ace8244897d4b342a3f1cae8e3f81314cb5b792253957c1622621bd1f6c0 SHA512 eefb331699faccaaa98775e14e4f33f5cc99b86ec8feb8f1c34b6cb7d20f061c576f8fcd683e51740fa662fb54d987bed36b9d87ad13a1b39b4fe66e60177ab1
DIST stress-ng-0.11.20.tar.xz 480540 BLAKE2B 97ef2726ae5882c405ac752b56fa14e1a08a428b2ff2685b2d513438394b86184aa412ce97ea428a6ab4ec42c29c6bd4f5c28da9331c27c477d29a8fbe070a74 SHA512 08dda9ec44d9bde873b0186c4dbf3b15090c261316f0ec0ceed5378d31780b85038f898957c892393fef593ad5c913d044c1db8e2b60c68d88f5678d0209b6ac
diff --git a/app-benchmarks/stress-ng/files/stress-ng-0.11.19-optimization-checks.patch b/app-benchmarks/stress-ng/files/stress-ng-0.11.19-optimization-checks.patch
deleted file mode 100644
index 18bd02ae9d57..000000000000
--- a/app-benchmarks/stress-ng/files/stress-ng-0.11.19-optimization-checks.patch
+++ /dev/null
@@ -1,87 +0,0 @@
-From 70acc386b6afb726d4576a3d4368b51114e92530 Mon Sep 17 00:00:00 2001
-From: Colin Ian King <colin.king@canonical.com>
-Date: Tue, 1 Sep 2020 12:54:19 +0100
-Subject: [PATCH] stress-ng.h: build in target clone types if gcc supports the
- feature
-
-Add in more build time optimization checks, try to build smarter with
-various gcc compatibility support checks.
-
-Signed-off-by: Colin Ian King <colin.king@canonical.com>
----
- stress-ng.h | 62 ++++++++++++++++++++++++++++++++++++++++++++++++++++-
- 1 file changed, 61 insertions(+), 1 deletion(-)
-
-diff --git a/stress-ng.h b/stress-ng.h
-index 3803bc71..6ce7d72e 100644
---- a/stress-ng.h
-+++ b/stress-ng.h
-@@ -1686,7 +1686,67 @@ extern void pr_dbg_lock(bool *locked, const char *fmt, ...) FORMAT(printf, 2, 3
-
- /* GCC5.0+ target_clones attribute */
- #if defined(HAVE_TARGET_CLONES) && defined(STRESS_ARCH_X86)
--#define TARGET_CLONES __attribute__((target_clones("mmx","sse","sse2","ssse3", "sse4.1", "sse4a", "avx", "avx2", "arch=skylake-avx512", "default")))
-+#if defined(__MMX_WITH_SSE__)
-+#define TARGET_CLONE_MMX "mmx",
-+#else
-+#define TARGET_CLONE_MMX
-+#endif
-+
-+#if defined(__AVX__)
-+#define TARGET_CLONE_AVX "avx",
-+#else
-+#define TARGET_CLONE_AVX
-+#endif
-+
-+#if defined(__AVX2__)
-+#define TARGET_CLONE_AVX2 "avx2",
-+#else
-+#define TARGET_CLONE_AVX2
-+#endif
-+
-+#if defined(__SSE__)
-+#define TARGET_CLONE_SSE "sse",
-+#else
-+#define TARGET_CLONE_SSE
-+#endif
-+
-+#if defined(__SSE2__)
-+#define TARGET_CLONE_SSE2 "sse2",
-+#else
-+#define TARGET_CLONE_SSE2
-+#endif
-+
-+#if defined(__SSE3__)
-+#define TARGET_CLONE_SSE3 "sse3",
-+#else
-+#define TARGET_CLONE_SSE3
-+#endif
-+
-+#if defined(__SSSE3__)
-+#define TARGET_CLONE_SSSE3 "ssse3",
-+#else
-+#define TARGET_CLONE_SSSE3
-+#endif
-+
-+#if defined(__SSE4_1__)
-+#define TARGET_CLONE_SSE4_1 "sse4.1",
-+#else
-+#define TARGET_CLONE_SSE4_1
-+#endif
-+
-+#if defined(__SSE4_2__)
-+#define TARGET_CLONE_SSE4_2 "sse4.2",
-+#else
-+#define TARGET_CLONE_SSE4_2
-+#endif
-+
-+#if defined(__AVX512F__)
-+#define TARGET_CLONE_SKYLAKE_AVX512 "arch=skylake-avx512",
-+#else
-+#define TARGET_CLONE_SKYLAKE_AVX512
-+#endif
-+
-+#define TARGET_CLONES __attribute__((target_clones(TARGET_CLONE_AVX TARGET_CLONE_AVX2 TARGET_CLONE_MMX TARGET_CLONE_SSE TARGET_CLONE_SSE2 TARGET_CLONE_SSE3 TARGET_CLONE_SSSE3 TARGET_CLONE_SSE4_1 TARGET_CLONE_SSE4_2 TARGET_CLONE_SKYLAKE_AVX512 "default")))
- #elif defined(HAVE_TARGET_CLONES) && defined(STRESS_ARCH_PPC64)
- #define TARGET_CLONES __attribute__((target_clones("cpu=power9,default")))
- #else
diff --git a/app-benchmarks/stress-ng/stress-ng-0.11.19.ebuild b/app-benchmarks/stress-ng/stress-ng-0.11.19.ebuild
deleted file mode 100644
index 45fa78dbb290..000000000000
--- a/app-benchmarks/stress-ng/stress-ng-0.11.19.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit optfeature toolchain-funcs
-
-DESCRIPTION="Stress test for a computer system with various selectable ways"
-HOMEPAGE="https://kernel.ubuntu.com/~cking/stress-ng/"
-SRC_URI="https://kernel.ubuntu.com/~cking/tarballs/${PN}/${P}.tar.xz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
-
-DEPEND="
- dev-libs/libaio
- dev-libs/libbsd
- dev-libs/libgcrypt:0=
- sys-apps/attr
- sys-apps/keyutils:=
- sys-libs/libcap
- sys-libs/zlib
-"
-
-RDEPEND="${DEPEND}"
-
-DOCS=( "README" "README.Android" "TODO" "syscalls.txt" )
-
-PATCHES=(
- "${FILESDIR}/${PN}-0.11.17-makefile.patch"
- "${FILESDIR}/${PN}-0.11.19-optimization-checks.patch"
-)
-
-src_compile() {
- tc-export CC
-
- default
-}
-
-pkg_postinst() {
- optfeature "AppArmor support" sys-libs/libapparmor
- optfeature "SCTP support" net-misc/lksctp-tools
-}