summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-libs/nghttp2/Manifest1
-rw-r--r--net-libs/nghttp2/nghttp2-1.17.0.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/net-libs/nghttp2/Manifest b/net-libs/nghttp2/Manifest
index e4e083e774b2..1ca5211f9ade 100644
--- a/net-libs/nghttp2/Manifest
+++ b/net-libs/nghttp2/Manifest
@@ -1,4 +1,5 @@
DIST nghttp2-1.10.0.tar.gz 2086580 SHA256 192dc031e71e182240079befae9db7e64c9951da3a83c7a438f57cf76145b6a8 SHA512 4341f76ead38ba30e0dfda492e2e0f4c842f453e235fa90ee55b1e556092828236f21c6b212d0099cea005f149e4be3e63ad007009dd5228999101e563009a6f WHIRLPOOL 603391b0d15883cd9db734a0e4bb7d994c17ae4209d5251504e29cc59e0ccf67488b9340acefdb6d6603e9e7d3b0a0491ed18330edce4d20adb0ed19ffc5b975
DIST nghttp2-1.16.0.tar.gz 2150767 SHA256 02b829d8cdb93ed4598e5209d8932bd272f706d3c183787378209f988e01f007 SHA512 9397d584e6062996af01a3c403c637c5ba7ef822d0df1a9ee8066079c00e3bf5171cd5c43cb6a1ef40ce16aac78a73eb89206aa3b61b317b7f81647c36c6e08d WHIRLPOOL af5d92d7e6b2fc146dda2391530e71dbc021749335dc123935b572de25cb2bdf4b37e40f5aa8c5da91a2080e33d35f630c161d1f62a701d410b283bee01e55da
DIST nghttp2-1.16.1.tar.gz 2145926 SHA256 c690d89f653722e335c36aec861d5f1769cfdb9ea873d9874ffa54dac4532cf3 SHA512 efc14020c842e2ba039fe75281103905fb2a38711d5cc5980b899e44f6dd5e409d5ae1544fd3b1a66dc4abc1310cdcddb56c4d6d58b9a3fb12e517edaefebe1c WHIRLPOOL b8229aa612f310b23361d362806cbe7f9a56f4011ae60b82f8e6ba43fa0c3ee3e7148dc0525b584f68af875f20aa9f64fd8de56587f7b3b216413b0e383875c8
+DIST nghttp2-1.17.0.tar.gz 2150137 SHA256 d7f1c3ea4ca8325998607140284e8640743366cc9ec87fbbcc11842e6106f2c4 SHA512 c2da7edfe802f8c3078f09b1fd31cbe18cf60779d3f3b1e5083bc4bdf12b180e9cd8e7785ee76820421de4ad8480e747b81feb15a5098002d40e7ab0bace3719 WHIRLPOOL fa08d48c7ba4cf8aa4ad8f29758102b489b7d2ff91c66882baf40d1d1a498f0f54111390674716baaa28d02531dbe07e4ef8933c9dd50c8dbfba17e158b29807
DIST nghttp2-1.7.1.tar.gz 1993320 SHA256 d83858464c03555828bb603288b66a48680bf164b376d2459a5407c102098a14 SHA512 3a71153d2b30a69e79115402b7db9a04bc812025ccb67b918079f33690f18eb5b286095b8bc161df91abf6466b6bb822ecc13c49bee54265a06ba9ab7c289b54 WHIRLPOOL 41d0afd43878029069d2c339e22b8aec77fedbd1b0fb45da96b9592525c760731e2eec567999af704d63cf94c913b1d0c52063380e69170e1f2d2b928c1d70f3
diff --git a/net-libs/nghttp2/nghttp2-1.17.0.ebuild b/net-libs/nghttp2/nghttp2-1.17.0.ebuild
new file mode 100644
index 000000000000..1fae52de3253
--- /dev/null
+++ b/net-libs/nghttp2/nghttp2-1.17.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# TODO: Add python support.
+
+EAPI=6
+
+inherit multilib-minimal
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/tatsuhiro-t/nghttp2.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/tatsuhiro-t/nghttp2/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+DESCRIPTION="HTTP/2 C Library"
+HOMEPAGE="https://nghttp2.org/"
+
+LICENSE="MIT"
+SLOT="0/1.14" # <C++>.<C> SONAMEs
+IUSE="cxx debug hpack-tools jemalloc libressl static-libs test +threads utils xml"
+
+RDEPEND="
+ cxx? ( dev-libs/boost:=[${MULTILIB_USEDEP},threads] )
+ hpack-tools? ( >=dev-libs/jansson-2.5 )
+ jemalloc? ( dev-libs/jemalloc[${MULTILIB_USEDEP}] )
+ utils? (
+ >=dev-libs/libev-4.15[${MULTILIB_USEDEP}]
+ !libressl? ( >=dev-libs/openssl-1.0.2:0[-bindist,${MULTILIB_USEDEP}] )
+ libressl? ( dev-libs/libressl[${MULTILIB_USEDEP}] )
+ >=sys-libs/zlib-1.2.3[${MULTILIB_USEDEP}]
+ )
+ xml? ( >=dev-libs/libxml2-2.7.7:2[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf \
+ --disable-examples \
+ --disable-failmalloc \
+ --disable-werror \
+ --without-cython \
+ --disable-python-bindings \
+ --without-spdylay \
+ $(use_enable cxx asio-lib) \
+ $(use_enable debug) \
+ $(multilib_native_use_enable hpack-tools) \
+ $(use_enable static-libs static) \
+ $(use_enable threads) \
+ $(multilib_native_use_enable utils app) \
+ $(multilib_native_use_with jemalloc) \
+ $(multilib_native_use_with xml libxml2)
+}
+
+multilib_src_install_all() {
+ use static-libs || find "${ED}"/usr -name '*.la' -delete
+}