summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/xcffib/Manifest2
-rw-r--r--dev-python/xcffib/xcffib-0.1.10.ebuild27
-rw-r--r--dev-python/xcffib/xcffib-0.2.5.ebuild35
3 files changed, 0 insertions, 64 deletions
diff --git a/dev-python/xcffib/Manifest b/dev-python/xcffib/Manifest
index f710f4c695b7..1be3050cb584 100644
--- a/dev-python/xcffib/Manifest
+++ b/dev-python/xcffib/Manifest
@@ -1,3 +1 @@
-DIST xcffib-0.1.10.tar.gz 69476 SHA256 32265750c67df13dec50b4fe4d72187cb9e38ae303a1b3b2c146ace56a225f69 SHA512 261dcf7fd7b650beba04deafd37d995ba43f0136f779230ec176c6988883d48ebb6c3bf1c79fa695822612cc8767a54f05d55206dfa8ee12f20272210d722ee1 WHIRLPOOL 5722397105a445d5e0a50af0e38f60372fc8b16658a6bf761226bee452e1e30bb689fd3ea652b4c57fa2e4131a7331efc0ac56ffcef05f7430b9021661d29aad
-DIST xcffib-0.2.5.tar.gz 72026 SHA256 7f2ff0923d27f76b04cc546729f9d106da84b7214c25ae1cf71502dda4fff988 SHA512 5323e983f5e400675a656a92b89551c80b4fe62ab29028799c63ef26f3cbfa9b2338935a57068d410f90f8afe2c31797987fbe33d68350a88db12df6701fb98a WHIRLPOOL eb0ff753ee595ac3bb12c9e9de036739577ad0926fdce22bafee6ab4b3b5e670df633d6f351ede2e65eff9051302594b97b8aaa9f7b432801266cce197032a82
DIST xcffib-0.3.4.tar.gz 65481 SHA256 9c54f835351a1622495322f314ee58ca5cb498fe8a2123a3905a25c1fd66850b SHA512 7c70dc6ae37531e6e9649a9055e4740872fc071620825d647525a236cad95e24e2c5f950e5f916b3742588a3c79363fe56431aba0488d939930398022c832be2 WHIRLPOOL 9b99ae6959bea33df013f21f897edba89d0b66b775ed1c019f5c2a61a23293fb26a0bf3311aa225a05e862bac95ac3d4bcad50023a56dde83a2b12b968b4a987
diff --git a/dev-python/xcffib/xcffib-0.1.10.ebuild b/dev-python/xcffib/xcffib-0.1.10.ebuild
deleted file mode 100644
index 860193b7b465..000000000000
--- a/dev-python/xcffib/xcffib-0.1.10.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="A drop in replacement for xpyb, an XCB python binding"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-HOMEPAGE="https://github.com/tych0/xcffib"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-
-COMMON_DEPEND="x11-libs/libxcb"
-
-RDEPEND="
- $(python_gen_cond_dep '>=dev-python/cffi-0.8.2:=[${PYTHON_USEDEP}]' 'python*')
- dev-python/six[${PYTHON_USEDEP}]
- ${COMMON_DEPEND}"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- ${COMMON_DEPEND}"
diff --git a/dev-python/xcffib/xcffib-0.2.5.ebuild b/dev-python/xcffib/xcffib-0.2.5.ebuild
deleted file mode 100644
index 1246ebebd1bf..000000000000
--- a/dev-python/xcffib/xcffib-0.2.5.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-
-PYTHON_COMPAT=( python2_7 python3_{3,4} pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="A drop in replacement for xpyb, an XCB python binding"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-HOMEPAGE="https://github.com/tych0/xcffib"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-COMMON_DEPEND="x11-libs/libxcb"
-
-RDEPEND="
- $(python_gen_cond_dep '>=dev-python/cffi-0.8.2:=[${PYTHON_USEDEP}]' 'python*')
- $(python_gen_cond_dep '<dev-python/cffi-1:=[${PYTHON_USEDEP}]' 'python*')
- $(python_gen_cond_dep '<virtual/pypy-2.6.0' pypy )
- dev-python/six[${PYTHON_USEDEP}]
- ${COMMON_DEPEND}"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- ${COMMON_DEPEND}
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-python_test() {
- nosetests -d -v || die
-}