summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-firewall/firehol/Manifest1
-rw-r--r--net-firewall/firehol/files/firehol-2.0.2-autosave.patch18
-rw-r--r--net-firewall/firehol/firehol-2.0.3-r1.ebuild61
3 files changed, 0 insertions, 80 deletions
diff --git a/net-firewall/firehol/Manifest b/net-firewall/firehol/Manifest
index 0c6391f12459..8d9659209610 100644
--- a/net-firewall/firehol/Manifest
+++ b/net-firewall/firehol/Manifest
@@ -1,2 +1 @@
-DIST firehol-2.0.3.tar.xz 898248 SHA256 4bcc2d19ee7d41377f19c3bcd3ae882ba10dd3ebed6eac2deedbce202d1a3d72 SHA512 fab1ddea6d60d5cb91eacc73f79549f454abc7d581c696463f4396465257a708af175f18da7aa2c6ddc3dddc68b21528edb043a3fe539d16f5057e4f0c0db0b6 WHIRLPOOL 50556da7e392575ef2e36a489e544295f909c8621be5e7c91ad8b00f99879d1eebe59076948d8e58839869771547e85c425262438eb5f79d4b2bd8f2bb0009f8
DIST firehol-3.1.3.tar.xz 1476220 SHA256 4693d7238d411ffcaacd1febf7231a9e69657e8b198f1b0726429bdb258372e7 SHA512 6c75b57650d918cfc485f6eb01d69694acd5c7b487a10a566fc26b8d5e0cd6a6a9a09bd8d3219bf4e78aa4fe47f83e5ac399107a07770b787e1ccba3078c5f3f WHIRLPOOL b14628fe4e9f7d0b45231a0720b4142dfd41edadd5bafd74650c8af2c67b5a535b8c32e03c696a06332455b18b18900c063a7cdbeb7582c15b409a83cfea83b7
diff --git a/net-firewall/firehol/files/firehol-2.0.2-autosave.patch b/net-firewall/firehol/files/firehol-2.0.2-autosave.patch
deleted file mode 100644
index f552b2b167b3..000000000000
--- a/net-firewall/firehol/files/firehol-2.0.2-autosave.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-diff -urNp firehol-2.0.1/sbin/firehol.in firehol-2.0.1.new/sbin/firehol.in
---- firehol-2.0.1/sbin/firehol.in 2015-02-15 17:08:03.000000000 +0200
-+++ firehol-2.0.1.new/sbin/firehol.in 2015-04-14 18:05:22.262234003 +0300
-@@ -846,12 +846,12 @@ test -z "$FIREHOL_ROUTING" && \
- # Where /etc/init.d/iptables expects its configuration?
- # Leave it empty for automatic detection
- test -z "$FIREHOL_AUTOSAVE" && \
-- FIREHOL_AUTOSAVE=
-+ FIREHOL_AUTOSAVE="@FIREHOL_AUTOSAVE@"
-
- # Where /etc/init.d/ip6tables expects its configuration?
- # Leave it empty for automatic detection
- test -z "$FIREHOL_AUTOSAVE6" && \
-- FIREHOL_AUTOSAVE6=
-+ FIREHOL_AUTOSAVE6="@FIREHOL_AUTOSAVE6@"
-
- # Set to non-empty to wait (max 60 seconds) for a network interface
- test -z "$WAIT_FOR_IFACE" && \
diff --git a/net-firewall/firehol/firehol-2.0.3-r1.ebuild b/net-firewall/firehol/firehol-2.0.3-r1.ebuild
deleted file mode 100644
index ad90b0638faa..000000000000
--- a/net-firewall/firehol/firehol-2.0.3-r1.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit eutils linux-info
-
-DESCRIPTION="iptables firewall generator"
-HOMEPAGE="http://firehol.sourceforge.net/"
-SRC_URI="http://firehol.org/download/releases/v${PV}/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="doc"
-KEYWORDS="amd64 ~ppc ~sparc x86"
-
-RDEPEND="net-firewall/iptables
- sys-apps/iproute2[-minimal]
- virtual/modutils
- app-arch/gzip"
-DEPEND="${RDEPEND}"
-
-pkg_setup() {
- local KCONFIG_OPTS="~NF_CONNTRACK_IPV4 ~NF_CONNTRACK_MARK ~NF_NAT ~NF_NAT_FTP ~NF_NAT_IRC \
- ~IP_NF_IPTABLES ~IP_NF_FILTER ~IP_NF_TARGET_REJECT ~IP_NF_TARGET_LOG ~IP_NF_TARGET_ULOG \
- ~IP_NF_TARGET_MASQUERADE ~IP_NF_TARGET_REDIRECT ~IP_NF_MANGLE \
- ~NETFILTER_XT_MATCH_LIMIT ~NETFILTER_XT_MATCH_STATE ~NETFILTER_XT_MATCH_OWNER"
-
- get_version
- if [ ${KV_PATCH} -ge 25 ]; then
- CONFIG_CHECK="~NF_CONNTRACK ${KCONFIG_OPTS}"
- else
- CONFIG_CHECK="~NF_CONNTRACK_ENABLED ${KCONFIG_OPTS}"
- fi
- linux-info_pkg_setup
-}
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-2.0.2-autosave.patch"
-}
-
-src_configure() {
- # removing IP6TABLES_CMD has no effect and enable build
- # without ipv6 available
- econf \
- --docdir="${EPREFIX}/usr/share/doc/${PF}" \
- --with-autosave="${EPREFIX}/var/lib/iptables/rules-save" \
- --with-autosave6="${EPREFIX}/var/lib/ip6tables/rules-save" \
- $(use_enable doc) \
- IP6TABLES_CMD=/bin/false \
- IP6TABLES_SAVE_CMD=/bin/false \
- IP6TABLES_RESTORE_CMD=/bin/false
-}
-
-src_install() {
- default
-
- newconfd "${FILESDIR}"/firehol.conf.d firehol
- newinitd "${FILESDIR}"/firehol.initrd firehol
- newconfd "${FILESDIR}"/fireqos.conf.d fireqos
- newinitd "${FILESDIR}"/fireqos.initrd fireqos
-}