summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/txaio/Manifest3
-rw-r--r--dev-python/txaio/txaio-1.0.0.ebuild46
-rw-r--r--dev-python/txaio/txaio-2.2.0.ebuild48
-rw-r--r--dev-python/txaio/txaio-2.2.1.ebuild48
4 files changed, 0 insertions, 145 deletions
diff --git a/dev-python/txaio/Manifest b/dev-python/txaio/Manifest
index 47e16c22ba17..09ed69ee9ea2 100644
--- a/dev-python/txaio/Manifest
+++ b/dev-python/txaio/Manifest
@@ -1,5 +1,2 @@
-DIST txaio-1.0.0.zip 33656 SHA256 4b38afc5d416b23426ed4e7f582d949317df5173c50efec999f2cc97ed368a57 SHA512 7ca543721139e3da96e86d3d2feafbd0901df7a48585f43f46407a17c226e24bbd18841c50bf911c3f208d614c9e32bfc0a7bee37b03b9ddea87a8a47e940572 WHIRLPOOL d11ea36f27d26566a5dcce83751a723ac2e33c51ecc7019b95d66014850e94fc820ae44b36cbbe3c5a3f5b86de666a2b59cec29194ca3d4b9d39908bb47b2556
-DIST txaio-2.2.0.tar.gz 33225 SHA256 5aa536f69d7a52bfe528863e783f20a70138269ed97d134222fdab6afa0dfe14 SHA512 13c4345fa0e64e86cecfa56e3cfa02ed088eed37dee582cc62b35b9e0984041a458ee837cdcb4ae56966e102f504b0cce8750d5ba8240c83815ca076d2deb979 WHIRLPOOL e75c5fc76f294d17e156b58fe69bb4719bc36a3966367b5e930bb9fef8e026d9a107ea0d883e1f7be569f4dfd0d85b472500a87c51fc012987c80f6d9352e774
-DIST txaio-2.2.1.tar.gz 35208 SHA256 6eee00c397d8193d15313dfc36da3eac8d64edf0b92fe3b67cd5a735ffc3074b SHA512 63a1d1a5807efc6b46821f77448c5b82cc5f2aca0b2e374c9c35baedee84903d400939698578d15428c4b1d2ad0471f5c7b17a6c815d020e4df8b4a85d787671 WHIRLPOOL 2edc46918e8f6ff7b6cd7282897a81e8dd31089bb6da722c5718e7cddd719dfb296231876222e0678f0eb570b12c83cd011acdbd9b027c7a8004e4beff6a46c9
DIST txaio-2.3.1.tar.gz 36755 SHA256 1111c87bff73e22c2067318cbb267781e2f651c485d21783b25e1e768eabab67 SHA512 019d686102c862ec308e8ffdfbca25cda1b495adef73ee8b817a465a8054a24590ab0f1e3322df92d0a528152fc5b987b98b039dcd87308e81854d3c6a9fb146 WHIRLPOOL c5f550788f669237d24c5194348a84f5e6e8ca5206bd647ff8e5dee80705809601b798c4eecca260defa69d3276c77adbee6599529b48a325ec7865902c77d89
DIST txaio-2.5.1.tar.gz 41577 SHA256 625076477182e2dde78b79d0b2b0d6b3cecb0e24fe0ea7eaf2abd26a4c0dd1de SHA512 921b4f6738a91923cffe00eed30237e0a2a12dbd42476587b4902675d3d7d8ecbf3b6fbf47afa5648836f779f1c22f7edf9bd94d44dcacee86d03a1dd16450a5 WHIRLPOOL 24286b510c7f1911dd2a315362c76aff77bc2246164a4a1ba50573d87408db9e0e384e5063cfdbee96501b3d03decc9f4198aae9f8cd375d8c49de817d0eda63
diff --git a/dev-python/txaio/txaio-1.0.0.ebuild b/dev-python/txaio/txaio-1.0.0.ebuild
deleted file mode 100644
index 6089de0b8666..000000000000
--- a/dev-python/txaio/txaio-1.0.0.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_4} )
-
-inherit distutils-r1
-
-DESCRIPTION="a helper library for writing code unmodified on both Twisted and asyncio"
-HOMEPAGE="https://github.com/tavendo/txaio"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="doc test"
-
-RDEPEND="dev-python/six[${PYTHON_USEDEP}]
- >=dev-python/pep8-1.6.2[${PYTHON_USEDEP}]"
-
-DEPEND="app-arch/unzip
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/alabaster[${PYTHON_USEDEP}] )
- test? ( >=dev-python/pytest-2.6.4[${PYTHON_USEDEP}]
- >=dev-python/pytest-cov-1.8.1[${PYTHON_USEDEP}] )"
-
-python_prepare() {
- # https://github.com/tavendo/txaio/issues/3
- cp -r "${FILESDIR}"/util.py test || die
-
- distutils-r1_python_prepare
-}
-
-python_compile_all() {
- use doc && emake -C doc html
-}
-
-python_test() {
- py.test || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( doc/_build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/txaio/txaio-2.2.0.ebuild b/dev-python/txaio/txaio-2.2.0.ebuild
deleted file mode 100644
index 6895c0d2ddec..000000000000
--- a/dev-python/txaio/txaio-2.2.0.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_4} )
-
-RESTRICT="test"
-
-inherit distutils-r1
-
-DESCRIPTION="a helper library for writing code unmodified on both Twisted and asyncio"
-HOMEPAGE="https://github.com/tavendo/txaio"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="doc test"
-
-RDEPEND="dev-python/six[${PYTHON_USEDEP}]
- >=dev-python/pep8-1.6.2[${PYTHON_USEDEP}]"
-
-DEPEND="app-arch/unzip
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/alabaster[${PYTHON_USEDEP}] )
- test? ( >=dev-python/pytest-2.6.4[${PYTHON_USEDEP}]
- >=dev-python/pytest-cov-1.8.1[${PYTHON_USEDEP}] )"
-
-python_prepare() {
- # https://github.com/tavendo/txaio/issues/3
- cp -r "${FILESDIR}"/util.py test || die
-
- distutils-r1_python_prepare
-}
-
-python_compile_all() {
- use doc && emake -C doc html
-}
-
-python_test() {
- py.test || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( doc/_build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/txaio/txaio-2.2.1.ebuild b/dev-python/txaio/txaio-2.2.1.ebuild
deleted file mode 100644
index 6895c0d2ddec..000000000000
--- a/dev-python/txaio/txaio-2.2.1.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_4} )
-
-RESTRICT="test"
-
-inherit distutils-r1
-
-DESCRIPTION="a helper library for writing code unmodified on both Twisted and asyncio"
-HOMEPAGE="https://github.com/tavendo/txaio"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="doc test"
-
-RDEPEND="dev-python/six[${PYTHON_USEDEP}]
- >=dev-python/pep8-1.6.2[${PYTHON_USEDEP}]"
-
-DEPEND="app-arch/unzip
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/alabaster[${PYTHON_USEDEP}] )
- test? ( >=dev-python/pytest-2.6.4[${PYTHON_USEDEP}]
- >=dev-python/pytest-cov-1.8.1[${PYTHON_USEDEP}] )"
-
-python_prepare() {
- # https://github.com/tavendo/txaio/issues/3
- cp -r "${FILESDIR}"/util.py test || die
-
- distutils-r1_python_prepare
-}
-
-python_compile_all() {
- use doc && emake -C doc html
-}
-
-python_test() {
- py.test || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( doc/_build/html/. )
- distutils-r1_python_install_all
-}