summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/flask/Manifest2
-rw-r--r--dev-python/flask/files/flask-0.11.1-pypy3.patch45
-rw-r--r--dev-python/flask/flask-0.10.1-r2.ebuild60
-rw-r--r--dev-python/flask/flask-0.11.1-r1.ebuild58
-rw-r--r--dev-python/flask/flask-0.11.ebuild54
5 files changed, 0 insertions, 219 deletions
diff --git a/dev-python/flask/Manifest b/dev-python/flask/Manifest
index 6d24611576a4..431273c0fc1b 100644
--- a/dev-python/flask/Manifest
+++ b/dev-python/flask/Manifest
@@ -1,4 +1,2 @@
DIST Flask-0.10.1.tar.gz 544247 SHA256 4c83829ff83d408b5e1d4995472265411d2c414112298f2eb4b359d9e4563373 SHA512 0008d62d03a46b071c7d0510513d011a9bfd2b77df7f677371a446ca9805d16b1ee5e17dd8dd7cde6443a629370234e44735e20381de20a7da385969797f053f WHIRLPOOL f30a306ed00fe6d4c8e47b781c556c576b99b3545f833ae06f6b778d91c3127dc0adcc34d48221a0f1db1bb1633f2329d6085b7a4550afc672530525fdff474f
-DIST Flask-0.11.1.tar.gz 564993 SHA256 b4713f2bfb9ebc2966b8a49903ae0d3984781d5c878591cf2f7b484d28756b0e SHA512 62168dea0d44a1fcf862373def1f6d55d53145800cf353634b108bef2fcf9170b75e05d1e7d374e45e7fe261f170b6d7bf503816120dd9034dc19b6b83f1e384 WHIRLPOOL 66c766658e4786dda9105078c839c739ae0bc87f6f72790db65aaf2ad476b0ab36c17041b8d8926844581683cf023ddc26e4bd6510257f5c792e5e8f5ff362b2
-DIST Flask-0.11.tar.gz 563928 SHA256 29a7405a7f0de178232fe48cd9b2a2403083bf03bd34eabe12168863d4cdb493 SHA512 77ee9998c96ba5e4eb007b81e04a051a6f8fc3ac837496a8c9e6637fdbff3e6fbba4912919b1cb2c5ed72951cc9fb8eb28d699e3f15de14ecbb51c362111eafc WHIRLPOOL ee65af738a841a05c7d2ad2e9b021e3b0a0e046db706c747802d675d76246701b62d1911fae321aa460f7aafd17274b21177fd2cc5c647383ac6b6eba37cd36d
DIST Flask-0.12.tar.gz 531923 SHA256 93e803cdbe326a61ebd5c5d353959397c85f829bec610d59cb635c9f97d7ca8b SHA512 b8e9e005a850fcba413ad151998768ea0facb68f05855a1934cc6e4de1438cb59a4dd1bc74d2b04d52b3e837afa0a7785e98ae6c5af363a894c2be64773113f0 WHIRLPOOL df0df8db12b18b50d9ddf43ae925717bf4a67179af1d387020e73d4fb5f0c04c6cc1d6c83504d8dc5cbcb4dc11dcb0b63724499bd3c5b820feb181418d965138
diff --git a/dev-python/flask/files/flask-0.11.1-pypy3.patch b/dev-python/flask/files/flask-0.11.1-pypy3.patch
deleted file mode 100644
index 8f27c344e204..000000000000
--- a/dev-python/flask/files/flask-0.11.1-pypy3.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-From 6e46d0cd3969f6c13ff61c95c81a975192232fed Mon Sep 17 00:00:00 2001
-From: Markus Unterwaditzer <markus@unterwaditzer.net>
-Date: Mon, 13 Jun 2016 20:29:21 +0200
-Subject: [PATCH] Fix PyPy3 support and add bug references
-
-Fix #1841
----
- flask/_compat.py | 18 +++++++++++++-----
- 2 files changed, 20 insertions(+), 5 deletions(-)
-
-diff --git a/flask/_compat.py b/flask/_compat.py
-index bfe607d..071628f 100644
---- a/flask/_compat.py
-+++ b/flask/_compat.py
-@@ -65,17 +65,25 @@ def __new__(cls, name, this_bases, d):
-
-
- # Certain versions of pypy have a bug where clearing the exception stack
--# breaks the __exit__ function in a very peculiar way. This is currently
--# true for pypy 2.2.1 for instance. The second level of exception blocks
--# is necessary because pypy seems to forget to check if an exception
--# happened until the next bytecode instruction?
-+# breaks the __exit__ function in a very peculiar way. The second level of
-+# exception blocks is necessary because pypy seems to forget to check if an
-+# exception happened until the next bytecode instruction?
-+#
-+# Relevant PyPy bugfix commit:
-+# https://bitbucket.org/pypy/pypy/commits/77ecf91c635a287e88e60d8ddb0f4e9df4003301
-+# According to ronan on #pypy IRC, it is released in PyPy2 2.3 and later
-+# versions.
-+#
-+# Ubuntu 14.04 has PyPy 2.2.1, which does exhibit this bug.
- BROKEN_PYPY_CTXMGR_EXIT = False
- if hasattr(sys, 'pypy_version_info'):
- class _Mgr(object):
- def __enter__(self):
- return self
- def __exit__(self, *args):
-- sys.exc_clear()
-+ if hasattr(sys, 'exc_clear'):
-+ # Python 3 (PyPy3) doesn't have exc_clear
-+ sys.exc_clear()
- try:
- try:
- with _Mgr():
diff --git a/dev-python/flask/flask-0.10.1-r2.ebuild b/dev-python/flask/flask-0.10.1-r2.ebuild
deleted file mode 100644
index 8206617788da..000000000000
--- a/dev-python/flask/flask-0.10.1-r2.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="A microframework based on Werkzeug, Jinja2 and good intentions"
-MY_PN="Flask"
-MY_P="${MY_PN}-${PV}"
-SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
-HOMEPAGE="https://github.com/mitsuhiko/flask/"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples"
-
-RDEPEND="
- dev-python/blinker[${PYTHON_USEDEP}]
- >=dev-python/itsdangerous-0.21[${PYTHON_USEDEP}]
- >=dev-python/jinja-2.4[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/werkzeug-0.7[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-DEPEND="${RDEPEND}"
-# Usual; test phase
-DISTUTILS_IN_SOURCE_BUILD=1
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=(
- "${FILESDIR}"/${P}-is_package.patch
- "${FILESDIR}"/${P}-sort_json.patch
- "${FILESDIR}"/${P}-test_appcontext.patch
-)
-
-python_prepare_all() {
- # Prevent un-needed d'loading
- sed -e "s/ 'sphinx.ext.intersphinx',//" -i docs/conf.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- "${PYTHON}" run-tests.py || die "Testing failed with ${EPYTHON}"
-}
-
-python_install_all() {
- use examples && local EXAMPLES=( examples/. )
- use doc && HTML_DOCS=( docs/_build/html/. )
-
- distutils-r1_python_install_all
-}
diff --git a/dev-python/flask/flask-0.11.1-r1.ebuild b/dev-python/flask/flask-0.11.1-r1.ebuild
deleted file mode 100644
index b0ce40e35768..000000000000
--- a/dev-python/flask/flask-0.11.1-r1.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
-
-inherit distutils-r1
-
-MY_PN="Flask"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="A microframework based on Werkzeug, Jinja2 and good intentions"
-SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
-HOMEPAGE="https://github.com/pallets/flask/"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples test"
-
-RDEPEND=">=dev-python/blinker-1[${PYTHON_USEDEP}]
- >=dev-python/werkzeug-0.7[${PYTHON_USEDEP}]
- >=dev-python/jinja-2.4[${PYTHON_USEDEP}]
- >=dev-python/itsdangerous-0.21[${PYTHON_USEDEP}]
- >=dev-python/click-2[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}/${MY_P}"
-
-python_prepare_all() {
- # Prevent un-needed d'loading
- sed -e "s/ 'sphinx.ext.intersphinx',//" -i docs/conf.py || die
-
- local PATCHES=(
- "${FILESDIR}"/${P}-pypy3.patch
- )
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- py.test -v || die "Testing failed with ${EPYTHON}"
-}
-
-python_install_all() {
- use examples && dodoc -r examples
- use doc && HTML_DOCS=( docs/_build/html/. )
-
- distutils-r1_python_install_all
-}
diff --git a/dev-python/flask/flask-0.11.ebuild b/dev-python/flask/flask-0.11.ebuild
deleted file mode 100644
index 6c8c9b90a21c..000000000000
--- a/dev-python/flask/flask-0.11.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
-
-inherit distutils-r1
-
-MY_PN="Flask"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="A microframework based on Werkzeug, Jinja2 and good intentions"
-SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
-HOMEPAGE="https://github.com/pallets/flask/"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples test"
-
-RDEPEND=">=dev-python/blinker-1[${PYTHON_USEDEP}]
- >=dev-python/werkzeug-0.7[${PYTHON_USEDEP}]
- >=dev-python/jinja-2.4[${PYTHON_USEDEP}]
- >=dev-python/itsdangerous-0.21[${PYTHON_USEDEP}]
- >=dev-python/click-2[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}/${MY_P}"
-
-python_prepare_all() {
- # Prevent un-needed d'loading
- sed -e "s/ 'sphinx.ext.intersphinx',//" -i docs/conf.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- py.test -v || die "Testing failed with ${EPYTHON}"
-}
-
-python_install_all() {
- use examples && dodoc -r examples
- use doc && HTML_DOCS=( docs/_build/html/. )
-
- distutils-r1_python_install_all
-}