summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-vim/gentoo-syntax/Manifest1
-rw-r--r--app-vim/gentoo-syntax/gentoo-syntax-20210911.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-vim/gentoo-syntax/Manifest b/app-vim/gentoo-syntax/Manifest
index e7a0493c614c..8192b2f72e14 100644
--- a/app-vim/gentoo-syntax/Manifest
+++ b/app-vim/gentoo-syntax/Manifest
@@ -1,3 +1,4 @@
DIST gentoo-syntax-20210716.tar.bz2 18872 BLAKE2B faef2f356331c8560cb8e8014ad1a32a299f94fe8d05be499955cb78f1537f85abe44864b782df34244c3e606443b2146bd58a55047b23d327a548a436e818dc SHA512 f1a374fb5cf05563ea8cafa2209c9e8ba62bc072cac99202f486c3f7412cbb63432a33830e285ba706f8f73ee7f7bfd4e0b30bfad6feee1643e862b86495b82e
DIST gentoo-syntax-20210828.tar.bz2 18872 BLAKE2B bd3e152718b921aef8ce93e2d3e66d6195ab01801ea60987f62f9cb541fb726c2d552b6ec341943c1ca0e0cc1419c1cb75266e653b8bc958c8103855688f3d54 SHA512 e148c42b3e3281780d4f23ff1e464ba3c8404b3a4ba566a1a685c8364b6dd174830b489d5c7b561c3e30375fd9f510cfbf56d92f81c3f8fec8ab792ab48aa62a
DIST gentoo-syntax-20210901.tar.bz2 18876 BLAKE2B ef3913d8e631903003f469a8500c24f751ab70c17b1718cb9cd06b1e81b2dc7c07ed686b03be1da05afd5c238b8fddf67d35a63e7f381176be9340371cdc5dc9 SHA512 40c4f8522ce90bb529fd1cb050d1dd50010547006e385827980559a9febaa78f6d29b4798f6580a0c00de32db21a5528a051c2906d9dec95b62b992ea4875afe
+DIST gentoo-syntax-20210911.tar.bz2 18865 BLAKE2B 14dfe4b1eaab39a7de11c9b2e00c6a39385cd81d5717522dbac1f9ff265047c9ded745c335cca88413f6ad622f2858d996bdb39c5f4b1b4796ef7740c48c5f68 SHA512 b7ac7aba50c086e1e550692426bb38dbca5bf4770c148ff4989686ef043a2d990710bec782f1baba582ff67da3b3db007a4dbc6dec16f69830312205f1a45d3c
diff --git a/app-vim/gentoo-syntax/gentoo-syntax-20210911.ebuild b/app-vim/gentoo-syntax/gentoo-syntax-20210911.ebuild
new file mode 100644
index 000000000000..72f25ef766b6
--- /dev/null
+++ b/app-vim/gentoo-syntax/gentoo-syntax-20210911.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Gentoo and Portage syntax highlighting"
+HOMEPAGE="https://github.com/gentoo/gentoo-syntax"
+SRC_URI="https://gitweb.gentoo.org/proj/gentoo-syntax.git/snapshot/${P}.tar.bz2"
+
+LICENSE="vim"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="ignore-glep31"
+
+VIM_PLUGIN_HELPFILES="gentoo-syntax"
+VIM_PLUGIN_MESSAGES="filetype"
+
+src_prepare() {
+ default
+ if use ignore-glep31 ; then
+ for f in ftplugin/*.vim ; do
+ ebegin "Removing UTF-8 rules from ${f} ..."
+ sed -i -e 's~\(setlocal fileencoding=utf-8\)~" \1~' ${f} \
+ || die "waah! bad sed voodoo. need more goats."
+ eend $?
+ done
+ fi
+}
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ if use ignore-glep31 1>/dev/null ; then
+ ewarn "You have chosen to disable the rules which ensure GLEP 31"
+ ewarn "compliance. When editing ebuilds, please make sure you get"
+ ewarn "the character set correct."
+ fi
+ fi
+}