summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-misc/fbpanel/Manifest1
-rw-r--r--x11-misc/fbpanel/fbpanel-7.0.ebuild58
-rw-r--r--x11-misc/fbpanel/files/fbpanel-7.0-clang.patch57
-rw-r--r--x11-misc/fbpanel/files/fbpanel-7.0-shebangs.patch120
4 files changed, 236 insertions, 0 deletions
diff --git a/x11-misc/fbpanel/Manifest b/x11-misc/fbpanel/Manifest
index ee89550ced9c..37e46383f573 100644
--- a/x11-misc/fbpanel/Manifest
+++ b/x11-misc/fbpanel/Manifest
@@ -1 +1,2 @@
DIST fbpanel-6.1.tbz2 190266 SHA256 e14542cc81ea06e64dd4708546f5fd3f5e01884c3e4617885c7ef22af8cf3965 SHA512 10ffa422d811725dff68f43af9735d79c7859114bdf06f49b05e0bc4b0fd5eb8a3ea196cd07753f261d60c0bd0716baa6d5a22c860dde6597c70bfcfb0f7078e WHIRLPOOL 362d4beaa383ad716a851d4fe1a5e583d635c300a0d97ba36d07e2709b8ca09cd6756c7bf8f7fc62508c547dc23c043b6ad0e90787dc629b3dda280d2b55e97e
+DIST fbpanel-7.0.tar.gz 3746477 SHA256 711570954f8f99235d6afb7ec3226dede20b832eb712a5bd00e4f793b75ac5bb SHA512 9706a96569c41241de4dbd250c9d6a473b53a5e26e880f4c782041b2b91c7570046e1bee3070059fd2d333fb7159490732ef397b86701c72d4c65c0784948874 WHIRLPOOL 37fc5f86b80474026b660491b83ee26c4e9e260cadafff9673d161feb79efe2b2d6c89f1c83c76ebfe41eeee61e83cf3dc271667d4a2aeefe37c5e93c30f8e31
diff --git a/x11-misc/fbpanel/fbpanel-7.0.ebuild b/x11-misc/fbpanel/fbpanel-7.0.ebuild
new file mode 100644
index 000000000000..408fcdd3aa7c
--- /dev/null
+++ b/x11-misc/fbpanel/fbpanel-7.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-any-r1 toolchain-funcs
+
+DESCRIPTION="light-weight X11 desktop panel"
+HOMEPAGE="https://aanatoly.github.io/fbpanel/"
+SRC_URI="https://github.com/aanatoly/fbpanel/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
+IUSE="alsa"
+
+RDEPEND="
+ dev-libs/glib:2
+ alsa? ( media-libs/alsa-lib )
+ x11-libs/gdk-pixbuf:2[X]
+ x11-libs/gtk+:2
+ x11-libs/libX11
+"
+DEPEND="
+ ${RDEPEND}
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+ x11-proto/xproto
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-6.1-underlinking.patch
+ "${FILESDIR}"/${P}-shebangs.patch
+ "${FILESDIR}"/${P}-clang.patch
+)
+
+src_configure() {
+ tc-export CC
+ # not autotools based
+ local myconfigure=(
+ ./configure V=1
+ --mandir="${EPREFIX}"/usr/share/man/man1
+ --datadir="${EPREFIX}"/usr/share/${PN}
+ --prefix="${EPREFIX}"/usr
+ --libdir="${EPREFIX}"/usr/$(get_libdir)/${PN}
+ $(usex alsa --sound --no-sound)
+ )
+ echo ${myconfigure[@]} || die
+ ${myconfigure[@]} || die
+}
+
+pkg_postinst() {
+ elog "For the volume plugin to work, you need to configure your kernel"
+ elog "with CONFIG_SND_MIXER_OSS or CONFIG_SOUND_PRIME or some other means"
+ elog "that provide the /dev/mixer device node."
+}
diff --git a/x11-misc/fbpanel/files/fbpanel-7.0-clang.patch b/x11-misc/fbpanel/files/fbpanel-7.0-clang.patch
new file mode 100644
index 000000000000..69347c0f3aa9
--- /dev/null
+++ b/x11-misc/fbpanel/files/fbpanel-7.0-clang.patch
@@ -0,0 +1,57 @@
+diff -u -r fbpanel-7.0/plugins/battery/power_supply.c fbpanel-7.0-3/plugins/battery/power_supply.c
+--- fbpanel-7.0/plugins/battery/power_supply.c 2015-12-05 08:34:19.000000000 +0200
++++ fbpanel-7.0-3/plugins/battery/power_supply.c 2017-02-25 14:52:55.431202738 +0200
+@@ -154,7 +154,7 @@
+ tmp->path = path;
+ tmp->name = NULL;
+ tmp->status = NULL;
+- tmp->capacity = -1.0d;
++ tmp->capacity = -1.0f;
+ return tmp;
+ }
+
+@@ -206,12 +206,12 @@
+ bat->capacity = g_ascii_strtod(tmp_value, NULL);
+ } else { // for older kernels
+ tmp_value = (gchar*) g_hash_table_lookup(hash, SYS_ACPI_UEVENT_BAT_ENERGY_NOW_KEY);
+- gdouble tmp = -1.0d;
++ gdouble tmp = -1.0f;
+ if (tmp_value != NULL) { // ac off
+ tmp = g_ascii_strtod(tmp_value, NULL);
+ tmp_value = (gchar*) g_hash_table_lookup(hash, SYS_ACPI_UEVENT_BAT_ENERGY_FULL_KEY);
+- if (tmp_value != NULL && tmp > 0.0d) {
+- tmp = tmp / g_ascii_strtod(tmp_value, NULL) * 100.0d;
++ if (tmp_value != NULL && tmp > 0.0f) {
++ tmp = tmp / g_ascii_strtod(tmp_value, NULL) * 100.0f;
+ bat->capacity = tmp;
+ }
+ } else {
+@@ -219,8 +219,8 @@
+ if (tmp_value != NULL) { // ac on
+ tmp = g_ascii_strtod(tmp_value, NULL);
+ tmp_value = (gchar*) g_hash_table_lookup(hash, SYS_ACPI_UEVENT_BAT_CHARGE_FULL_KEY);
+- if (tmp_value != NULL && tmp > 0.0d) {
+- tmp = tmp / g_ascii_strtod(tmp_value, NULL) * 100.0d;
++ if (tmp_value != NULL && tmp > 0.0f) {
++ tmp = tmp / g_ascii_strtod(tmp_value, NULL) * 100.0f;
+ bat->capacity = tmp;
+ }
+ }
+@@ -327,7 +327,7 @@
+ extern gdouble
+ power_supply_get_bat_capacity(power_supply* ps)
+ {
+- gdouble total_bat_capacity = 0.0d;
++ gdouble total_bat_capacity = 0.0f;
+ guint bat_count = 0;
+ GSequenceIter* it;
+ bat* battery;
+@@ -335,7 +335,7 @@
+ it = g_sequence_get_begin_iter(ps->bat_list);
+ while (!g_sequence_iter_is_end(it)) {
+ battery = (bat*) g_sequence_get(it);
+- if (battery->capacity > 0.0d) {
++ if (battery->capacity > 0.0f) {
+ total_bat_capacity = total_bat_capacity + battery->capacity;
+ }
+ bat_count++;
diff --git a/x11-misc/fbpanel/files/fbpanel-7.0-shebangs.patch b/x11-misc/fbpanel/files/fbpanel-7.0-shebangs.patch
new file mode 100644
index 000000000000..cdbe998e0660
--- /dev/null
+++ b/x11-misc/fbpanel/files/fbpanel-7.0-shebangs.patch
@@ -0,0 +1,120 @@
+--- a/.config/help
++++ b/.config/help
+@@ -1,4 +1,4 @@
+-#!/usr/bin/python
++#!/usr/bin/env python2
+
+ import re, os, sys, textwrap
+ # Formats help message
+--- a/.config/repl.py
++++ b/.config/repl.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/python
++#!/usr/bin/env python2
+
+ import re, sys
+
+--- a/.config/tar.py
++++ b/.config/tar.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/python
++#!/usr/bin/env python2
+
+ import subprocess as sp
+ import re, tempfile
+--- a/configure
++++ b/configure
+@@ -1,4 +1,4 @@
+-#!/usr/bin/python
++#!/usr/bin/env python2
+
+ import sys
+ if sys.version_info < (2, 7):
+--- a/exec/make_profile.in
++++ b/exec/make_profile.in
+@@ -1,4 +1,4 @@
+-#!/bin/bash
++#!/usr/bin/env bash
+
+ umask 0077
+ # new profile directory
+--- a/exec/xlogout
++++ b/exec/xlogout
+@@ -1,4 +1,4 @@
+-#!/bin/bash
++#!/usr/bin/env bash
+
+ # xlogout - logs user out of its X session
+ # Linux specific since uses /proc
+--- a/scripts/endianess.sh
++++ b/scripts/endianess.sh
+@@ -1,4 +1,4 @@
+-#!/bin/bash
++#!/usr/bin/env bash
+
+ # When cross compiling, you may put cross compiler directory
+ # in PATH before native gcc (aka spoofing), or you may set CC
+--- a/scripts/install_locale.sh
++++ b/scripts/install_locale.sh
+@@ -1,4 +1,4 @@
+-#!/bin/bash
++#!/usr/bin/env bash
+
+ dir=/tmp/lo-$$
+ mkdir $dir
+--- a/scripts/install_locale.sh.in
++++ b/scripts/install_locale.sh.in
+@@ -1,4 +1,4 @@
+-#!/bin/bash
++#!/usr/bin/env bash
+
+ dir=/tmp/lo-$$
+ mkdir $dir
+--- a/scripts/install.sh
++++ b/scripts/install.sh
+@@ -1,4 +1,4 @@
+-#!/bin/bash
++#!/usr/bin/env bash
+
+ usage ()
+ {
+--- a/scripts/mk_tar
++++ b/scripts/mk_tar
+@@ -1,4 +1,4 @@
+-#!/bin/bash
++#!/usr/bin/env bash
+
+
+ function info()
+--- a/scripts/rfs-pkg-config
++++ b/scripts/rfs-pkg-config
+@@ -1,4 +1,4 @@
+-#!/bin/bash
++#!/usr/bin/env bash
+
+ # Tt runs pkg-config in a way that everything is searched under RFS
+ # but reported including full path. Suitable for cross-compiling
+--- a/scripts/update-proj.sh
++++ b/scripts/update-proj.sh
+@@ -1,4 +1,4 @@
+-#!/bin/bash
++#!/usr/bin/env bash
+
+ function usage ()
+ {
+--- a/www/plugins/mk_gallery
++++ b/www/plugins/mk_gallery
+@@ -1,4 +1,4 @@
+-#!/bin/sh
++#!/usr/bin/env sh
+
+ echo > "$1"
+ #echo '<table cellpadding="0" cellspacing="0" border="0" align="left" bgcolor="#ffffff">' >> "$1"
+--- a/www/shots/mk_gallery
++++ b/www/shots/mk_gallery
+@@ -1,4 +1,4 @@
+-#!/bin/sh
++#!/usr/bin/env sh
+
+ function help ()
+ {