summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ros/pointcloud_to_laserscan/Manifest1
-rw-r--r--dev-ros/pointcloud_to_laserscan/pointcloud_to_laserscan-1.4.1.ebuild27
-rw-r--r--dev-ros/pointcloud_to_laserscan/pointcloud_to_laserscan-9999.ebuild9
3 files changed, 33 insertions, 4 deletions
diff --git a/dev-ros/pointcloud_to_laserscan/Manifest b/dev-ros/pointcloud_to_laserscan/Manifest
index 57ab08fdf1d8..24c3c3e5041f 100644
--- a/dev-ros/pointcloud_to_laserscan/Manifest
+++ b/dev-ros/pointcloud_to_laserscan/Manifest
@@ -1 +1,2 @@
DIST pointcloud_to_laserscan-1.4.0.tar.gz 6502 BLAKE2B 02614ce3e046f4b6c828df7121dcd5a2d033e8fefa979a8541127684d5ea6bb40d74412ea9c1ccffc934aa7172343968f75198f444b2ca38391318f584e40901 SHA512 f54d65edc4eda2e97d75ed26b1d374a669f188c4ef2426730312ae479e051a0834abb782cdd00febbd8dc97cb6a0723b6a735d2cbf07e2f8260ad0e54e79376f
+DIST pointcloud_to_laserscan-1.4.1.tar.gz 7645 BLAKE2B b3b32213920679e3b0f76d1401658b5dce5057f9556f442e96e79719f083910454aa42e85869628c6713f0dfb858e10e16fc089a92c0e2233b810b9b698334a5 SHA512 c81fdb38affe6cf7da76db9de2b1c17f60a0c464fbd25278d013a601e8474a528a72ec981c3e2e8d257239c398f266960f9adc41e46e5d09bae81d9da8c05c84
diff --git a/dev-ros/pointcloud_to_laserscan/pointcloud_to_laserscan-1.4.1.ebuild b/dev-ros/pointcloud_to_laserscan/pointcloud_to_laserscan-1.4.1.ebuild
new file mode 100644
index 000000000000..e6427082f109
--- /dev/null
+++ b/dev-ros/pointcloud_to_laserscan/pointcloud_to_laserscan-1.4.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros-perception/pointcloud_to_laserscan"
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Converts a 3D Point Cloud into a 2D laser scan"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/message_filters
+ dev-ros/nodelet
+ dev-ros/roscpp
+ dev-ros/tf2
+ dev-ros/tf2_ros
+ dev-ros/tf2_sensor_msgs
+ dev-libs/boost:=
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
diff --git a/dev-ros/pointcloud_to_laserscan/pointcloud_to_laserscan-9999.ebuild b/dev-ros/pointcloud_to_laserscan/pointcloud_to_laserscan-9999.ebuild
index 36c5cfc0838d..e6427082f109 100644
--- a/dev-ros/pointcloud_to_laserscan/pointcloud_to_laserscan-9999.ebuild
+++ b/dev-ros/pointcloud_to_laserscan/pointcloud_to_laserscan-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/ros-perception/pointcloud_to_laserscan"
KEYWORDS="~amd64 ~arm"
@@ -16,11 +16,12 @@ RDEPEND="
dev-ros/message_filters
dev-ros/nodelet
dev-ros/roscpp
- dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
dev-ros/tf2
dev-ros/tf2_ros
dev-ros/tf2_sensor_msgs
dev-libs/boost:=
dev-libs/console_bridge:=
"
-DEPEND="${RDEPEND}"
+DEPEND="${RDEPEND}
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"