summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnome-base/gnome-shell/Manifest2
-rw-r--r--gnome-base/gnome-shell/gnome-shell-3.28.3.ebuild2
-rw-r--r--gnome-base/gnome-shell/gnome-shell-3.30.2.ebuild189
-rw-r--r--profiles/package.mask1
4 files changed, 193 insertions, 1 deletions
diff --git a/gnome-base/gnome-shell/Manifest b/gnome-base/gnome-shell/Manifest
index 553301215ddf..bea6c4afe6ea 100644
--- a/gnome-base/gnome-shell/Manifest
+++ b/gnome-base/gnome-shell/Manifest
@@ -3,3 +3,5 @@ DIST gnome-shell-3.26.2-patchset.tar.xz 55492 BLAKE2B 745b8549f7480b004f4df9b815
DIST gnome-shell-3.26.2.tar.xz 1405580 BLAKE2B ccbb8ad374931335fdc6e752a7feedcba4fe2b61112404b62bc9711b1736216d46fd6e85c6f06439cae50af86a174359d7df0e111e8db6ffed567e91b4292b14 SHA512 0e13bc7abff2367d24ea748cd69a1879ff14a6755ef27d17cf20cef61bc6d15bf6e9d18362142a2d6462689f64eada833f9bba21ebaac3a33765a5be0ae48d3a
DIST gnome-shell-3.28.3-patchset.tar.xz 30820 BLAKE2B 3402a1c455a5e9d028f6c15ea40db94afb84576643b9bfe9e973a7f375d9f0a22003eab3ccabec0b4b31c31f70ef02ca055c0f62a5c0392529fc375f6cef7029 SHA512 a1da84374dd97bff2546d6ddc5656bade69711d05b4b4f4283df66ebbac566767a509dcbd6db52c28a1915cf873c99b81029128cb2a2b63c325dc3e3340fffb4
DIST gnome-shell-3.28.3.tar.xz 1433388 BLAKE2B 656e2edabef363d779fd339b7158ad3461a05452a2fdad611889d19f272cd98dfbbb39871d10631326b83108678f8a7245c349583eb257e9d7e4827078134ade SHA512 3550a9e59101a96cf04e4a4bc183ac9a447baa72d74e57c3f438764741b4365f8848895c1eb2c4d0af5c7936e38eb8971ef578bbee315e78b9fdcbbe49fdc1e8
+DIST gnome-shell-3.30.2-patchset.tar.xz 39864 BLAKE2B 61c02e5ae87ab24f30d28865f4444f20e32fef63eefbfc1134bf0582eb25933700902aad08176fd2011781262552385bcb3ffaf35fc2d7a060c09ba0d27cb9a8 SHA512 8ad976c05488a6b7447d29105a566d0bb975c8e0798be18c1dc07295c51a27578274e611da4979397fc6c4da538f6d9f48072e043829a63faf87a781518ee531
+DIST gnome-shell-3.30.2.tar.xz 1439556 BLAKE2B 547ccf5571ea431d15c6430619640bd497a381191cad56bbf1a5c9992c5df47eb48527cc2749ea4d417cbe5fd7cc2acb44915ee35d3d89cd386541f19d743877 SHA512 5cdf2b9a4dc9dbcc75d76020a01b953ae3922d5820b692d1bc1cf62daf1f00d04b95d6ec076920563f555115c4f4ad11a019e4523a353ef4dd2189a5240239c6
diff --git a/gnome-base/gnome-shell/gnome-shell-3.28.3.ebuild b/gnome-base/gnome-shell/gnome-shell-3.28.3.ebuild
index 42564e155a8a..9931a77b08bc 100644
--- a/gnome-base/gnome-shell/gnome-shell-3.28.3.ebuild
+++ b/gnome-base/gnome-shell/gnome-shell-3.28.3.ebuild
@@ -119,7 +119,7 @@ DEPEND="${COMMON_DEPEND}
"
PATCHES=(
- # Patches from gnome-3-26 branch on top of 3.26.2
+ # Patches from gnome-3-28 branch on top of 3.28.3
"${WORKDIR}"/patches/
# Change favorites defaults, bug #479918
"${FILESDIR}"/${PV}-defaults.patch
diff --git a/gnome-base/gnome-shell/gnome-shell-3.30.2.ebuild b/gnome-base/gnome-shell/gnome-shell-3.30.2.ebuild
new file mode 100644
index 000000000000..49ce9e97ba32
--- /dev/null
+++ b/gnome-base/gnome-shell/gnome-shell-3.30.2.ebuild
@@ -0,0 +1,189 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit gnome.org gnome2-utils meson pax-utils python-single-r1 virtualx xdg
+
+DESCRIPTION="Provides core UI functions for the GNOME 3 desktop"
+HOMEPAGE="https://wiki.gnome.org/Projects/GnomeShell"
+SRC_URI+=" https://dev.gentoo.org/~leio/distfiles/${P}-patchset.tar.xz"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0"
+IUSE="+bluetooth +browser-extension elogind gtk-doc +ibus +networkmanager nsplugin systemd telepathy"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}
+ ?? ( elogind systemd )"
+
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+
+# libXfixes-5.0 needed for pointer barriers and #include <X11/extensions/Xfixes.h>
+# FIXME:
+# * gstreamer support is currently automagic
+COMMON_DEPEND="
+ >=dev-libs/libcroco-0.6.8:0.6
+ >=gnome-extra/evolution-data-server-3.17.2:=
+ >=app-crypt/gcr-3.7.5[introspection]
+ >=gnome-base/gnome-desktop-3.7.90:3=[introspection]
+ >=dev-libs/glib-2.57.2:2
+ >=dev-libs/gobject-introspection-1.49.1:=
+ >=dev-libs/gjs-1.47.0
+ >=x11-libs/gtk+-3.15.0:3[introspection]
+ nsplugin? ( >=dev-libs/json-glib-0.13.2 )
+ >=x11-wm/mutter-3.30.1:0/3[introspection]
+ >=sys-auth/polkit-0.100[introspection]
+ >=gnome-base/gsettings-desktop-schemas-3.27.90
+ >=x11-libs/startup-notification-0.11
+ >=app-i18n/ibus-1.5.2
+ bluetooth? ( >=net-wireless/gnome-bluetooth-3.9[introspection] )
+ >=media-libs/gstreamer-0.11.92:1.0
+ networkmanager? (
+ >=net-misc/networkmanager-1.10.4:=[introspection]
+ >=app-crypt/libsecret-0.18
+ dev-libs/dbus-glib )
+ systemd? ( >=sys-apps/systemd-31 )
+ elogind? ( >=sys-auth/elogind-237 )
+
+ >=app-accessibility/at-spi2-atk-2.5.3
+ media-libs/libcanberra[gtk3]
+ x11-libs/gdk-pixbuf:2[introspection]
+ dev-libs/libxml2:2
+ x11-libs/libX11
+
+ >=media-sound/pulseaudio-2[glib]
+ >=dev-libs/atk-2[introspection]
+ dev-libs/libical:=
+ >=x11-libs/libXfixes-5.0
+
+ ${PYTHON_DEPS}
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ media-libs/mesa
+"
+# Runtime-only deps are probably incomplete and approximate.
+# Introspection deps generated using:
+# grep -roe "imports.gi.*" gnome-shell-* | cut -f2 -d: | sort | uniq
+# Each block:
+# 1. Introspection stuff needed via imports.gi.*
+# 2. gnome-session needed for shutdown/reboot/inhibitors/etc
+# 3. Control shell settings
+# 4. logind interface needed for suspending support
+# 5. xdg-utils needed for xdg-open, used by extension tool
+# 6. adwaita-icon-theme needed for various icons & arrows (3.26 for new video-joined-displays-symbolic and co icons; review for 3.28+)
+# 7. mobile-broadband-provider-info, timezone-data for shell-mobile-providers.c # TODO: Review
+# 8. IBus is needed for nls integration
+# 9. Optional telepathy chat integration
+# 10. Cantarell font used in gnome-shell global CSS (if removing this for some reason, make sure it's pulled in somehow for non-meta users still too)
+# 11. TODO: semi-optional webkit-gtk[introspection] for captive portal helper
+RDEPEND="${COMMON_DEPEND}
+ >=sys-apps/accountsservice-0.6.14[introspection]
+ app-accessibility/at-spi2-core:2[introspection]
+ app-misc/geoclue[introspection]
+ >=dev-libs/libgweather-3.26:2[introspection]
+ >=sys-power/upower-0.99:=[introspection]
+ x11-libs/pango[introspection]
+ gnome-base/librsvg:2[introspection]
+
+ >=gnome-base/gnome-session-2.91.91
+ >=gnome-base/gnome-settings-daemon-3.8.3
+
+ x11-misc/xdg-utils
+
+ >=x11-themes/adwaita-icon-theme-3.26
+
+ networkmanager? (
+ net-misc/mobile-broadband-provider-info
+ sys-libs/timezone-data )
+ ibus? ( >=app-i18n/ibus-1.4.99[dconf(+),gtk,introspection] )
+ telepathy? (
+ >=net-im/telepathy-logger-0.2.4[introspection]
+ >=net-libs/telepathy-glib-0.19[introspection] )
+ media-fonts/cantarell
+"
+# avoid circular dependency, see bug #546134
+PDEPEND="
+ >=gnome-base/gdm-3.5[introspection]
+ >=gnome-base/gnome-control-center-3.26[bluetooth(+)?,networkmanager(+)?]
+ browser-extension? ( gnome-extra/chrome-gnome-shell )
+"
+DEPEND="${COMMON_DEPEND}
+ dev-lang/sassc
+ dev-libs/libxslt
+ >=dev-util/gdbus-codegen-2.45.3
+ dev-util/glib-utils
+ gtk-doc? ( >=dev-util/gtk-doc-1.17 )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ # Patches from gnome-3-28 branch on top of 3.30.2
+ "${WORKDIR}"/patches/
+ # Change favorites defaults, bug #479918
+ "${FILESDIR}"/3.28.3-defaults.patch
+ # Fix automagic gnome-bluetooth dep, bug #398145
+ "${FILESDIR}"/3.28.3-optional-bluetooth.patch
+)
+
+src_prepare() {
+ xdg_src_prepare
+ # We want nsplugins in /usr/$(get_libdir)/nsbrowser/plugins not .../mozilla/plugins
+ sed -e 's/mozilla/nsbrowser/' -i meson.build || die
+ # Hack in correct python shebang
+ sed -e "s:python\.path():'/usr/bin/env ${EPYTHON}':" -i src/meson.build || die
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use bluetooth)
+ $(meson_use nsplugin browser_plugin)
+ $(meson_use gtk-doc gtk_doc)
+ -Dman=true
+ $(meson_use networkmanager)
+ $(meson_use systemd) # this controls journald integration only as of 3.26.2 (structured logging and having gnome-shell launched apps use its own identifier instead of gnome-session)
+ # suspend support is runtime optional via /run/systemd/seats presence and org.freedesktop.login1.Manager dbus interface; elogind should provide what's necessary
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ # Required for gnome-shell on hardened/PaX, bug #398941; FIXME: Is this still relevant?
+ pax-mark m "${ED}usr/bin/gnome-shell"{,-extension-prefs}
+}
+
+src_test() {
+ virtx meson_src_test
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+
+ if ! has_version 'media-libs/gst-plugins-good:1.0' || \
+ ! has_version 'media-plugins/gst-plugins-vpx:1.0'; then
+ ewarn "To make use of GNOME Shell's built-in screen recording utility,"
+ ewarn "you need to either install media-libs/gst-plugins-good:1.0"
+ ewarn "and media-plugins/gst-plugins-vpx:1.0, or use dconf-editor to change"
+ ewarn "apps.gnome-shell.recorder/pipeline to what you want to use."
+ fi
+
+ if ! has_version "media-libs/mesa[llvm]"; then
+ elog "llvmpipe is used as fallback when no 3D acceleration"
+ elog "is available. You will need to enable llvm USE for"
+ elog "media-libs/mesa if you do not have hardware 3D setup."
+ fi
+
+ # https://bugs.gentoo.org/show_bug.cgi?id=563084
+ # TODO: Is this still the case after various fixed in 3.28 for detecting non-working KMS for wayland (to fall back to X)?
+ if has_version "x11-drivers/nvidia-drivers[-kms]"; then
+ ewarn "You will need to enable kms support in x11-drivers/nvidia-drivers,"
+ ewarn "otherwise Gnome will fail to start"
+ fi
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}
diff --git a/profiles/package.mask b/profiles/package.mask
index 31a5c06b1b78..1c106a989ff0 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -91,6 +91,7 @@ media-video/get_flash_videos
~dev-libs/gjs-1.54.3
~net-irc/polari-3.30.2
~x11-wm/mutter-3.30.2
+~gnome-base/gnome-shell-3.30.2
# Lars Wendler <polynomial-c@gentoo.org> (17 Mar 2019)
# Breaks user crontab (#680764)