summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-irc/konversation/Manifest1
-rw-r--r--net-irc/konversation/files/konversation-1.7.5-QElapsedTimer.patch81
-rw-r--r--net-irc/konversation/files/konversation-1.7.5-fix-regex-for-cap-ack.patch25
-rw-r--r--net-irc/konversation/files/konversation-1.7.5-kf5bookmarks-5.69.patch51
-rw-r--r--net-irc/konversation/files/konversation-1.7.5-kf5windowsystem-5.63.patch37
-rw-r--r--net-irc/konversation/files/konversation-1.7.5-missing-header.patch23
-rw-r--r--net-irc/konversation/files/konversation-1.7.5-qt-5.15.patch31
-rw-r--r--net-irc/konversation/konversation-1.7.5-r2.ebuild84
8 files changed, 0 insertions, 333 deletions
diff --git a/net-irc/konversation/Manifest b/net-irc/konversation/Manifest
index da6b166acadc..fd13db27a3b0 100644
--- a/net-irc/konversation/Manifest
+++ b/net-irc/konversation/Manifest
@@ -1,2 +1 @@
-DIST konversation-1.7.5.tar.xz 3739392 BLAKE2B 92a068d57f19f3cf8822d1dbc219949ae34388eaa00f4542aaee28b1c78cdc68e80c2c032e54efd842c1925a689a1ee2f05458322d106a677829a623dd61432a SHA512 001534c7f6c5110ca5e210977cc4275e083f5c3704078a74aa573af659154e0fa4c3c960be08f41256db1ac4568f0734741bf10cfb2e15d9e6f6440250682504
DIST konversation-1.7.7.tar.xz 3357584 BLAKE2B 9f6817a1e01674f383879eeaafc65a50825aa7554fedcf7fbe7affc43da16f7198761ca12b510d9980df5a5f41819a5415043ec91de55f1cb4d86e62e8e23ea0 SHA512 99026007af7fa00b82240c1f0e46a8d3db6c3434948aff7d0b01c2f99bccdd227a2a705bd83bce1ca2e47be13866d5d0a981c8b4ff8dec472612d6ee40f9ed2c
diff --git a/net-irc/konversation/files/konversation-1.7.5-QElapsedTimer.patch b/net-irc/konversation/files/konversation-1.7.5-QElapsedTimer.patch
deleted file mode 100644
index 74fd23e58d3c..000000000000
--- a/net-irc/konversation/files/konversation-1.7.5-QElapsedTimer.patch
+++ /dev/null
@@ -1,81 +0,0 @@
-From 0efede7857a86f729bec0fdfd1789f7faf23d957 Mon Sep 17 00:00:00 2001
-From: David Faure <faure@kde.org>
-Date: Thu, 28 Nov 2019 17:41:33 +0100
-Subject: Port to QElapsedTimer; remove unused default constructor
-
-Tested by printing out the value of age(), works like before.
----
- src/irc/ircqueue.cpp | 8 ++++++++
- src/irc/ircqueue.h | 18 +++++++-----------
- 2 files changed, 15 insertions(+), 11 deletions(-)
-
-diff --git a/src/irc/ircqueue.cpp b/src/irc/ircqueue.cpp
-index 1101623..3cc33a5 100644
---- a/src/irc/ircqueue.cpp
-+++ b/src/irc/ircqueue.cpp
-@@ -19,6 +19,14 @@
-
- #include "server.h"
-
-+IRCMessage::IRCMessage(const QString &str)
-+ : s(str) //, codec(QTextCodec::codecForName("utf8"))
-+{
-+ t.start();
-+}
-+
-+////
-+
- int IRCQueue::EmptyingRate::nextInterval(int, int elapsed)
- {
- if (!isValid())
-diff --git a/src/irc/ircqueue.h b/src/irc/ircqueue.h
-index 3f7f0c8..7a91776 100644
---- a/src/irc/ircqueue.h
-+++ b/src/irc/ircqueue.h
-@@ -19,6 +19,7 @@
- #include <QObject>
- #include <QList>
- #include <QTime>
-+#include <QElapsedTimer>
-
- class QTimer;
- class Server;
-@@ -34,29 +35,24 @@ class Server;
- */
- struct IRCMessage
- {
-- IRCMessage() : t(QTime::currentTime()) //, codec(QTextCodec::codecForName("utf8"))
-- {} ///< this constructor required for QValueList, do not use
--
- /**
- Make a new IRCMessage with timestamp of QTime::currentTime().
-
- Note the constructor takes a QString, not a const QString& or a QString *. If you want to modify the
- contained text, put it back with setText.
- */
-- IRCMessage(QString i) : s(i), t(QTime::currentTime()) //, codec(QTextCodec::codecForName("utf8"))
-- {}
-+ IRCMessage(const QString &str);
-
-- QString text() { return s; }
-- int age() { return t.elapsed(); }
-- QTime time() { return t; }
-- void setText(QString text) { s=text; }
-+ QString text() const { return s; }
-+ int age() const { return t.elapsed(); } // in milliseconds
-+ void setText(const QString &text) { s=text; }
- private:
- QString s;
-- QTime t;
-+ QElapsedTimer t;
-
- //FIXME wire this up
- //QTextCodec* codec;
-- //operator const char * () const { return codec->fromUnicode(text()); }
-+ //operator QByteArray () const { return codec->fromUnicode(text()); }
-
- };
-
---
-cgit v1.1
-
diff --git a/net-irc/konversation/files/konversation-1.7.5-fix-regex-for-cap-ack.patch b/net-irc/konversation/files/konversation-1.7.5-fix-regex-for-cap-ack.patch
deleted file mode 100644
index f351dd00134f..000000000000
--- a/net-irc/konversation/files/konversation-1.7.5-fix-regex-for-cap-ack.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 6d896b4efc93c18246ce4db7c788929b0ce75559 Mon Sep 17 00:00:00 2001
-From: Peter Simonsson <peter.simonsson@gmail.com>
-Date: Sun, 23 Sep 2018 08:29:43 +0200
-Subject: Fix regex for cap ack
-
-Seems to have worked despite being broken
----
- src/irc/inputfilter.cpp | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/irc/inputfilter.cpp b/src/irc/inputfilter.cpp
-index fbd268b..45d4f88 100644
---- a/src/irc/inputfilter.cpp
-+++ b/src/irc/inputfilter.cpp
-@@ -795,7 +795,7 @@ void InputFilter::parseServerCommand(const QString &prefix, const QString &comma
-
- foreach(const QString& capability, capabilities)
- {
-- int nameStart = capability.indexOf(QRegExp(QStringLiteral("[a-z0-9"), Qt::CaseInsensitive));
-+ int nameStart = capability.indexOf(QRegExp(QStringLiteral("[a-z0-9]"), Qt::CaseInsensitive));
- QString modifierString = capability.left(nameStart);
- QString name = capability.mid(nameStart);
-
---
-cgit v1.1
diff --git a/net-irc/konversation/files/konversation-1.7.5-kf5bookmarks-5.69.patch b/net-irc/konversation/files/konversation-1.7.5-kf5bookmarks-5.69.patch
deleted file mode 100644
index 2c36f69aa99c..000000000000
--- a/net-irc/konversation/files/konversation-1.7.5-kf5bookmarks-5.69.patch
+++ /dev/null
@@ -1,51 +0,0 @@
-From 57df81cd8a11c4dbe170f9d81abd5b35b4887e0b Mon Sep 17 00:00:00 2001
-From: Ahmad Samir <a.samirh78@gmail.com>
-Date: Fri, 17 Apr 2020 13:14:26 +0200
-Subject: Adapt the code to KBookmarkMenu-5.69 changes
-
-Test Plan:
-Bookmarks menu still works, and the bookmark actions still show in the
-shortcuts editor dialog.
-
-Reviewers: #konversation, psn
-
-Reviewed By: #konversation, psn
-
-Subscribers: #konversation
-
-Differential Revision: https://phabricator.kde.org/D28911
----
- src/bookmarkhandler.cpp | 8 ++++++++
- 1 file changed, 8 insertions(+)
-
-diff --git a/src/bookmarkhandler.cpp b/src/bookmarkhandler.cpp
-index 5a70591..74b51ff 100644
---- a/src/bookmarkhandler.cpp
-+++ b/src/bookmarkhandler.cpp
-@@ -21,7 +21,10 @@ Copyright (C) 2002 Carsten Pfeiffer <pfeiffer@kde.org>
- #include "connectionmanager.h"
- #include "viewer/viewcontainer.h"
-
-+#include <KActionCollection>
-+#include <kbookmarks_version.h>
- #include <KBookmarkMenu>
-+#include <QMenu>
- #include <QStandardPaths>
-
-
-@@ -41,7 +44,12 @@ m_mainWindow(mainWindow)
- manager->setEditorOptions(i18n("Konversation Bookmarks Editor"), false);
- manager->setUpdate( true );
-
-+#if KBOOKMARKS_VERSION < QT_VERSION_CHECK(5, 69, 0)
- m_bookmarkMenu = new KBookmarkMenu(manager, this, menu, m_mainWindow->actionCollection());
-+#else
-+ m_bookmarkMenu = new KBookmarkMenu(manager, this, menu);
-+ m_mainWindow->actionCollection()->addActions(menu->actions());
-+#endif
- }
-
- KonviBookmarkHandler::~KonviBookmarkHandler()
---
-cgit v1.1
-
diff --git a/net-irc/konversation/files/konversation-1.7.5-kf5windowsystem-5.63.patch b/net-irc/konversation/files/konversation-1.7.5-kf5windowsystem-5.63.patch
deleted file mode 100644
index cf93b3b66def..000000000000
--- a/net-irc/konversation/files/konversation-1.7.5-kf5windowsystem-5.63.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-From 4295aba5c02533040723d140e062aebd231b3f18 Mon Sep 17 00:00:00 2001
-From: David Faure <faure@kde.org>
-Date: Thu, 28 Nov 2019 12:56:34 +0100
-Subject: Port away from deprecated KWindowSystem API (with ifdefs)
-
----
- src/application.cpp | 6 ++++++
- 1 file changed, 6 insertions(+)
-
-diff --git a/src/application.cpp b/src/application.cpp
-index 4667c24..538624b 100644
---- a/src/application.cpp
-+++ b/src/application.cpp
-@@ -50,6 +50,7 @@
- #include <KTextEdit>
- #include <KSharedConfig>
- #include <KStartupInfo>
-+#include <kwindowsystem_version.h>
-
- using namespace Konversation;
-
-@@ -1392,7 +1393,12 @@ void Application::handleActivate(const QStringList& arguments)
-
- newInstance(m_commandLineParser);
-
-+#if KWINDOWSYSTEM_VERSION <= QT_VERSION_CHECK(5, 62, 0)
- KStartupInfo::setNewStartupId(mainWindow, KStartupInfo::startupId());
-+#else
-+ mainWindow->setAttribute(Qt::WA_NativeWindow, true);
-+ KStartupInfo::setNewStartupId(mainWindow->windowHandle(), KStartupInfo::startupId());
-+#endif
- mainWindow->show();
- mainWindow->raise();
- }
---
-cgit v1.1
-
diff --git a/net-irc/konversation/files/konversation-1.7.5-missing-header.patch b/net-irc/konversation/files/konversation-1.7.5-missing-header.patch
deleted file mode 100644
index 1ff14b81ec58..000000000000
--- a/net-irc/konversation/files/konversation-1.7.5-missing-header.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From 4d0036617becc26a76fd021138c98aceec4c7b53 Mon Sep 17 00:00:00 2001
-From: Luca Beltrame <lbeltrame@kde.org>
-Date: Sun, 21 Jul 2019 09:14:32 +0200
-Subject: Fix build with Qt 5.13
-
----
- src/irc/outputfilter.cpp | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/src/irc/outputfilter.cpp b/src/irc/outputfilter.cpp
-index f9e6253..45d11fb 100644
---- a/src/irc/outputfilter.cpp
-+++ b/src/irc/outputfilter.cpp
-@@ -32,6 +32,7 @@
-
- #include <QStringList>
- #include <QFile>
-+#include <QMetaMethod>
- #include <QRegExp>
- #include <QTextCodec>
- #include <QByteArray>
---
-cgit v1.1
diff --git a/net-irc/konversation/files/konversation-1.7.5-qt-5.15.patch b/net-irc/konversation/files/konversation-1.7.5-qt-5.15.patch
deleted file mode 100644
index a17c0a432314..000000000000
--- a/net-irc/konversation/files/konversation-1.7.5-qt-5.15.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From f88c73cf278da9907496eab0777903f942c50cb9 Mon Sep 17 00:00:00 2001
-From: Andreas Sturmlechner <asturm@gentoo.org>
-Date: Tue, 21 Apr 2020 10:34:49 +0200
-Subject: [PATCH] Fix build with Qt 5.15 (missing header)
-
-Test Plan: Build succeeds with Qt 5.15.0_beta4
-
-Reviewers: #konversation, psn
-
-Reviewed By: #konversation, psn
-
-Differential Revision: https://phabricator.kde.org/D29038
----
- src/viewer/viewtree.cpp | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/src/viewer/viewtree.cpp b/src/viewer/viewtree.cpp
-index eeee8fb4..04ec4e54 100644
---- a/src/viewer/viewtree.cpp
-+++ b/src/viewer/viewtree.cpp
-@@ -21,6 +21,7 @@
- #include <QFontDatabase>
- #include <QGuiApplication>
- #include <QPainter>
-+#include <QPainterPath>
- #include <QItemSelectionModel>
- #include <QStyleHints>
- #include <QToolTip>
---
-2.26.1
-
diff --git a/net-irc/konversation/konversation-1.7.5-r2.ebuild b/net-irc/konversation/konversation-1.7.5-r2.ebuild
deleted file mode 100644
index 7e956aad47ad..000000000000
--- a/net-irc/konversation/konversation-1.7.5-r2.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-ECM_HANDBOOK="forceoptional"
-KFMIN=5.63.0
-QTMIN=5.12.3
-inherit ecm kde.org
-
-DESCRIPTION="User friendly IRC Client"
-HOMEPAGE="https://konversation.kde.org https://apps.kde.org/en/konversation"
-SRC_URI="mirror://kde/stable/${PN}/${PV/_/-}/src/${P/_/-}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="5"
-KEYWORDS="amd64 ~arm64 ~ppc64 x86"
-IUSE="+crypt"
-
-BDEPEND="sys-devel/gettext"
-DEPEND="
- >=dev-qt/qtdbus-${QTMIN}:5
- >=dev-qt/qtgui-${QTMIN}:5
- >=dev-qt/qtnetwork-${QTMIN}:5
- >=dev-qt/qtwidgets-${QTMIN}:5
- >=dev-qt/qtxml-${QTMIN}:5
- >=kde-frameworks/karchive-${KFMIN}:5
- >=kde-frameworks/kbookmarks-${KFMIN}:5=
- >=kde-frameworks/kcodecs-${KFMIN}:5
- >=kde-frameworks/kcompletion-${KFMIN}:5
- >=kde-frameworks/kconfig-${KFMIN}:5
- >=kde-frameworks/kconfigwidgets-${KFMIN}:5
- >=kde-frameworks/kcoreaddons-${KFMIN}:5
- >=kde-frameworks/kcrash-${KFMIN}:5
- >=kde-frameworks/kdbusaddons-${KFMIN}:5
- >=kde-frameworks/kglobalaccel-${KFMIN}:5
- >=kde-frameworks/ki18n-${KFMIN}:5
- >=kde-frameworks/kiconthemes-${KFMIN}:5
- >=kde-frameworks/kidletime-${KFMIN}:5
- >=kde-frameworks/kio-${KFMIN}:5
- >=kde-frameworks/kitemviews-${KFMIN}:5
- >=kde-frameworks/knotifications-${KFMIN}:5
- >=kde-frameworks/knotifyconfig-${KFMIN}:5
- >=kde-frameworks/kparts-${KFMIN}:5
- >=kde-frameworks/kservice-${KFMIN}:5
- >=kde-frameworks/ktextwidgets-${KFMIN}:5
- >=kde-frameworks/kwallet-${KFMIN}:5
- >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
- >=kde-frameworks/kwindowsystem-${KFMIN}:5
- >=kde-frameworks/kxmlgui-${KFMIN}:5
- media-libs/phonon[qt5(+)]
- crypt? ( app-crypt/qca:2[qt5(+)] )
-"
-RDEPEND="${DEPEND}
- crypt? ( app-crypt/qca:2[ssl] )
-"
-
-PATCHES=(
- # 1.7 branch
- "${FILESDIR}"/${P}-fix-regex-for-cap-ack.patch
- "${FILESDIR}"/${P}-missing-header.patch
- "${FILESDIR}"/${P}-QElapsedTimer.patch
- "${FILESDIR}"/${P}-kf5windowsystem-5.63.patch
- # git master
- "${FILESDIR}"/${P}-kf5bookmarks-5.69.patch
- "${FILESDIR}"/${P}-unused-kemoticons.patch
- "${FILESDIR}"/${P}-qt-5.15.patch
-)
-
-src_configure() {
- local mycmakeargs=(
- $(cmake_use_find_package crypt Qca-qt5)
- )
-
- ecm_src_configure
-}
-
-src_install() {
- ecm_src_install
-
- # Bug 616162
- insinto /etc/xdg
- doins "${FILESDIR}"/konversationrc
-}