summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/restorecond/Manifest1
-rw-r--r--sys-apps/restorecond/restorecond-2.7_rc1.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/sys-apps/restorecond/Manifest b/sys-apps/restorecond/Manifest
new file mode 100644
index 000000000000..c8a691644112
--- /dev/null
+++ b/sys-apps/restorecond/Manifest
@@ -0,0 +1 @@
+DIST restorecond-2.7-rc1.tar.gz 17752 SHA256 af97d65094dd0b064325647e63130737b6fb077de1753e0b6d2d4c8060b938d5 SHA512 386d62a42237288fbe013bcc05ce9d6b46007ca3c9c0671fd53e60203fb0a92e7911d80a27591f068c8038f390af7bd39b6b75244f944684186e7766a19e2fbd WHIRLPOOL 06e6ad4afe94e49b6d3040235da052a4e0641c8054e6b80236cc84c04ed477eb71e1a276c03e1ef9c7025b670ac55014ba4b64df336fd9681d68bb96c0ead2b2
diff --git a/sys-apps/restorecond/restorecond-2.7_rc1.ebuild b/sys-apps/restorecond/restorecond-2.7_rc1.ebuild
new file mode 100644
index 000000000000..4af561e62e2f
--- /dev/null
+++ b/sys-apps/restorecond/restorecond-2.7_rc1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit toolchain-funcs
+
+MY_RELEASEDATE="20170609"
+
+MY_P="${P//_/-}"
+IUSE=""
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
+ S="${WORKDIR}/${MY_P}/${PN}"
+else
+ SRC_URI="https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/${MY_RELEASEDATE}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+DESCRIPTION="Daemon to watch for creation and set default SELinux fcontexts"
+HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND=">=sys-libs/libsepol-${PV}:=
+ >=sys-libs/libselinux-${PV}:=
+ dev-libs/libpcre:=
+ >=sys-libs/libcap-1.10-r10:="
+
+RDEPEND="${DEPEND}
+ !<sys-apps/policycoreutils-2.7_pre"
+
+src_prepare() {
+ default
+
+ sed -i 's/-Werror//g' "${S}"/Makefile || die "Failed to remove Werror"
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ LIBDIR="\$(PREFIX)/$(get_libdir)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ LIBDIR="\$(PREFIX)/$(get_libdir)" \
+ install
+
+ rm -rf "${D}/etc/rc.d" || die
+
+ newinitd "${FILESDIR}/restorecond.init" restorecond
+}