summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-im/skypeforlinux/Manifest1
-rw-r--r--net-im/skypeforlinux/skypeforlinux-8.79.0.95.ebuild99
2 files changed, 100 insertions, 0 deletions
diff --git a/net-im/skypeforlinux/Manifest b/net-im/skypeforlinux/Manifest
index 47ca3ca43e6d..f96cd08a172a 100644
--- a/net-im/skypeforlinux/Manifest
+++ b/net-im/skypeforlinux/Manifest
@@ -2,3 +2,4 @@ DIST skypeforlinux_8.75.0.140-1.x86_64.rpm 123300996 BLAKE2B a1b0d4696489be33721
DIST skypeforlinux_8.77.0.90-1.x86_64.rpm 123643165 BLAKE2B 12c578f99f482012f54d5f9faa2d017358376902aa6879fd35ce6eba1b16e3458d4831450574158c69436b9c6103a8dd00233451b56415542e2b6e81eb9346b8 SHA512 ee1fdae1ad10f1fba91886bea52eef261151463e184746af288150bebb69d4bf0dd87d0ac4030d8d11f86054f7b2cb663b8647ce795b1bf924f23c2b7559574b
DIST skypeforlinux_8.78.0.161-1.x86_64.rpm 123910012 BLAKE2B 560b9548f99d681c916e55a939659ab925096c7bd135a44cca99f12fa9fe913a1fbdbeaf584414e626215f313d09aec4320bfa2859892029c822b5adfc388f23 SHA512 fca1f839611d1ec46eebeacc0e90141a36fc305da90e02df1eecd529256e2609726d180b4839a2874973eb6f842bc332302f041b0b3be49293f64f2a18e7060f
DIST skypeforlinux_8.79.0.92-1.x86_64.rpm 117949890 BLAKE2B a7150c362f117096d554c446357789f51595ff403061f81adf8be3e59452b7bf7970ff10e2fe31413f793a0a137f8f0822fd6710932e9aea2197959ef2976cfa SHA512 2094870f227acb7e0a24af4d96d39bc0cf94ea0d3e5fb5907c75ad0ff6704c55882b104a306ad5d1e350c4adf5fd4f0d8444a9ddb07d7a39ef79a8cacd7faf3d
+DIST skypeforlinux_8.79.0.95-1.x86_64.rpm 118002157 BLAKE2B 0e836e3fd0c06bb5bd57d2806b3a51772e307a9555e573fdc366ebf1b82f2f8f1e422d64981f1973962d0ed1fa689c26482a48bf8193eedb65fe009056ff651c SHA512 eda292a1cd624c9a4819362820430769ead67f08113c66e58d6a4db17af4323f5483b6dadec41075b53feb25e7d7ef4c7ab738289246724678d2af9414fe58ad
diff --git a/net-im/skypeforlinux/skypeforlinux-8.79.0.95.ebuild b/net-im/skypeforlinux/skypeforlinux-8.79.0.95.ebuild
new file mode 100644
index 000000000000..9627b561f6f1
--- /dev/null
+++ b/net-im/skypeforlinux/skypeforlinux-8.79.0.95.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MULTILIB_COMPAT=( abi_x86_64 )
+
+inherit chromium-2 desktop pax-utils rpm multilib-build xdg
+
+DESCRIPTION="Instant messaging client, with support for audio and video"
+HOMEPAGE="https://www.skype.com/"
+SRC_URI="https://repo.skype.com/rpm/stable/${PN}_${PV}-1.x86_64.rpm"
+S="${WORKDIR}"
+
+LICENSE="Skype-TOS MIT MIT-with-advertising BSD-1 BSD-2 BSD Apache-2.0 Boost-1.0 ISC CC-BY-SA-3.0 CC0-1.0 openssl ZLIB APSL-2 icu Artistic-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+
+QA_PREBUILT="*"
+RESTRICT="mirror bindist strip" #299368
+
+RDEPEND="
+ app-crypt/libsecret[${MULTILIB_USEDEP}]
+ dev-libs/atk[${MULTILIB_USEDEP}]
+ dev-libs/expat[${MULTILIB_USEDEP}]
+ dev-libs/glib:2[${MULTILIB_USEDEP}]
+ dev-libs/nspr[${MULTILIB_USEDEP}]
+ dev-libs/nss[${MULTILIB_USEDEP}]
+ media-libs/alsa-lib[${MULTILIB_USEDEP}]
+ media-libs/fontconfig:1.0[${MULTILIB_USEDEP}]
+ media-libs/freetype:2[${MULTILIB_USEDEP}]
+ media-libs/libv4l[${MULTILIB_USEDEP}]
+ net-print/cups[${MULTILIB_USEDEP}]
+ sys-apps/dbus[${MULTILIB_USEDEP}]
+ sys-devel/gcc[cxx]
+ virtual/ttf-fonts
+ x11-libs/cairo[${MULTILIB_USEDEP}]
+ x11-libs/gdk-pixbuf:2[${MULTILIB_USEDEP}]
+ x11-libs/gtk+:3[${MULTILIB_USEDEP}]
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXScrnSaver[${MULTILIB_USEDEP}]
+ x11-libs/libXcomposite[${MULTILIB_USEDEP}]
+ x11-libs/libXcursor[${MULTILIB_USEDEP}]
+ x11-libs/libXdamage[${MULTILIB_USEDEP}]
+ x11-libs/libXext[${MULTILIB_USEDEP}]
+ x11-libs/libXfixes[${MULTILIB_USEDEP}]
+ x11-libs/libXi[${MULTILIB_USEDEP}]
+ x11-libs/libXrandr[${MULTILIB_USEDEP}]
+ x11-libs/libXrender[${MULTILIB_USEDEP}]
+ x11-libs/libXtst[${MULTILIB_USEDEP}]
+ x11-libs/libxcb[${MULTILIB_USEDEP}]
+ x11-libs/libxkbcommon[${MULTILIB_USEDEP}]
+ x11-libs/libxkbfile[${MULTILIB_USEDEP}]
+ x11-libs/pango[${MULTILIB_USEDEP}]"
+
+pkg_setup() {
+ chromium_suid_sandbox_check_kernel_config
+}
+
+src_unpack() {
+ rpm_src_unpack ${A}
+}
+
+src_prepare() {
+ default
+ sed -e "s!^SKYPE_PATH=.*!SKYPE_PATH=${EPREFIX}/opt/skypeforlinux/skypeforlinux!" \
+ -i usr/bin/skypeforlinux || die
+ sed -e "s!^Categories=.*!Categories=Network;InstantMessaging;Telephony;!" \
+ -e "/^OnlyShowIn=/d" \
+ -i usr/share/applications/skypeforlinux.desktop || die
+}
+
+src_install() {
+ dodir /opt
+ cp -a usr/share/skypeforlinux "${ED}"/opt || die
+
+ # remove chrome-sandbox binary, users should use kernel namespaces
+ # https://bugs.gentoo.org/692692#c18
+ rm "${ED}"/opt/skypeforlinux/chrome-sandbox || die
+
+ dobin usr/bin/skypeforlinux
+
+ dodoc usr/share/skypeforlinux/*.html
+ dodoc -r usr/share/doc/skypeforlinux/.
+ # symlink required for the "Help->3rd Party Notes" menu entry (otherwise frozen skype -> xdg-open)
+ dosym ${PF} usr/share/doc/skypeforlinux
+
+ doicon usr/share/pixmaps/skypeforlinux.png
+
+ local res
+ for res in 16 32 256 512; do
+ newicon -s ${res} usr/share/icons/hicolor/${res}x${res}/apps/skypeforlinux.png skypeforlinux.png
+ done
+
+ domenu usr/share/applications/skypeforlinux.desktop
+
+ pax-mark -m "${ED}"/opt/skypeforlinux/skypeforlinux
+ pax-mark -m "${ED}"/opt/skypeforlinux/resources/app.asar.unpacked/node_modules/slimcore/bin/slimcore.node
+}