summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-physics/geant-vmc/geant-vmc-4.4.0.ebuild7
-rw-r--r--sci-physics/geant-vmc/geant-vmc-9999.ebuild5
2 files changed, 9 insertions, 3 deletions
diff --git a/sci-physics/geant-vmc/geant-vmc-4.4.0.ebuild b/sci-physics/geant-vmc/geant-vmc-4.4.0.ebuild
index ae53bfcd41d1..83c2f0b1204e 100644
--- a/sci-physics/geant-vmc/geant-vmc-4.4.0.ebuild
+++ b/sci-physics/geant-vmc/geant-vmc-4.4.0.ebuild
@@ -31,6 +31,7 @@ RDEPEND="
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )"
RESTRICT="
+ !examples? ( test )
!geant3? ( test )
!g4root? ( test )
!mtroot? ( test )
@@ -77,8 +78,12 @@ src_test() {
# see e.g. https://sft.its.cern.ch/jira/browse/ROOT-8146 .
addwrite /dev/random
cd examples || die
+ # Bug: Can not disable Garfield in test suite, fixed upstream.
+ sed -i 's/ExGarfield//' test_suite.sh || die
+ # Bug: Path for E03 sub-examples wrong, see https://github.com/vmc-project/geant4_vmc/pull/11 .
+ sed -i 's#only in E03 test#only in E03 test\nG4EXEDIR=${BUILDDIR}/examples/$EXAMPLE/$OPTION#' test_suite_exe.sh || die
./test_suite.sh --g3=off --builddir="${BUILD_DIR}" || die
- ./test_suite_exe.sh --g3=off --builddir="${BUILD_DIR}" || die
+ ./test_suite_exe.sh --g3=off --garfield=off --builddir="${BUILD_DIR}" || die
}
src_install() {
diff --git a/sci-physics/geant-vmc/geant-vmc-9999.ebuild b/sci-physics/geant-vmc/geant-vmc-9999.ebuild
index ae53bfcd41d1..ffc8e7dc8743 100644
--- a/sci-physics/geant-vmc/geant-vmc-9999.ebuild
+++ b/sci-physics/geant-vmc/geant-vmc-9999.ebuild
@@ -31,6 +31,7 @@ RDEPEND="
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )"
RESTRICT="
+ !examples? ( test )
!geant3? ( test )
!g4root? ( test )
!mtroot? ( test )
@@ -77,8 +78,8 @@ src_test() {
# see e.g. https://sft.its.cern.ch/jira/browse/ROOT-8146 .
addwrite /dev/random
cd examples || die
- ./test_suite.sh --g3=off --builddir="${BUILD_DIR}" || die
- ./test_suite_exe.sh --g3=off --builddir="${BUILD_DIR}" || die
+ ./test_suite.sh --debug --g3=off --garfield=off --builddir="${BUILD_DIR}" || die
+ ./test_suite_exe.sh -debug --g3=off --garfield=off --builddir="${BUILD_DIR}" || die
}
src_install() {