summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--licenses/LOTW60
-rw-r--r--media-radio/tqsl/Manifest1
-rw-r--r--media-radio/tqsl/files/2.3.1-suffix.patch11
-rw-r--r--media-radio/tqsl/metadata.xml11
-rw-r--r--media-radio/tqsl/tqsl-2.3.1.ebuild38
5 files changed, 121 insertions, 0 deletions
diff --git a/licenses/LOTW b/licenses/LOTW
new file mode 100644
index 000000000000..c4ceeacff90f
--- /dev/null
+++ b/licenses/LOTW
@@ -0,0 +1,60 @@
+License Terms and Conditions
+
+Copyright (C) 2001-2015 American Radio Relay League, Inc. All rights
+reserved.
+
+Portions (C) 2003-2015 The TrustedQSL Developers. Please see the AUTHORS.txt
+file for contributors.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions
+are met:
+
+1. Any redistribution of source code must retain the above copyright
+notice, this list of conditions and the disclaimer shown in
+Paragraph 5 (below).
+
+2. Redistribution in binary form must reproduce the above copyright
+notice, this list of conditions and the disclaimer shown in
+Paragraph 5 (below) in the documentation and/or other materials
+provided with the distribution.
+
+3. Products derived from or including this software may not use
+"Logbook of the World" or "LoTW" or any other American Radio Relay
+League, Incorporated trademarks or servicemarks in their names
+without prior written permission of the ARRL. See Paragraph 6
+(below) for contact information.
+
+4. Use of this software does not imply endorsement by ARRL of
+products derived from or including this software and vendors may not
+claim such endorsement.
+
+5. Disclaimer: This software is provided "as-is" without
+representation, guarantee or warranty of any kind, either express or
+implied, including but not limited to the implied warranties of
+merchantability or of fitness for a particular purpose. The entire
+risk as to the quality and performance of the software is solely
+with you. Should the software prove defective, you (and not the
+American Radio Relay League, its officers, directors, employees or
+agents) assume the entire cost of all necessary servicing, repair or
+correction. In no event will ARRL be liable to you or to any third
+party for any damages, whether direct or indirect, including lost
+profits, lost savings, or other incidental or consequential damages
+arising out of the use or inability to use such software, regardless
+of whether ARRL has been advised of the possibility of such damages.
+
+6. Contact information:
+
+American Radio Relay League, Inc.
+Attn: Logbook of the World Manager
+225 Main St
+Newington, CT 06111
+voice: 860-594-0200
+fax: 860-594-0259
+email: logbook@arrl.org
+Worldwide Web: www.arrl.org
+
+This software consists of voluntary contributions made by many
+individuals on behalf of the ARRL. More information on the "Logbook
+of The World" project and the ARRL is available from the ARRL Web
+site at www.arrl.org.
diff --git a/media-radio/tqsl/Manifest b/media-radio/tqsl/Manifest
new file mode 100644
index 000000000000..df8e8de930d3
--- /dev/null
+++ b/media-radio/tqsl/Manifest
@@ -0,0 +1 @@
+DIST tqsl-2.3.1.tar.gz 2896807 BLAKE2B f2937950b5328cfb0a13b87797f40594799e01139d5b307199095b8cdbe6f4532e911fd9661ad3b663d8616d9287d8a359f2fefb4364c6450ba4be2505a89c63 SHA512 edaa21b1605bcb38790a66d61e1498a04f41c4f9b3b577908a6e57cd38e1ac2e1724e9c6d5421e0ca4a4ea72d1d5f5d54f08bf5a6c202bf68181ec12f27d4afd
diff --git a/media-radio/tqsl/files/2.3.1-suffix.patch b/media-radio/tqsl/files/2.3.1-suffix.patch
new file mode 100644
index 000000000000..e5d44dc7b856
--- /dev/null
+++ b/media-radio/tqsl/files/2.3.1-suffix.patch
@@ -0,0 +1,11 @@
+--- tqsl-2.3.1-orig/src/CMakeLists.txt
++++ tqsl-2.3.1/src/CMakeLists.txt
+@@ -54,7 +54,7 @@ include_directories(${OPENSSL_INCLUDE_DIR} ${ZLIB_INCLUDE_DIR} ${EXPAT_INCLUDE_D
+ if(NOT APPLE AND NOT WIN32)
+ set_source_files_properties(location.cpp PROPERTIES COMPILE_DEFINITIONS CONFDIR="${CMAKE_INSTALL_PREFIX}/share/TrustedQSL/")
+ set(HEADERS_TO_INSTALL tqsllib.h tqslerrno.h cabrillo.h adif.h tqslconvert.h)
+-install(TARGETS tqsllib DESTINATION lib$(LIB_SUFFIX))
++install(TARGETS tqsllib DESTINATION lib${LIB_SUFFIX})
+ install(FILES config.xml DESTINATION share/TrustedQSL)
+ install(FILES ${HEADERS_TO_INSTALL} DESTINATION include)
+ endif()
diff --git a/media-radio/tqsl/metadata.xml b/media-radio/tqsl/metadata.xml
new file mode 100644
index 000000000000..bd55a99244b3
--- /dev/null
+++ b/media-radio/tqsl/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>rich0@gentoo.org</email>
+ <description>Primary maintainer</description>
+</maintainer>
+<upstream>
+ <remote-id type="sourceforge">trustedqsl</remote-id>
+</upstream>
+</pkgmetadata>
diff --git a/media-radio/tqsl/tqsl-2.3.1.ebuild b/media-radio/tqsl/tqsl-2.3.1.ebuild
new file mode 100644
index 000000000000..8321f32ece32
--- /dev/null
+++ b/media-radio/tqsl/tqsl-2.3.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils cmake-utils wxwidgets
+
+DESCRIPTION="ARRL Logbook of the World"
+HOMEPAGE="http://www.arrl.org/tqsl-download"
+SRC_URI="mirror://sourceforge/trustedqsl/${P}.tar.gz"
+
+LICENSE="LOTW"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/expat:=
+ dev-libs/openssl:=
+ net-misc/curl:=
+ sys-libs/db:=
+ sys-libs/zlib:=
+ x11-libs/wxGTK:3.0="
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS.txt INSTALL README )
+HTML_DOCS=( html )
+
+WX_GTK_VER=3.0
+
+pkg_setup() {
+ setup-wxwidgets
+}
+
+src_prepare() {
+# Fix syntax file in makefile
+ eapply_user
+ epatch "${FILESDIR}/${PV}-suffix.patch"
+}